From: Satyam Sharma <satyam@infradead.org>
To: "Ken'ichi Ohmichi" <oomichi@mxs.nes.nec.co.jp>
Cc: Andrew Morton <akpm@linux-foundation.org>,
Adrian Bunk <bunk@kernel.org>,
kexec-ml <kexec@lists.infradead.org>,
lkml <linux-kernel@vger.kernel.org>,
David Rientjes <rientjes@google.com>,
Joe Perches <joe@perches.com>
Subject: Re: [PATCH 6/4] [-mm patch] use the existing offsetof().
Date: Thu, 20 Sep 2007 17:58:52 +0530 (IST) [thread overview]
Message-ID: <alpine.LFD.0.999.0709201752310.17093@enigma.security.iitk.ac.in> (raw)
In-Reply-To: <46F205DB.70209@mxs.nes.nec.co.jp>
On Thu, 20 Sep 2007, Ken'ichi Ohmichi wrote:
>
> [PATCH 6/4] [-mm patch] use the existing offsetof().
> It is better that offsetof() is used for VMCOREINFO_OFFSET().
> This idea is Joe Perches's.
>
>
>
> Thanks
> Ken'ichi Ohmichi
>
> ---
> Signed-off-by: Joe Perches <joe@perches.com>
Same deal here ...
> Signed-off-by: Ken'ichi Ohmichi <oomichi@mxs.nes.nec.co.jp>
> ---
> diff -rpuN a/include/linux/kexec.h b/include/linux/kexec.h
> --- a/include/linux/kexec.h 2007-09-18 15:23:22.000000000 +0900
> +++ b/include/linux/kexec.h 2007-09-18 15:27:29.000000000 +0900
> @@ -137,7 +137,7 @@ unsigned long paddr_vmcoreinfo_note(void
> (unsigned long)sizeof(struct name))
> #define VMCOREINFO_OFFSET(name, field) \
> vmcoreinfo_append_str("OFFSET(%s.%s)=%lu\n", #name, #field, \
> - (unsigned long)&(((struct name *)0)->field))
> + (unsigned long)offsetof(struct name, field))
> #define VMCOREINFO_LENGTH(name, value) \
> vmcoreinfo_append_str("LENGTH(%s)=%lu\n", #name, (unsigned long)value)
... and here. Use %zu and lose the casts.
BTW I don't think these macros are such a big win in readability or
code clarity anyway. And I noticed that there are still some open
calls to vmcoreinfo_append_str() in kexec.c (such as for the OS_RELEASE
case) which you haven't macro-ized ... we end up having code that looks
like:
vmcoreinfo_append_str(...);
...
...
VMCOREINFO_OFFSET(...);
...
and it's not even obvious (unless you follow on to the definition of the
later macro) that the above two are *exactly* the same. So you could also
consider just losing the macros altogether.
Satyam
next prev parent reply other threads:[~2007-09-20 12:26 UTC|newest]
Thread overview: 17+ messages / expand[flat|nested] mbox.gz Atom feed top
2007-09-14 2:49 [PATCH 0/4] [-mm patch] Cleanup add-vmcoreinfo.patch v2 Ken'ichi Ohmichi
2007-09-14 2:53 ` [PATCH 1/4] [-mm patch] Cleanup the coding style according to Andrew's comments Ken'ichi Ohmichi
2007-09-14 2:56 ` [PATCH 2/4] [-mm patch] Add nodemask_t's size and NR_FREE_PAGES's value to vmcoreinfo_data Ken'ichi Ohmichi
2007-09-14 3:36 ` David Rientjes
2007-09-20 5:16 ` Ken'ichi Ohmichi
2007-09-14 2:58 ` [PATCH 3/4] [-mm patch] Use the existing ia64_tpa() instead of asm code Ken'ichi Ohmichi
2007-09-14 3:00 ` [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros Ken'ichi Ohmichi
2007-09-15 2:03 ` Andrew Morton
2007-09-20 5:28 ` Ken'ichi Ohmichi
2007-09-20 5:30 ` [PATCH 5/4] [-mm patch] Rename macros returning the size Ken'ichi Ohmichi
2007-09-20 12:21 ` Satyam Sharma
2007-09-20 18:40 ` David Rientjes
2007-09-25 8:49 ` Ken'ichi Ohmichi
2007-09-20 5:32 ` [PATCH 6/4] [-mm patch] use the existing offsetof() Ken'ichi Ohmichi
2007-09-20 12:28 ` Satyam Sharma [this message]
2007-09-25 8:50 ` Ken'ichi Ohmichi
2007-09-25 8:59 ` [PATCH 4/4] [-mm patch] Add a prefix "VMCOREINFO_" to the vmcoreinfo macros Ken'ichi Ohmichi
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.LFD.0.999.0709201752310.17093@enigma.security.iitk.ac.in \
--to=satyam@infradead.org \
--cc=akpm@linux-foundation.org \
--cc=bunk@kernel.org \
--cc=joe@perches.com \
--cc=kexec@lists.infradead.org \
--cc=linux-kernel@vger.kernel.org \
--cc=oomichi@mxs.nes.nec.co.jp \
--cc=rientjes@google.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®