From: Stafford Horne <shorne@gmail.com>
To: Jonas Bonn <jonas@southpole.se>,
Stefan Kristiansson <stefan.kristiansson@saunalahti.fi>
Cc: linux@roeck-us.net, openrisc@lists.librecores.org,
linux-kernel@vger.kernel.org,
Sebastian Macke <sebastian@macke.de>,
Stafford Horne <shorne@gmail.com>
Subject: [PATCH v4 12/24] openrisc: Fix the bitmask for the unit present register
Date: Fri, 24 Feb 2017 13:32:32 +0900 [thread overview]
Message-ID: <4812c836e956dbc7e10b15d6dcce2f2a2aff4748.1487910170.git.shorne@gmail.com> (raw)
In-Reply-To: <cover.1487910170.git.shorne@gmail.com>
In-Reply-To: <cover.1487910170.git.shorne@gmail.com>
From: Sebastian Macke <sebastian@macke.de>
The bits were swapped, as per spec and processor implementation the
power management present bit is 9 and PIC bit is 8. This patch brings
the definitions into spec.
Signed-off-by: Sebastian Macke <sebastian@macke.de>
[shorne@gmail.com: Added commit body]
Signed-off-by: Stafford Horne <shorne@gmail.com>
---
arch/openrisc/include/asm/spr_defs.h | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/arch/openrisc/include/asm/spr_defs.h b/arch/openrisc/include/asm/spr_defs.h
index 5dbc668..367dac7 100644
--- a/arch/openrisc/include/asm/spr_defs.h
+++ b/arch/openrisc/include/asm/spr_defs.h
@@ -152,8 +152,8 @@
#define SPR_UPR_MP 0x00000020 /* MAC present */
#define SPR_UPR_DUP 0x00000040 /* Debug unit present */
#define SPR_UPR_PCUP 0x00000080 /* Performance counters unit present */
-#define SPR_UPR_PMP 0x00000100 /* Power management present */
-#define SPR_UPR_PICP 0x00000200 /* PIC present */
+#define SPR_UPR_PICP 0x00000100 /* PIC present */
+#define SPR_UPR_PMP 0x00000200 /* Power management present */
#define SPR_UPR_TTP 0x00000400 /* Tick timer present */
#define SPR_UPR_RES 0x00fe0000 /* Reserved */
#define SPR_UPR_CUP 0xff000000 /* Context units present */
--
2.9.3
next prev parent reply other threads:[~2017-02-24 4:34 UTC|newest]
Thread overview: 46+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-02-24 4:32 [PATCH v4 00/24] OpenRISC patches for 4.11 Stafford Horne
2017-02-24 4:32 ` [PATCH v4 01/24] openrisc: use SPARSE_IRQ Stafford Horne
2017-02-24 4:32 ` [PATCH v4 02/24] openrisc: add cache way information to cpuinfo Stafford Horne
2017-02-24 4:32 ` [PATCH v4 03/24] openrisc: tlb miss handler optimizations Stafford Horne
2017-02-24 4:32 ` [PATCH v4 04/24] openrisc: head: use THREAD_SIZE instead of magic constant Stafford Horne
2017-02-24 4:32 ` [PATCH v4 05/24] openrisc: head: refactor out tlb flush into it's own function Stafford Horne
2017-02-24 9:57 ` Jonas Bonn
2017-02-24 10:54 ` Stefan Kristiansson
2017-02-24 12:48 ` Jonas Bonn
2017-02-24 13:54 ` Stefan Kristiansson
2017-02-24 19:20 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 06/24] openrisc: add l.lwa/l.swa emulation Stafford Horne
2017-02-24 9:27 ` Jonas Bonn
2017-02-24 19:53 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 07/24] openrisc: add atomic bitops Stafford Horne
2017-02-24 10:56 ` Peter Zijlstra
2017-02-24 19:16 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 08/24] openrisc: add cmpxchg and xchg implementations Stafford Horne
2017-02-24 4:32 ` [PATCH v4 09/24] openrisc: add optimized atomic operations Stafford Horne
2017-02-24 4:32 ` [PATCH v4 10/24] openrisc: add futex_atomic_* implementations Stafford Horne
2017-02-24 4:32 ` [PATCH v4 11/24] openrisc: remove unnecessary stddef.h include Stafford Horne
2017-02-24 4:32 ` Stafford Horne [this message]
2017-02-24 4:32 ` [PATCH v4 13/24] openrisc: Initial support for the idle state Stafford Horne
2017-02-24 4:32 ` [PATCH v4 14/24] openrisc: Add optimized memset Stafford Horne
2017-02-24 4:32 ` [PATCH v4 15/24] openrisc: Add optimized memcpy routine Stafford Horne
2017-02-24 4:32 ` [PATCH v4 16/24] openrisc: Add .gitignore Stafford Horne
2017-02-24 4:32 ` [PATCH v4 17/24] MAINTAINERS: Add the openrisc official repository Stafford Horne
2017-02-24 4:32 ` [PATCH v4 18/24] scripts/checkstack.pl: Add openrisc support Stafford Horne
2017-02-24 14:42 ` Tobias Klauser
2017-02-24 19:33 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 19/24] openrisc: entry: Whitespace and comment cleanups Stafford Horne
2017-02-24 9:45 ` Jonas Bonn
2017-02-24 20:31 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 20/24] openrisc: entry: Fix delay slot detection Stafford Horne
2017-02-24 9:32 ` Jonas Bonn
2017-02-24 20:13 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 21/24] openrisc: head: Move init strings to rodata section Stafford Horne
2017-02-24 9:28 ` Jonas Bonn
2017-02-24 20:09 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 22/24] arch/openrisc/lib/memcpy.c: use correct OR1200 option Stafford Horne
2017-02-24 9:24 ` Jonas Bonn
2017-02-24 19:44 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 23/24] openrisc: Export ioremap symbols used by modules Stafford Horne
2017-02-24 4:32 ` [PATCH v4 24/24] openrisc: head: Init r0 to 0 on start Stafford Horne
2017-02-24 9:21 ` Jonas Bonn
2017-02-24 19:35 ` Stafford Horne
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4812c836e956dbc7e10b15d6dcce2f2a2aff4748.1487910170.git.shorne@gmail.com \
--to=shorne@gmail.com \
--cc=jonas@southpole.se \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=openrisc@lists.librecores.org \
--cc=sebastian@macke.de \
--cc=stefan.kristiansson@saunalahti.fi \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®