From: Stafford Horne <shorne@gmail.com>
To: Jonas Bonn <jonas@southpole.se>,
Stefan Kristiansson <stefan.kristiansson@saunalahti.fi>
Cc: linux@roeck-us.net, openrisc@lists.librecores.org,
linux-kernel@vger.kernel.org,
Peter Zijlstra <peterz@infradead.org>,
Stafford Horne <shorne@gmail.com>, Arnd Bergmann <arnd@arndb.de>,
linux-arch@vger.kernel.org
Subject: [PATCH v4 09/24] openrisc: add optimized atomic operations
Date: Fri, 24 Feb 2017 13:32:29 +0900 [thread overview]
Message-ID: <e66970354310182a74334d3bc2181ad86f9e8524.1487910170.git.shorne@gmail.com> (raw)
In-Reply-To: <cover.1487910170.git.shorne@gmail.com>
In-Reply-To: <cover.1487910170.git.shorne@gmail.com>
From: Stefan Kristiansson <stefan.kristiansson@saunalahti.fi>
Using the l.lwa and l.swa atomic instruction pair.
Most openrisc processor cores provide these instructions now. If the
instructions are not available emulation is provided.
Cc: Peter Zijlstra <peterz@infradead.org>
Signed-off-by: Stefan Kristiansson <stefan.kristiansson@saunalahti.fi>
[shorne@gmail.com: remove OPENRISC_HAVE_INST_LWA_SWA config suggesed by
Alan Cox https://lkml.org/lkml/2014/7/23/666]
[shorne@gmail.com: expand to implement all ops suggested by Peter
Zijlstra https://lkml.org/lkml/2017/2/20/317]
Signed-off-by: Stafford Horne <shorne@gmail.com>
---
arch/openrisc/include/asm/Kbuild | 1 -
arch/openrisc/include/asm/atomic.h | 126 +++++++++++++++++++++++++++++++++++++
include/asm-generic/atomic.h | 2 +
3 files changed, 128 insertions(+), 1 deletion(-)
create mode 100644 arch/openrisc/include/asm/atomic.h
diff --git a/arch/openrisc/include/asm/Kbuild b/arch/openrisc/include/asm/Kbuild
index 15e6ed5..1cedd63 100644
--- a/arch/openrisc/include/asm/Kbuild
+++ b/arch/openrisc/include/asm/Kbuild
@@ -1,7 +1,6 @@
header-y += ucontext.h
-generic-y += atomic.h
generic-y += auxvec.h
generic-y += barrier.h
generic-y += bitsperlong.h
diff --git a/arch/openrisc/include/asm/atomic.h b/arch/openrisc/include/asm/atomic.h
new file mode 100644
index 0000000..146e166
--- /dev/null
+++ b/arch/openrisc/include/asm/atomic.h
@@ -0,0 +1,126 @@
+/*
+ * Copyright (C) 2014 Stefan Kristiansson <stefan.kristiansson@saunalahti.fi>
+ *
+ * This file is licensed under the terms of the GNU General Public License
+ * version 2. This program is licensed "as is" without any warranty of any
+ * kind, whether express or implied.
+ */
+
+#ifndef __ASM_OPENRISC_ATOMIC_H
+#define __ASM_OPENRISC_ATOMIC_H
+
+#include <linux/types.h>
+
+/* Atomically perform op with v->counter and i */
+#define ATOMIC_OP(op) \
+static inline void atomic_##op(int i, atomic_t *v) \
+{ \
+ int tmp; \
+ \
+ __asm__ __volatile__( \
+ "1: l.lwa %0,0(%1) \n" \
+ " l." #op " %0,%0,%2 \n" \
+ " l.swa 0(%1),%0 \n" \
+ " l.bnf 1b \n" \
+ " l.nop \n" \
+ : "=&r"(tmp) \
+ : "r"(&v->counter), "r"(i) \
+ : "cc", "memory"); \
+}
+
+/* Atomically perform op with v->counter and i, return the result */
+#define ATOMIC_OP_RETURN(op) \
+static inline int atomic_##op##_return(int i, atomic_t *v) \
+{ \
+ int tmp; \
+ \
+ __asm__ __volatile__( \
+ "1: l.lwa %0,0(%1) \n" \
+ " l." #op " %0,%0,%2 \n" \
+ " l.swa 0(%1),%0 \n" \
+ " l.bnf 1b \n" \
+ " l.nop \n" \
+ : "=&r"(tmp) \
+ : "r"(&v->counter), "r"(i) \
+ : "cc", "memory"); \
+ \
+ return tmp; \
+}
+
+/* Atomically perform op with v->counter and i, return orig v->counter */
+#define ATOMIC_FETCH_OP(op) \
+static inline int atomic_fetch_##op(int i, atomic_t *v) \
+{ \
+ int tmp, old; \
+ \
+ __asm__ __volatile__( \
+ "1: l.lwa %0,0(%2) \n" \
+ " l." #op " %1,%0,%3 \n" \
+ " l.swa 0(%2),%1 \n" \
+ " l.bnf 1b \n" \
+ " l.nop \n" \
+ : "=&r"(old), "=&r"(tmp) \
+ : "r"(&v->counter), "r"(i) \
+ : "cc", "memory"); \
+ \
+ return old; \
+}
+
+ATOMIC_OP_RETURN(add)
+ATOMIC_OP_RETURN(sub)
+
+ATOMIC_FETCH_OP(add)
+ATOMIC_FETCH_OP(sub)
+ATOMIC_FETCH_OP(and)
+ATOMIC_FETCH_OP(or)
+ATOMIC_FETCH_OP(xor)
+
+ATOMIC_OP(and)
+ATOMIC_OP(or)
+ATOMIC_OP(xor)
+
+#undef ATOMIC_FETCH_OP
+#undef ATOMIC_OP_RETURN
+#undef ATOMIC_OP
+
+#define atomic_add_return atomic_add_return
+#define atomic_sub_return atomic_sub_return
+#define atomic_fetch_add atomic_fetch_add
+#define atomic_fetch_sub atomic_fetch_sub
+#define atomic_fetch_and atomic_fetch_and
+#define atomic_fetch_or atomic_fetch_or
+#define atomic_fetch_xor atomic_fetch_xor
+#define atomic_and atomic_and
+#define atomic_or atomic_or
+#define atomic_xor atomic_xor
+
+/*
+ * Atomically add a to v->counter as long as v is not already u.
+ * Returns the original value at v->counter.
+ *
+ * This is often used through atomic_inc_not_zero()
+ */
+static inline int __atomic_add_unless(atomic_t *v, int a, int u)
+{
+ int old, tmp;
+
+ __asm__ __volatile__(
+ "1: l.lwa %0, 0(%2) \n"
+ " l.sfeq %0, %4 \n"
+ " l.bf 2f \n"
+ " l.add %1, %0, %3 \n"
+ " l.swa 0(%2), %1 \n"
+ " l.bnf 1b \n"
+ " l.nop \n"
+ "2: \n"
+ : "=&r"(old), "=&r" (tmp)
+ : "r"(&v->counter), "r"(a), "r"(u)
+ : "cc", "memory");
+
+ return old;
+}
+#define __atomic_add_unless __atomic_add_unless
+
+#include <asm-generic/atomic.h>
+
+#endif /* __ASM_OPENRISC_ATOMIC_H */
diff --git a/include/asm-generic/atomic.h b/include/asm-generic/atomic.h
index 9ed8b98..3f38eb0 100644
--- a/include/asm-generic/atomic.h
+++ b/include/asm-generic/atomic.h
@@ -223,6 +223,7 @@ static inline void atomic_dec(atomic_t *v)
#define atomic_xchg(ptr, v) (xchg(&(ptr)->counter, (v)))
#define atomic_cmpxchg(v, old, new) (cmpxchg(&((v)->counter), (old), (new)))
+#ifndef __atomic_add_unless
static inline int __atomic_add_unless(atomic_t *v, int a, int u)
{
int c, old;
@@ -231,5 +232,6 @@ static inline int __atomic_add_unless(atomic_t *v, int a, int u)
c = old;
return c;
}
+#endif
#endif /* __ASM_GENERIC_ATOMIC_H */
--
2.9.3
next prev parent reply other threads:[~2017-02-24 4:34 UTC|newest]
Thread overview: 46+ messages / expand[flat|nested] mbox.gz Atom feed top
2017-02-24 4:32 [PATCH v4 00/24] OpenRISC patches for 4.11 Stafford Horne
2017-02-24 4:32 ` [PATCH v4 01/24] openrisc: use SPARSE_IRQ Stafford Horne
2017-02-24 4:32 ` [PATCH v4 02/24] openrisc: add cache way information to cpuinfo Stafford Horne
2017-02-24 4:32 ` [PATCH v4 03/24] openrisc: tlb miss handler optimizations Stafford Horne
2017-02-24 4:32 ` [PATCH v4 04/24] openrisc: head: use THREAD_SIZE instead of magic constant Stafford Horne
2017-02-24 4:32 ` [PATCH v4 05/24] openrisc: head: refactor out tlb flush into it's own function Stafford Horne
2017-02-24 9:57 ` Jonas Bonn
2017-02-24 10:54 ` Stefan Kristiansson
2017-02-24 12:48 ` Jonas Bonn
2017-02-24 13:54 ` Stefan Kristiansson
2017-02-24 19:20 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 06/24] openrisc: add l.lwa/l.swa emulation Stafford Horne
2017-02-24 9:27 ` Jonas Bonn
2017-02-24 19:53 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 07/24] openrisc: add atomic bitops Stafford Horne
2017-02-24 10:56 ` Peter Zijlstra
2017-02-24 19:16 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 08/24] openrisc: add cmpxchg and xchg implementations Stafford Horne
2017-02-24 4:32 ` Stafford Horne [this message]
2017-02-24 4:32 ` [PATCH v4 10/24] openrisc: add futex_atomic_* implementations Stafford Horne
2017-02-24 4:32 ` [PATCH v4 11/24] openrisc: remove unnecessary stddef.h include Stafford Horne
2017-02-24 4:32 ` [PATCH v4 12/24] openrisc: Fix the bitmask for the unit present register Stafford Horne
2017-02-24 4:32 ` [PATCH v4 13/24] openrisc: Initial support for the idle state Stafford Horne
2017-02-24 4:32 ` [PATCH v4 14/24] openrisc: Add optimized memset Stafford Horne
2017-02-24 4:32 ` [PATCH v4 15/24] openrisc: Add optimized memcpy routine Stafford Horne
2017-02-24 4:32 ` [PATCH v4 16/24] openrisc: Add .gitignore Stafford Horne
2017-02-24 4:32 ` [PATCH v4 17/24] MAINTAINERS: Add the openrisc official repository Stafford Horne
2017-02-24 4:32 ` [PATCH v4 18/24] scripts/checkstack.pl: Add openrisc support Stafford Horne
2017-02-24 14:42 ` Tobias Klauser
2017-02-24 19:33 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 19/24] openrisc: entry: Whitespace and comment cleanups Stafford Horne
2017-02-24 9:45 ` Jonas Bonn
2017-02-24 20:31 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 20/24] openrisc: entry: Fix delay slot detection Stafford Horne
2017-02-24 9:32 ` Jonas Bonn
2017-02-24 20:13 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 21/24] openrisc: head: Move init strings to rodata section Stafford Horne
2017-02-24 9:28 ` Jonas Bonn
2017-02-24 20:09 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 22/24] arch/openrisc/lib/memcpy.c: use correct OR1200 option Stafford Horne
2017-02-24 9:24 ` Jonas Bonn
2017-02-24 19:44 ` Stafford Horne
2017-02-24 4:32 ` [PATCH v4 23/24] openrisc: Export ioremap symbols used by modules Stafford Horne
2017-02-24 4:32 ` [PATCH v4 24/24] openrisc: head: Init r0 to 0 on start Stafford Horne
2017-02-24 9:21 ` Jonas Bonn
2017-02-24 19:35 ` Stafford Horne
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=e66970354310182a74334d3bc2181ad86f9e8524.1487910170.git.shorne@gmail.com \
--to=shorne@gmail.com \
--cc=arnd@arndb.de \
--cc=jonas@southpole.se \
--cc=linux-arch@vger.kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux@roeck-us.net \
--cc=openrisc@lists.librecores.org \
--cc=peterz@infradead.org \
--cc=stefan.kristiansson@saunalahti.fi \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®