mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: "Jan Beulich" <JBeulich@suse.com>
To: "Frederic Weisbecker" <fweisbec@gmail.com>,
	"Denys Vlasenko" <vda.linux@googlemail.com>
Cc: "Andy Lutomirski" <luto@amacapital.net>,
	"Kees Cook" <keescook@chromium.org>,
	"Will Drewry" <wad@chromium.org>, "X86 ML" <x86@kernel.org>,
	"Alexei Starovoitov" <ast@plumgrid.com>,
	"Denys Vlasenko" <dvlasenk@redhat.com>,
	"Oleg Nesterov" <oleg@redhat.com>,
	"Linux Kernel Mailing List" <linux-kernel@vger.kernel.org>,
	"H. Peter Anvin" <hpa@zytor.com>
Subject: Re: [PATCH 4/5] x86: entry_64.S: always allocate complete "struct pt_regs"
Date: Mon, 11 Aug 2014 09:40:35 +0100	[thread overview]
Message-ID: <53E89DA3020000780002B00B@mail.emea.novell.com> (raw)
In-Reply-To: <20140811004559.GA2656@lerouge>

>>> On 11.08.14 at 02:46, <fweisbec@gmail.com> wrote:
> On Mon, Aug 04, 2014 at 05:03:42AM +0200, Denys Vlasenko wrote:
>> On Sat, Aug 2, 2014 at 1:19 AM, Frederic Weisbecker <fweisbec@gmail.com> 
> wrote:
>> >>       CFI_ESCAPE      0x0f /* DW_CFA_def_cfa_expression */, 6, \
>> >>                       0x77 /* DW_OP_breg7 */, 0, \
>> >>                       0x06 /* DW_OP_deref */, \
>> >> -                     0x08 /* DW_OP_const1u */, SS+8-RBP, \
>> >> +                     0x08 /* DW_OP_const1u */, SS+8, \
>> >>                       0x22 /* DW_OP_plus */
>> >>       /* We entered an interrupt context - irqs are off: */
>> >>       TRACE_IRQS_OFF
>> >> -
>> >>       call \func
>> >>       .endm
>> >>
>> >> @@ -749,10 +719,9 @@ ret_from_intr:
>> >>
>> >>       /* Restore saved previous stack */
>> >>       popq %rsi
>> >
>> > And then you pop to rsi. Ok that indeed works but perhaps we should keep it symetrical
>> > just for clarity? Any reason why we can't reuse rdi here?
>> 
>> I changed this entire area in v2: basically, I will not change the logic,
>> but will add comments explaining what are we doing here, and why.
>> (Some minor code changes will be done, not affecting the logic).
>> 
>> While we are at it, what this  CFI_ESCAPE thing does here?
>> As usual, it has no comment :/

Each of its lines has a comment; with other CFI annotations not
each having comments, I don't see what else is needed here.

> I don't know, only Jan Beulich understands those CFI black magic.

That would be very said if true.

In any case: This needs to be a CFI_ESCAPE because there's no
other way I know of to emit the DW_CFA_def_cfa_expression.
And the change to it looks correct to me.

Jan


  reply	other threads:[~2014-08-11  8:40 UTC|newest]

Thread overview: 41+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2014-08-01 14:48 [PATCH 1/5] x86: entry_64.S: delete unused code Denys Vlasenko
2014-08-01 14:48 ` [PATCH 2/5] x86: open-code register save/restore in trace_hardirqs thunks Denys Vlasenko
2014-08-01 14:48 ` [PATCH 3/5] x86: entry_64.S: fold SAVE_ARGS_IRQ macro into its sole user Denys Vlasenko
2014-08-01 18:30   ` Frederic Weisbecker
2014-08-01 14:48 ` [PATCH 4/5] x86: entry_64.S: always allocate complete "struct pt_regs" Denys Vlasenko
2014-08-01 17:04   ` Andy Lutomirski
2014-08-04 14:28     ` Denys Vlasenko
2014-08-04 14:47       ` Oleg Nesterov
2014-08-04 15:34         ` Oleg Nesterov
2014-08-04 21:03       ` Andy Lutomirski
2014-08-04 21:23         ` Borislav Petkov
2014-08-05 10:35         ` Denys Vlasenko
2014-08-05 14:53           ` Andy Lutomirski
2014-08-05 15:17             ` Denys Vlasenko
2014-08-05 23:02               ` Andy Lutomirski
2014-08-07  9:54             ` Denys Vlasenko
2014-08-01 18:09   ` Alexei Starovoitov
2014-08-01 18:30   ` Oleg Nesterov
2014-08-01 18:35   ` H. Peter Anvin
2014-08-01 22:11     ` Denys Vlasenko
2014-08-01 22:13       ` H. Peter Anvin
2014-08-02 21:14         ` Andy Lutomirski
2014-08-02 21:23           ` H. Peter Anvin
2014-08-02 21:38             ` Andy Lutomirski
2014-08-01 22:52   ` Frederic Weisbecker
2014-08-01 23:19   ` Frederic Weisbecker
2014-08-04  3:03     ` Denys Vlasenko
2014-08-04  7:57       ` Borislav Petkov
2014-08-11  0:46       ` Frederic Weisbecker
2014-08-11  8:40         ` Jan Beulich [this message]
2014-08-11  9:07           ` Andy Lutomirski
2014-08-11  9:31             ` Jan Beulich
2014-08-11 13:26           ` Denys Vlasenko
2014-08-11 14:17             ` Jan Beulich
2014-08-11 14:53               ` H. Peter Anvin
2014-08-11 15:08                 ` Jan Beulich
2014-08-11 15:13                   ` H. Peter Anvin
2014-08-12  9:31                     ` Denys Vlasenko
2014-08-12  9:50                       ` Jan Beulich
2014-08-01 14:48 ` [PATCH 5/5] x86: mass removal of ARGOFFSET Denys Vlasenko
2014-08-01 18:00 ` [PATCH 1/5] x86: entry_64.S: delete unused code Frederic Weisbecker

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=53E89DA3020000780002B00B@mail.emea.novell.com \
    --to=jbeulich@suse.com \
    --cc=ast@plumgrid.com \
    --cc=dvlasenk@redhat.com \
    --cc=fweisbec@gmail.com \
    --cc=hpa@zytor.com \
    --cc=keescook@chromium.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=luto@amacapital.net \
    --cc=oleg@redhat.com \
    --cc=vda.linux@googlemail.com \
    --cc=wad@chromium.org \
    --cc=x86@kernel.org \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®