mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Reinette Chatre <reinette.chatre@intel.com>
To: Dave Martin <Dave.Martin@arm.com>
Cc: James Morse <james.morse@arm.com>, <x86@kernel.org>,
	<linux-kernel@vger.kernel.org>, Fenghua Yu <fenghua.yu@intel.com>,
	"Thomas Gleixner" <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, "Borislav Petkov" <bp@alien8.de>,
	H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
	<shameerali.kolothum.thodi@huawei.com>,
	"D Scott Phillips OS" <scott@os.amperecomputing.com>,
	<carl@os.amperecomputing.com>, <lcherian@marvell.com>,
	<bobo.shaobowang@huawei.com>, <tan.shaopeng@fujitsu.com>,
	<baolin.wang@linux.alibaba.com>,
	Jamie Iles <quic_jiles@quicinc.com>,
	Xin Hao <xhao@linux.alibaba.com>, <peternewman@google.com>,
	<dfustini@baylibre.com>, <amitsinght@marvell.com>,
	David Hildenbrand <david@redhat.com>,
	Rex Nie <rex.nie@jaguarmicro.com>
Subject: Re: [PATCH v1 08/31] x86/resctrl: Move resctrl types to a separate header
Date: Fri, 19 Apr 2024 20:59:52 -0700	[thread overview]
Message-ID: <7e44410a-895a-4364-82b5-2fc21c88f892@intel.com> (raw)
In-Reply-To: <ZiE7gritCvxF1XS5@e133380.arm.com>

Hi Dave,

On 4/18/2024 8:25 AM, Dave Martin wrote:
> On Wed, Apr 17, 2024 at 10:15:57PM -0700, Reinette Chatre wrote:
>> On 4/16/2024 9:19 AM, Dave Martin wrote:
>>> On Mon, Apr 15, 2024 at 11:03:05AM -0700, Reinette Chatre wrote:
>>>> On 4/12/2024 9:17 AM, Dave Martin wrote:
>>>>> On Mon, Apr 08, 2024 at 08:18:00PM -0700, Reinette Chatre
>>>>> wrote:
>>>>>> On 3/21/2024 9:50 AM, James Morse wrote:
>>>>>>> To avoid sticky problems in the mpam glue code, move the
>>>>>>> resctrl enums into a separate header.
>>>>>> 
>>>>>> Could you please elaborate so that "sticky problems in the
>>>>>> mpam glue code" is specific about what problems are
>>>>>> avoided?
>>>>> 
>>>>> Maybe just delete the the sticky clause, and leave:
>>>>> 
>>>>> Move the resctrl enums into a separate header.
>>>>> 
>>>>> ...since the next paragraph explains the rationale?
>>>> 
>>>> In the x86 area changelogs start with a context paragraph to 
>>>> provide reader with foundation to parse the subsequent problem
>>>> and solution statements (that are also expected to be in
>>>> separate paragraphs in that order).
>>> 
>>> Acknowledged; I was hoping to avoid a rewrite, but ...
>>>> 
>>>>>>> This lets the arch code declare prototypes that use these
>>>>>>> enums without creating a loop via asm<->linux resctrl.h
>>>>>>> The same logic applies to the monitor-configuration
>>>>>>> defines, move these too.
>>> 
>>> [...]
>>> 
>>> OK, how about the following:
>>> 
>>> --8<--
>>> 
>>> When resctrl is fully factored into core and per-arch code, each
>>> arch will need to use some resctrl common definitions in order to
>>> define its own specialisations and helpers.  Following
>>> conventional practice,
>> 
>> specializations
> 
> Debatable, but OK, fine.

ah British spelling, apologies.

> 
>>> it would be desirable to put the dependent arch definitions in
>>> an <asm/resctrl.h> header that is included by the common
>>> <linux/resctrl.h> header.  However, this can make it awkward to
>>> avoid a circular dependency between <linux/resctrl.h> and the
>>> arch header.
>>> 
>>> To avoid solving this issue via conditional inclusion tricks that
>>> are likely to be tricky to maintain, move the affected common
>>> types and
>> 
>> To help with motivation please be specific (somebody may interpret
>> above that it may not be tricky to maintain). So just ... "that are
>> difficult to maintain ...".
> 
> Rather than the text encouraging questions about whether there are 
> reasonable alternative approaches, perhaps this can just be, simply:
> 
> "To avoid such dependencies, move the affected types into a new 
> header [...]"
> 
> ?

Sure.

> 
>> 
>>> constants into a new header that does not need to depend on 
>>> <linux/resctrl.h> or on the arch headers.
>>> 
>>> The same logic applies to the monitor-configuration defines,
>>> move these too.
>>> 
>>> -->8--
>>> 
>> 
>> This explains the motivation for this file well, but its contents 
>> is not obvious to me and after reading [1] I am more weary of
>> including code before use. Not all of these definitions are needed 
>> by the end of this series so there needs to be a good motivation
>> for making things global without any visible user.
> 
> That's fair.  I guess we need to review the contents of this header
> and make sure that everything that's here really should be here.
> 
> However, this is not user ABI and there are only 1.5 users of this 
> interface (given that MPAM is not yet merged).  So, the penalty for 
> not getting this quite right and fixing it later seems low.
> 
> If you agree that adding this header is appropriate, are you OK with 
> some post-merge cleanup, or do you think it's essential to sanitise
> this fully up-front?
> 

I think you may have sent this before your response to patch #17 where you
are talking about keeping some definitions x86 specific until their usage is
clear.

I understand this is not user ABI and as I also stated previously I recognize
that these changes are easier now than later when changes need to cross two
subsystems. I do not think the goal should be to have the perfect header file
but I would like to understand why each definition in it needs to be global.

Unfortunately, based on learnings during the four year history of this work,
I do not have confidence that there will be post-merge cleanup. 

Reinette

  reply	other threads:[~2024-04-20  3:59 UTC|newest]

Thread overview: 179+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-03-21 16:50 [PATCH v1 00/31] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2024-03-21 16:50 ` [PATCH v1 01/31] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2024-04-09  3:13   ` Reinette Chatre
2024-04-11 14:13     ` Dave Martin
2024-04-09  8:05   ` David Hildenbrand
2024-04-09 15:02     ` Reinette Chatre
2024-04-09 15:06       ` David Hildenbrand
2024-04-11 15:02         ` Dave Martin
2024-04-11 14:13     ` Dave Martin
2024-04-11 17:35       ` Reinette Chatre
2024-04-12 16:17         ` Dave Martin
2024-04-15 20:27   ` Moger, Babu
2024-04-16 16:13     ` Dave Martin
2024-04-16 20:33       ` Moger, Babu
2024-03-21 16:50 ` [PATCH v1 02/31] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2024-04-09  3:13   ` Reinette Chatre
2024-04-11 14:14     ` Dave Martin
2024-04-09  8:09   ` David Hildenbrand
2024-04-11 14:13     ` Dave Martin
2024-04-15 20:28   ` Moger, Babu
2024-04-16 16:15     ` Dave Martin
2024-04-16 20:44       ` Moger, Babu
2024-04-17 14:40         ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 03/31] x86/resctrl: Move ctrlval string parsing policy away from the arch code James Morse
2024-04-09  3:14   ` Reinette Chatre
2024-04-12 16:16     ` Dave Martin
2024-04-15 17:44       ` Reinette Chatre
2024-04-16 16:16         ` Dave Martin
2024-04-18  5:34           ` Reinette Chatre
2024-05-23 18:04             ` James Morse
2024-04-09 15:13   ` David Hildenbrand
2024-04-12 16:13     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 04/31] x86/resctrl: Add helper for setting CPU default properties James Morse
2024-04-09  3:15   ` Reinette Chatre
2024-04-12 16:13     ` Dave Martin
2024-04-15 17:45       ` Reinette Chatre
2024-04-16 16:16         ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 05/31] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2024-04-09  3:16   ` Reinette Chatre
2024-04-12 16:12     ` Dave Martin
2024-04-15 17:47       ` Reinette Chatre
2024-04-16 16:16         ` Dave Martin
2024-04-18  5:12           ` Reinette Chatre
2024-04-18 15:21             ` Dave Martin
2024-04-20  3:58               ` Reinette Chatre
2024-04-15 20:40   ` Moger, Babu
2024-04-16 16:17     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 06/31] x86/resctrl: Export resctrl fs's init function James Morse
2024-04-03  7:51   ` Shaopeng Tan (Fujitsu)
2024-04-11 14:14     ` Dave Martin
2024-04-09  3:16   ` Reinette Chatre
2024-04-11 14:14     ` Dave Martin
2024-04-11 17:36       ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 07/31] x86/resctrl: Wrap resctrl_arch_find_domain() around rdt_find_domain() James Morse
2024-04-09  3:17   ` Reinette Chatre
2024-04-11 14:15     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 08/31] x86/resctrl: Move resctrl types to a separate header James Morse
2024-04-09  3:18   ` Reinette Chatre
2024-04-12 16:17     ` Dave Martin
2024-04-15 18:03       ` Reinette Chatre
2024-04-16 16:19         ` Dave Martin
2024-04-18  5:15           ` Reinette Chatre
2024-04-18 15:25             ` Dave Martin
2024-04-20  3:59               ` Reinette Chatre [this message]
2024-03-21 16:50 ` [PATCH v1 09/31] x86/resctrl: Add a resctrl helper to reset all the resources James Morse
2024-04-03  7:52   ` Shaopeng Tan (Fujitsu)
2024-04-12 16:17     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 10/31] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2024-04-09  3:18   ` Reinette Chatre
2024-04-10  2:57   ` Shawn Wang
2024-04-11 15:35     ` Dave Martin
2024-06-05 16:40     ` James Morse
2024-03-21 16:50 ` [PATCH v1 11/31] x86/resctrl: Move monitor exit work to a restrl exit call James Morse
2024-04-09  3:19   ` Reinette Chatre
2024-04-11 14:15     ` Dave Martin
2024-04-11 17:37       ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 12/31] x86/resctrl: Move max_{name,data}_width into resctrl code James Morse
2024-04-09  3:19   ` Reinette Chatre
2024-04-11 14:15     ` Dave Martin
2024-04-11 17:38       ` Reinette Chatre
2024-04-17 14:41         ` Dave Martin
2024-04-18  5:16           ` Reinette Chatre
2024-04-18 15:26             ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 13/31] x86/resctrl: Stop using the for_each_*_rdt_resource() walkers James Morse
2024-04-09  3:19   ` Reinette Chatre
2024-04-11 14:16     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 14/31] x86/resctrl: Export the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2024-04-09  3:20   ` Reinette Chatre
2024-04-11 14:16     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 15/31] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2024-03-21 16:50 ` [PATCH v1 16/31] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2024-04-09  3:20   ` Reinette Chatre
2024-04-11 14:16     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 17/31] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2024-04-09  3:21   ` Reinette Chatre
2024-04-11 14:16     ` Dave Martin
2024-04-11 17:39       ` Reinette Chatre
2024-04-17 14:41         ` Dave Martin
2024-04-18  5:18           ` Reinette Chatre
2024-04-18 15:26             ` Dave Martin
2024-06-14 13:57               ` James Morse
2024-03-21 16:50 ` [PATCH v1 18/31] x86/resctrl: Allow resctrl_arch_mon_event_config_write() to return an error James Morse
2024-04-09  3:23   ` Reinette Chatre
2024-04-11 14:17     ` Dave Martin
2024-04-11 17:39       ` Reinette Chatre
2024-04-17 14:42         ` Dave Martin
2024-04-18  5:19           ` Reinette Chatre
2024-04-18 15:31             ` Dave Martin
2024-06-14 13:57     ` James Morse
2024-03-21 16:50 ` [PATCH v1 19/31] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2024-03-21 16:50 ` [PATCH v1 20/31] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2024-04-09  3:24   ` Reinette Chatre
2024-04-11 14:17     ` Dave Martin
2024-04-11 17:40       ` Reinette Chatre
2024-04-17 14:42         ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 21/31] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2024-03-21 16:50 ` [PATCH v1 22/31] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr James Morse
2024-04-09  3:24   ` Reinette Chatre
2024-04-11 14:38     ` Dave Martin
2024-04-11 17:40       ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 23/31] x86/resctrl: Move thread_throttle_mode_init() to be managed by resctrl James Morse
2024-03-21 16:50 ` [PATCH v1 24/31] x86/resctrl: Move get_config_index() to a header James Morse
2024-04-09  3:25   ` Reinette Chatre
2024-04-11 14:25     ` Dave Martin
2024-04-11 17:41       ` Reinette Chatre
2024-06-14 13:58         ` James Morse
2024-03-21 16:51 ` [PATCH v1 25/31] x86/resctrl: Claim get_domain_from_cpu() for resctrl James Morse
2024-03-21 16:51 ` [PATCH v1 26/31] x86/resctrl: Describe resctrl's bitmap size assumptions James Morse
2024-03-21 16:51 ` [PATCH v1 27/31] x86/resctrl: Rename resctrl_sched_in() to begin resctrl_arch_ James Morse
2024-04-09  3:26   ` Reinette Chatre
2024-04-11 14:25     ` Dave Martin
2024-04-15 20:43   ` Moger, Babu
2024-03-21 16:51 ` [PATCH v1 28/31] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2024-04-09  3:32   ` Reinette Chatre
2024-04-11 14:26     ` Dave Martin
2024-04-11 15:51       ` [EXTERNAL] " Amit Singh Tomar
2024-04-12 16:20         ` Dave Martin
2024-04-30  7:13           ` Amit Singh Tomar
2024-04-30 16:19             ` Dave Martin
2024-05-01 16:21               ` Amit Singh Tomar
2024-05-02 15:58                 ` Dave Martin
2024-06-14 13:59                   ` James Morse
2024-06-14 13:59         ` [EXTERNAL] " James Morse
2024-03-21 16:51 ` [PATCH v1 29/31] fs/resctrl: Add boiler plate for external resctrl code James Morse
2024-04-09  3:41   ` Reinette Chatre
2024-04-11 14:27     ` Dave Martin
2024-04-11 17:42       ` Reinette Chatre
2024-04-12 16:23         ` Dave Martin
2024-04-12 16:23         ` Dave Martin
2024-03-21 16:51 ` [PATCH v1 30/31] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2024-04-04  7:43   ` Shaopeng Tan (Fujitsu)
2024-04-11 14:27     ` Dave Martin
2024-04-09  3:42   ` Reinette Chatre
2024-04-11 14:28     ` Dave Martin
2024-04-11 17:43       ` Reinette Chatre
2024-04-12 16:20         ` Dave Martin
2024-04-15 18:03           ` Reinette Chatre
2024-04-17 14:42             ` Dave Martin
2024-03-21 16:51 ` [PATCH v1 31/31] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2024-03-26 19:44   ` Fenghua Yu
2024-04-11 14:30     ` Dave Martin
2024-04-11 17:45       ` Reinette Chatre
2024-04-12 16:20         ` Dave Martin
2024-04-09  3:43   ` Reinette Chatre
2024-04-11 14:38     ` Dave Martin
2024-04-15 20:44   ` Moger, Babu
2024-04-17 14:43     ` Dave Martin
2024-06-14 13:59       ` James Morse
2024-04-09  3:13 ` [PATCH v1 00/31] " Reinette Chatre
2024-04-11 14:38   ` Dave Martin
2024-04-18 15:32   ` Dave Martin
2024-04-20  4:06     ` Reinette Chatre
2024-04-22 13:51       ` Moger, Babu
2024-04-22 16:01         ` Reinette Chatre
2024-04-22 18:35           ` Moger, Babu
2024-04-22 18:39           ` Peter Newman
2024-04-23 12:37             ` Dave Martin
2024-06-14 13:59   ` James Morse
2024-04-11 13:52 ` Dave Martin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=7e44410a-895a-4364-82b5-2fc21c88f892@intel.com \
    --to=reinette.chatre@intel.com \
    --cc=Babu.Moger@amd.com \
    --cc=Dave.Martin@arm.com \
    --cc=amitsinght@marvell.com \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=bobo.shaobowang@huawei.com \
    --cc=bp@alien8.de \
    --cc=carl@os.amperecomputing.com \
    --cc=david@redhat.com \
    --cc=dfustini@baylibre.com \
    --cc=fenghua.yu@intel.com \
    --cc=hpa@zytor.com \
    --cc=james.morse@arm.com \
    --cc=lcherian@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peternewman@google.com \
    --cc=quic_jiles@quicinc.com \
    --cc=rex.nie@jaguarmicro.com \
    --cc=scott@os.amperecomputing.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=tan.shaopeng@fujitsu.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    --cc=xhao@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®