From: Dave Martin <Dave.Martin@arm.com>
To: Reinette Chatre <reinette.chatre@intel.com>
Cc: James Morse <james.morse@arm.com>,
x86@kernel.org, linux-kernel@vger.kernel.org,
Fenghua Yu <fenghua.yu@intel.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
shameerali.kolothum.thodi@huawei.com,
D Scott Phillips OS <scott@os.amperecomputing.com>,
carl@os.amperecomputing.com, lcherian@marvell.com,
bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
baolin.wang@linux.alibaba.com,
Jamie Iles <quic_jiles@quicinc.com>,
Xin Hao <xhao@linux.alibaba.com>,
peternewman@google.com, dfustini@baylibre.com,
amitsinght@marvell.com, David Hildenbrand <david@redhat.com>,
Rex Nie <rex.nie@jaguarmicro.com>
Subject: Re: [PATCH v1 30/31] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl
Date: Wed, 17 Apr 2024 15:42:48 +0100 [thread overview]
Message-ID: <Zh/f6Kv1oWTRPna3@e133380.arm.com> (raw)
In-Reply-To: <f287424f-c749-408e-92af-1717baf1718d@intel.com>
On Mon, Apr 15, 2024 at 11:03:32AM -0700, Reinette Chatre wrote:
> Hi Dave,
>
> On 4/12/2024 9:20 AM, Dave Martin wrote:
> > On Thu, Apr 11, 2024 at 10:43:55AM -0700, Reinette Chatre wrote:
> >> Hi Dave,
> >>
> >> On 4/11/2024 7:28 AM, Dave Martin wrote:
> >>> On Mon, Apr 08, 2024 at 08:42:00PM -0700, Reinette Chatre wrote:
> >>>> Hi James,
> >>>>
> >>>> On 3/21/2024 9:51 AM, James Morse wrote:
> >>>> ..
> >>>>> diff --git a/include/linux/resctrl_types.h b/include/linux/resctrl_types.h
> >>>>> index 4788bd95dac6..fe0b10b589c0 100644
> >>>>> --- a/include/linux/resctrl_types.h
> >>>>> +++ b/include/linux/resctrl_types.h
> >>>>> @@ -7,6 +7,36 @@
> >>>>> #ifndef __LINUX_RESCTRL_TYPES_H
> >>>>> #define __LINUX_RESCTRL_TYPES_H
> >>>>>
> >>>>> +#define CQM_LIMBOCHECK_INTERVAL 1000
> >>>>> +
> >>>>> +#define MBM_CNTR_WIDTH_BASE 24
> >>>>> +#define MBM_OVERFLOW_INTERVAL 1000
> >>>>> +#define MAX_MBA_BW 100u
> >>>>> +#define MBA_IS_LINEAR 0x4
> >>>>> +
> >>>>> +/* rdtgroup.flags */
> >>>>> +#define RDT_DELETED 1
> >>>>> +
> >>>>> +/* rftype.flags */
> >>>>> +#define RFTYPE_FLAGS_CPUS_LIST 1
> >>>>> +
> >>>>> +/*
> >>>>> + * Define the file type flags for base and info directories.
> >>>>> + */
> >>>>> +#define RFTYPE_INFO BIT(0)
> >>>>> +#define RFTYPE_BASE BIT(1)
> >>>>> +#define RFTYPE_CTRL BIT(4)
> >>>>> +#define RFTYPE_MON BIT(5)
> >>>>> +#define RFTYPE_TOP BIT(6)
> >>>>> +#define RFTYPE_RES_CACHE BIT(8)
> >>>>> +#define RFTYPE_RES_MB BIT(9)
> >>>>> +#define RFTYPE_DEBUG BIT(10)
> >>>>> +#define RFTYPE_CTRL_INFO (RFTYPE_INFO | RFTYPE_CTRL)
> >>>>> +#define RFTYPE_MON_INFO (RFTYPE_INFO | RFTYPE_MON)
> >>>>> +#define RFTYPE_TOP_INFO (RFTYPE_INFO | RFTYPE_TOP)
> >>>>> +#define RFTYPE_CTRL_BASE (RFTYPE_BASE | RFTYPE_CTRL)
> >>>>> +#define RFTYPE_MON_BASE (RFTYPE_BASE | RFTYPE_MON)
> >>>>> +
> >>>>> /* Reads to Local DRAM Memory */
> >>>>> #define READS_TO_LOCAL_MEM BIT(0)
> >>>>>
> >>>>
> >>>> Not all these new seem to belong in this file. Could you please confirm?
> >>>>
> >>>> For example:
> >>>> Earlier in series it was mentioned that struct rdtgroup is private to the
> >>>> fs so having RDT_DELETED is unexpected as it implies access to struct rdtgroup.
> >>>>
> >>>> CQM_LIMBOCHECK_INTERVAL seems private to the fs code, so too
> >>>> RFTYPE_FLAGS_CPUS_LIST.
> >>>>
> >>>> Reinette
> >>>>
> >>>
> >>> I'll flag this for James to review.
> >>>
> >>> These have to be moved out of the x86 private headers, but you're right
> >>> that some of them seem logically private to the resctrl core.
> >>>
> >>> I guess some of these could move to fs/resctrl/internal.h?
> >>
> >> It looks to me that way.
> >>
> >>>
> >>> OTOH, might it be preferable to keep all the flag definitions for a
> >>> given member together for ease of maintenance, even if some are for
> >>> resctrl internal use only?
> >>
> >> Indeed, those RFTYPE flags really seem to be fs code but I agree that
> >> architectures' use of RFTYPE_RES_CACHE and RFTYPE_RES_MB does make this
> >> complicated and having these in a central place is reasonable to me.
> >>
> >> Reinette
> >
> > Maybe we could split these into two groups, and clearly comment the ones
> > that have no user outside resctrl as internal use only?
>
> Another option to consider, which I think you hinted about earlier, is
> to add an enum that maps to the RFTYPE_RES_CACHE and RFTYPE_RES_MB
> flags. Just like, for example, RDTCTRL_GROUP maps to RFTYPE_CTRL.
> The new enum can then be used similar to enum rdt_group_type to pick the
> appropriate files based on RFTYPE_RES_CACHE or RFTYPE_RES_MB.
>
> >
> > That's not as clean as removing those definitions from a shared header,
> > but at least would help document the issue until/unless a better
> > solution is found...
> >
> > Cheers
> > ---Dave
(Note, I seem to have responded to that suggestion via my reply on patch 3,
rather than here:
"x86/resctrl: Move ctrlval string parsing policy away from the arch code"
https://lore.kernel.org/lkml/Zh6kRMkqVpu0Km4l@e133380.arm.com/ )
Cheers
---Dave
next prev parent reply other threads:[~2024-04-17 14:42 UTC|newest]
Thread overview: 179+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-03-21 16:50 [PATCH v1 00/31] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2024-03-21 16:50 ` [PATCH v1 01/31] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2024-04-09 3:13 ` Reinette Chatre
2024-04-11 14:13 ` Dave Martin
2024-04-09 8:05 ` David Hildenbrand
2024-04-09 15:02 ` Reinette Chatre
2024-04-09 15:06 ` David Hildenbrand
2024-04-11 15:02 ` Dave Martin
2024-04-11 14:13 ` Dave Martin
2024-04-11 17:35 ` Reinette Chatre
2024-04-12 16:17 ` Dave Martin
2024-04-15 20:27 ` Moger, Babu
2024-04-16 16:13 ` Dave Martin
2024-04-16 20:33 ` Moger, Babu
2024-03-21 16:50 ` [PATCH v1 02/31] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2024-04-09 3:13 ` Reinette Chatre
2024-04-11 14:14 ` Dave Martin
2024-04-09 8:09 ` David Hildenbrand
2024-04-11 14:13 ` Dave Martin
2024-04-15 20:28 ` Moger, Babu
2024-04-16 16:15 ` Dave Martin
2024-04-16 20:44 ` Moger, Babu
2024-04-17 14:40 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 03/31] x86/resctrl: Move ctrlval string parsing policy away from the arch code James Morse
2024-04-09 3:14 ` Reinette Chatre
2024-04-12 16:16 ` Dave Martin
2024-04-15 17:44 ` Reinette Chatre
2024-04-16 16:16 ` Dave Martin
2024-04-18 5:34 ` Reinette Chatre
2024-05-23 18:04 ` James Morse
2024-04-09 15:13 ` David Hildenbrand
2024-04-12 16:13 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 04/31] x86/resctrl: Add helper for setting CPU default properties James Morse
2024-04-09 3:15 ` Reinette Chatre
2024-04-12 16:13 ` Dave Martin
2024-04-15 17:45 ` Reinette Chatre
2024-04-16 16:16 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 05/31] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2024-04-09 3:16 ` Reinette Chatre
2024-04-12 16:12 ` Dave Martin
2024-04-15 17:47 ` Reinette Chatre
2024-04-16 16:16 ` Dave Martin
2024-04-18 5:12 ` Reinette Chatre
2024-04-18 15:21 ` Dave Martin
2024-04-20 3:58 ` Reinette Chatre
2024-04-15 20:40 ` Moger, Babu
2024-04-16 16:17 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 06/31] x86/resctrl: Export resctrl fs's init function James Morse
2024-04-03 7:51 ` Shaopeng Tan (Fujitsu)
2024-04-11 14:14 ` Dave Martin
2024-04-09 3:16 ` Reinette Chatre
2024-04-11 14:14 ` Dave Martin
2024-04-11 17:36 ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 07/31] x86/resctrl: Wrap resctrl_arch_find_domain() around rdt_find_domain() James Morse
2024-04-09 3:17 ` Reinette Chatre
2024-04-11 14:15 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 08/31] x86/resctrl: Move resctrl types to a separate header James Morse
2024-04-09 3:18 ` Reinette Chatre
2024-04-12 16:17 ` Dave Martin
2024-04-15 18:03 ` Reinette Chatre
2024-04-16 16:19 ` Dave Martin
2024-04-18 5:15 ` Reinette Chatre
2024-04-18 15:25 ` Dave Martin
2024-04-20 3:59 ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 09/31] x86/resctrl: Add a resctrl helper to reset all the resources James Morse
2024-04-03 7:52 ` Shaopeng Tan (Fujitsu)
2024-04-12 16:17 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 10/31] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2024-04-09 3:18 ` Reinette Chatre
2024-04-10 2:57 ` Shawn Wang
2024-04-11 15:35 ` Dave Martin
2024-06-05 16:40 ` James Morse
2024-03-21 16:50 ` [PATCH v1 11/31] x86/resctrl: Move monitor exit work to a restrl exit call James Morse
2024-04-09 3:19 ` Reinette Chatre
2024-04-11 14:15 ` Dave Martin
2024-04-11 17:37 ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 12/31] x86/resctrl: Move max_{name,data}_width into resctrl code James Morse
2024-04-09 3:19 ` Reinette Chatre
2024-04-11 14:15 ` Dave Martin
2024-04-11 17:38 ` Reinette Chatre
2024-04-17 14:41 ` Dave Martin
2024-04-18 5:16 ` Reinette Chatre
2024-04-18 15:26 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 13/31] x86/resctrl: Stop using the for_each_*_rdt_resource() walkers James Morse
2024-04-09 3:19 ` Reinette Chatre
2024-04-11 14:16 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 14/31] x86/resctrl: Export the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2024-04-09 3:20 ` Reinette Chatre
2024-04-11 14:16 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 15/31] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2024-03-21 16:50 ` [PATCH v1 16/31] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2024-04-09 3:20 ` Reinette Chatre
2024-04-11 14:16 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 17/31] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2024-04-09 3:21 ` Reinette Chatre
2024-04-11 14:16 ` Dave Martin
2024-04-11 17:39 ` Reinette Chatre
2024-04-17 14:41 ` Dave Martin
2024-04-18 5:18 ` Reinette Chatre
2024-04-18 15:26 ` Dave Martin
2024-06-14 13:57 ` James Morse
2024-03-21 16:50 ` [PATCH v1 18/31] x86/resctrl: Allow resctrl_arch_mon_event_config_write() to return an error James Morse
2024-04-09 3:23 ` Reinette Chatre
2024-04-11 14:17 ` Dave Martin
2024-04-11 17:39 ` Reinette Chatre
2024-04-17 14:42 ` Dave Martin
2024-04-18 5:19 ` Reinette Chatre
2024-04-18 15:31 ` Dave Martin
2024-06-14 13:57 ` James Morse
2024-03-21 16:50 ` [PATCH v1 19/31] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2024-03-21 16:50 ` [PATCH v1 20/31] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2024-04-09 3:24 ` Reinette Chatre
2024-04-11 14:17 ` Dave Martin
2024-04-11 17:40 ` Reinette Chatre
2024-04-17 14:42 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 21/31] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2024-03-21 16:50 ` [PATCH v1 22/31] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr James Morse
2024-04-09 3:24 ` Reinette Chatre
2024-04-11 14:38 ` Dave Martin
2024-04-11 17:40 ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 23/31] x86/resctrl: Move thread_throttle_mode_init() to be managed by resctrl James Morse
2024-03-21 16:50 ` [PATCH v1 24/31] x86/resctrl: Move get_config_index() to a header James Morse
2024-04-09 3:25 ` Reinette Chatre
2024-04-11 14:25 ` Dave Martin
2024-04-11 17:41 ` Reinette Chatre
2024-06-14 13:58 ` James Morse
2024-03-21 16:51 ` [PATCH v1 25/31] x86/resctrl: Claim get_domain_from_cpu() for resctrl James Morse
2024-03-21 16:51 ` [PATCH v1 26/31] x86/resctrl: Describe resctrl's bitmap size assumptions James Morse
2024-03-21 16:51 ` [PATCH v1 27/31] x86/resctrl: Rename resctrl_sched_in() to begin resctrl_arch_ James Morse
2024-04-09 3:26 ` Reinette Chatre
2024-04-11 14:25 ` Dave Martin
2024-04-15 20:43 ` Moger, Babu
2024-03-21 16:51 ` [PATCH v1 28/31] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2024-04-09 3:32 ` Reinette Chatre
2024-04-11 14:26 ` Dave Martin
2024-04-11 15:51 ` [EXTERNAL] " Amit Singh Tomar
2024-04-12 16:20 ` Dave Martin
2024-04-30 7:13 ` Amit Singh Tomar
2024-04-30 16:19 ` Dave Martin
2024-05-01 16:21 ` Amit Singh Tomar
2024-05-02 15:58 ` Dave Martin
2024-06-14 13:59 ` James Morse
2024-06-14 13:59 ` [EXTERNAL] " James Morse
2024-03-21 16:51 ` [PATCH v1 29/31] fs/resctrl: Add boiler plate for external resctrl code James Morse
2024-04-09 3:41 ` Reinette Chatre
2024-04-11 14:27 ` Dave Martin
2024-04-11 17:42 ` Reinette Chatre
2024-04-12 16:23 ` Dave Martin
2024-04-12 16:23 ` Dave Martin
2024-03-21 16:51 ` [PATCH v1 30/31] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2024-04-04 7:43 ` Shaopeng Tan (Fujitsu)
2024-04-11 14:27 ` Dave Martin
2024-04-09 3:42 ` Reinette Chatre
2024-04-11 14:28 ` Dave Martin
2024-04-11 17:43 ` Reinette Chatre
2024-04-12 16:20 ` Dave Martin
2024-04-15 18:03 ` Reinette Chatre
2024-04-17 14:42 ` Dave Martin [this message]
2024-03-21 16:51 ` [PATCH v1 31/31] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2024-03-26 19:44 ` Fenghua Yu
2024-04-11 14:30 ` Dave Martin
2024-04-11 17:45 ` Reinette Chatre
2024-04-12 16:20 ` Dave Martin
2024-04-09 3:43 ` Reinette Chatre
2024-04-11 14:38 ` Dave Martin
2024-04-15 20:44 ` Moger, Babu
2024-04-17 14:43 ` Dave Martin
2024-06-14 13:59 ` James Morse
2024-04-09 3:13 ` [PATCH v1 00/31] " Reinette Chatre
2024-04-11 14:38 ` Dave Martin
2024-04-18 15:32 ` Dave Martin
2024-04-20 4:06 ` Reinette Chatre
2024-04-22 13:51 ` Moger, Babu
2024-04-22 16:01 ` Reinette Chatre
2024-04-22 18:35 ` Moger, Babu
2024-04-22 18:39 ` Peter Newman
2024-04-23 12:37 ` Dave Martin
2024-06-14 13:59 ` James Morse
2024-04-11 13:52 ` Dave Martin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=Zh/f6Kv1oWTRPna3@e133380.arm.com \
--to=dave.martin@arm.com \
--cc=Babu.Moger@amd.com \
--cc=amitsinght@marvell.com \
--cc=baolin.wang@linux.alibaba.com \
--cc=bobo.shaobowang@huawei.com \
--cc=bp@alien8.de \
--cc=carl@os.amperecomputing.com \
--cc=david@redhat.com \
--cc=dfustini@baylibre.com \
--cc=fenghua.yu@intel.com \
--cc=hpa@zytor.com \
--cc=james.morse@arm.com \
--cc=lcherian@marvell.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peternewman@google.com \
--cc=quic_jiles@quicinc.com \
--cc=reinette.chatre@intel.com \
--cc=rex.nie@jaguarmicro.com \
--cc=scott@os.amperecomputing.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=tan.shaopeng@fujitsu.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
--cc=xhao@linux.alibaba.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome