From: Reinette Chatre <reinette.chatre@intel.com>
To: James Morse <james.morse@arm.com>, <x86@kernel.org>,
<linux-kernel@vger.kernel.org>
Cc: Fenghua Yu <fenghua.yu@intel.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
<shameerali.kolothum.thodi@huawei.com>,
D Scott Phillips OS <scott@os.amperecomputing.com>,
<carl@os.amperecomputing.com>, <lcherian@marvell.com>,
<bobo.shaobowang@huawei.com>, <tan.shaopeng@fujitsu.com>,
<baolin.wang@linux.alibaba.com>,
Jamie Iles <quic_jiles@quicinc.com>,
Xin Hao <xhao@linux.alibaba.com>, <peternewman@google.com>,
<dfustini@baylibre.com>, <amitsinght@marvell.com>,
David Hildenbrand <david@redhat.com>,
Rex Nie <rex.nie@jaguarmicro.com>,
Dave Martin <dave.martin@arm.com>
Subject: Re: [PATCH v1 13/31] x86/resctrl: Stop using the for_each_*_rdt_resource() walkers
Date: Mon, 8 Apr 2024 20:19:40 -0700 [thread overview]
Message-ID: <9d339257-97c3-4d9f-aa02-c43713fd33df@intel.com> (raw)
In-Reply-To: <20240321165106.31602-14-james.morse@arm.com>
Hi James,
On 3/21/2024 9:50 AM, James Morse wrote:
> The for_each_*_rdt_resource() helpers walk the architectures array
architecture's ?
> of structures, using the resctrl visible part as an iterator. These
> became over-complex when the structures were split into a
> filesystem and architecture-specific struct. This approach avoided
> the need to touch every call site.
>
> Once the filesystem parts of resctrl are moved to /fs/, both the
> architecture's resource array, and the definition of those structures
> is no longer accessible. To support resctrl, each architecture would
> have to provide equally complex macros.
>
> Change the resctrl code that uses these to walk through the resource_level
> enum and check the mon/alloc capable flags instead. Instances in core.c,
> and resctrl_arch_reset_resources() remain part of x86's architecture
> specific code.
>
> Signed-off-by: James Morse <james.morse@arm.com>
> ---
> arch/x86/kernel/cpu/resctrl/pseudo_lock.c | 7 +++++-
> arch/x86/kernel/cpu/resctrl/rdtgroup.c | 30 +++++++++++++++++++----
> 2 files changed, 31 insertions(+), 6 deletions(-)
>
> diff --git a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
> index 884b88e25141..f2315a50ea4f 100644
> --- a/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
> +++ b/arch/x86/kernel/cpu/resctrl/pseudo_lock.c
> @@ -840,6 +840,7 @@ bool rdtgroup_cbm_overlaps_pseudo_locked(struct rdt_domain *d, unsigned long cbm
> bool rdtgroup_pseudo_locked_in_hierarchy(struct rdt_domain *d)
> {
> cpumask_var_t cpu_with_psl;
> + enum resctrl_res_level i;
> struct rdt_resource *r;
> struct rdt_domain *d_i;
> bool ret = false;
> @@ -854,7 +855,11 @@ bool rdtgroup_pseudo_locked_in_hierarchy(struct rdt_domain *d)
> * First determine which cpus have pseudo-locked regions
> * associated with them.
> */
> - for_each_alloc_capable_rdt_resource(r) {
> + for (i = 0; i < RDT_NUM_RESOURCES; i++) {
> + r = resctrl_arch_get_resource(i);
> + if (!r->alloc_capable)
> + continue;
> +
> list_for_each_entry(d_i, &r->domains, list) {
> if (d_i->plr)
> cpumask_or(cpu_with_psl, cpu_with_psl,
> diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> index e736e4d20f63..3f16e7854411 100644
> --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> @@ -98,12 +98,17 @@ void rdt_last_cmd_printf(const char *fmt, ...)
>
> void rdt_staged_configs_clear(void)
> {
> + enum resctrl_res_level i;
> struct rdt_resource *r;
> struct rdt_domain *dom;
>
> lockdep_assert_held(&rdtgroup_mutex);
>
> - for_each_alloc_capable_rdt_resource(r) {
> + for (i = 0; i < RDT_NUM_RESOURCES; i++) {
> + r = resctrl_arch_get_resource(i);
> + if (!r->alloc_capable)
> + continue;
> +
> list_for_each_entry(dom, &r->domains, list)
> memset(dom->staged_config, 0, sizeof(dom->staged_config));
> }
> @@ -2181,6 +2186,7 @@ static int rdtgroup_mkdir_info_resdir(void *priv, char *name,
>
> static int rdtgroup_create_info_dir(struct kernfs_node *parent_kn)
> {
> + enum resctrl_res_level i;
> struct resctrl_schema *s;
> struct rdt_resource *r;
> unsigned long fflags;
> @@ -2205,8 +2211,12 @@ static int rdtgroup_create_info_dir(struct kernfs_node *parent_kn)
> goto out_destroy;
> }
>
> - for_each_mon_capable_rdt_resource(r) {
> - fflags = r->fflags | RFTYPE_MON_INFO;
> + for (i = 0; i < RDT_NUM_RESOURCES; i++) {
> + r = resctrl_arch_get_resource(i);
> + if (!r->mon_capable)
> + continue;
> +
> + fflags = r->fflags | RFTYPE_MON_INFO;
Please check spacing.
> sprintf(name, "%s_MON", r->name);
> ret = rdtgroup_mkdir_info_resdir(r, name, fflags);
> if (ret)
> @@ -2615,10 +2625,15 @@ static int schemata_list_add(struct rdt_resource *r, enum resctrl_conf_type type
>
> static int schemata_list_create(void)
> {
> + enum resctrl_res_level i;
> struct rdt_resource *r;
> int ret = 0;
>
> - for_each_alloc_capable_rdt_resource(r) {
> + for (i = 0; i < RDT_NUM_RESOURCES; i++) {
> + r = resctrl_arch_get_resource(i);
> + if (!r->alloc_capable)
> + continue;
> +
> if (resctrl_arch_get_cdp_enabled(r->rid)) {
> ret = schemata_list_add(r, CDP_CODE);
> if (ret)
> @@ -3166,6 +3181,7 @@ static int mkdir_mondata_all(struct kernfs_node *parent_kn,
> struct rdtgroup *prgrp,
> struct kernfs_node **dest_kn)
> {
> + enum resctrl_res_level i;
> struct rdt_resource *r;
> struct kernfs_node *kn;
> int ret;
> @@ -3184,7 +3200,11 @@ static int mkdir_mondata_all(struct kernfs_node *parent_kn,
> * Create the subdirectories for each domain. Note that all events
> * in a domain like L3 are grouped into a resource whose domain is L3
> */
> - for_each_mon_capable_rdt_resource(r) {
> + for (i = 0; i < RDT_NUM_RESOURCES; i++) {
> + r = resctrl_arch_get_resource(i);
> + if (!r->mon_capable)
> + continue;
> +
> ret = mkdir_mondata_subdir_alldom(kn, r, prgrp);
> if (ret)
> goto out_destroy;
Reinette
next prev parent reply other threads:[~2024-04-09 3:19 UTC|newest]
Thread overview: 179+ messages / expand[flat|nested] mbox.gz Atom feed top
2024-03-21 16:50 [PATCH v1 00/31] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2024-03-21 16:50 ` [PATCH v1 01/31] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2024-04-09 3:13 ` Reinette Chatre
2024-04-11 14:13 ` Dave Martin
2024-04-09 8:05 ` David Hildenbrand
2024-04-09 15:02 ` Reinette Chatre
2024-04-09 15:06 ` David Hildenbrand
2024-04-11 15:02 ` Dave Martin
2024-04-11 14:13 ` Dave Martin
2024-04-11 17:35 ` Reinette Chatre
2024-04-12 16:17 ` Dave Martin
2024-04-15 20:27 ` Moger, Babu
2024-04-16 16:13 ` Dave Martin
2024-04-16 20:33 ` Moger, Babu
2024-03-21 16:50 ` [PATCH v1 02/31] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2024-04-09 3:13 ` Reinette Chatre
2024-04-11 14:14 ` Dave Martin
2024-04-09 8:09 ` David Hildenbrand
2024-04-11 14:13 ` Dave Martin
2024-04-15 20:28 ` Moger, Babu
2024-04-16 16:15 ` Dave Martin
2024-04-16 20:44 ` Moger, Babu
2024-04-17 14:40 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 03/31] x86/resctrl: Move ctrlval string parsing policy away from the arch code James Morse
2024-04-09 3:14 ` Reinette Chatre
2024-04-12 16:16 ` Dave Martin
2024-04-15 17:44 ` Reinette Chatre
2024-04-16 16:16 ` Dave Martin
2024-04-18 5:34 ` Reinette Chatre
2024-05-23 18:04 ` James Morse
2024-04-09 15:13 ` David Hildenbrand
2024-04-12 16:13 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 04/31] x86/resctrl: Add helper for setting CPU default properties James Morse
2024-04-09 3:15 ` Reinette Chatre
2024-04-12 16:13 ` Dave Martin
2024-04-15 17:45 ` Reinette Chatre
2024-04-16 16:16 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 05/31] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2024-04-09 3:16 ` Reinette Chatre
2024-04-12 16:12 ` Dave Martin
2024-04-15 17:47 ` Reinette Chatre
2024-04-16 16:16 ` Dave Martin
2024-04-18 5:12 ` Reinette Chatre
2024-04-18 15:21 ` Dave Martin
2024-04-20 3:58 ` Reinette Chatre
2024-04-15 20:40 ` Moger, Babu
2024-04-16 16:17 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 06/31] x86/resctrl: Export resctrl fs's init function James Morse
2024-04-03 7:51 ` Shaopeng Tan (Fujitsu)
2024-04-11 14:14 ` Dave Martin
2024-04-09 3:16 ` Reinette Chatre
2024-04-11 14:14 ` Dave Martin
2024-04-11 17:36 ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 07/31] x86/resctrl: Wrap resctrl_arch_find_domain() around rdt_find_domain() James Morse
2024-04-09 3:17 ` Reinette Chatre
2024-04-11 14:15 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 08/31] x86/resctrl: Move resctrl types to a separate header James Morse
2024-04-09 3:18 ` Reinette Chatre
2024-04-12 16:17 ` Dave Martin
2024-04-15 18:03 ` Reinette Chatre
2024-04-16 16:19 ` Dave Martin
2024-04-18 5:15 ` Reinette Chatre
2024-04-18 15:25 ` Dave Martin
2024-04-20 3:59 ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 09/31] x86/resctrl: Add a resctrl helper to reset all the resources James Morse
2024-04-03 7:52 ` Shaopeng Tan (Fujitsu)
2024-04-12 16:17 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 10/31] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2024-04-09 3:18 ` Reinette Chatre
2024-04-10 2:57 ` Shawn Wang
2024-04-11 15:35 ` Dave Martin
2024-06-05 16:40 ` James Morse
2024-03-21 16:50 ` [PATCH v1 11/31] x86/resctrl: Move monitor exit work to a restrl exit call James Morse
2024-04-09 3:19 ` Reinette Chatre
2024-04-11 14:15 ` Dave Martin
2024-04-11 17:37 ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 12/31] x86/resctrl: Move max_{name,data}_width into resctrl code James Morse
2024-04-09 3:19 ` Reinette Chatre
2024-04-11 14:15 ` Dave Martin
2024-04-11 17:38 ` Reinette Chatre
2024-04-17 14:41 ` Dave Martin
2024-04-18 5:16 ` Reinette Chatre
2024-04-18 15:26 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 13/31] x86/resctrl: Stop using the for_each_*_rdt_resource() walkers James Morse
2024-04-09 3:19 ` Reinette Chatre [this message]
2024-04-11 14:16 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 14/31] x86/resctrl: Export the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2024-04-09 3:20 ` Reinette Chatre
2024-04-11 14:16 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 15/31] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2024-03-21 16:50 ` [PATCH v1 16/31] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2024-04-09 3:20 ` Reinette Chatre
2024-04-11 14:16 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 17/31] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2024-04-09 3:21 ` Reinette Chatre
2024-04-11 14:16 ` Dave Martin
2024-04-11 17:39 ` Reinette Chatre
2024-04-17 14:41 ` Dave Martin
2024-04-18 5:18 ` Reinette Chatre
2024-04-18 15:26 ` Dave Martin
2024-06-14 13:57 ` James Morse
2024-03-21 16:50 ` [PATCH v1 18/31] x86/resctrl: Allow resctrl_arch_mon_event_config_write() to return an error James Morse
2024-04-09 3:23 ` Reinette Chatre
2024-04-11 14:17 ` Dave Martin
2024-04-11 17:39 ` Reinette Chatre
2024-04-17 14:42 ` Dave Martin
2024-04-18 5:19 ` Reinette Chatre
2024-04-18 15:31 ` Dave Martin
2024-06-14 13:57 ` James Morse
2024-03-21 16:50 ` [PATCH v1 19/31] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2024-03-21 16:50 ` [PATCH v1 20/31] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2024-04-09 3:24 ` Reinette Chatre
2024-04-11 14:17 ` Dave Martin
2024-04-11 17:40 ` Reinette Chatre
2024-04-17 14:42 ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 21/31] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2024-03-21 16:50 ` [PATCH v1 22/31] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr James Morse
2024-04-09 3:24 ` Reinette Chatre
2024-04-11 14:38 ` Dave Martin
2024-04-11 17:40 ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 23/31] x86/resctrl: Move thread_throttle_mode_init() to be managed by resctrl James Morse
2024-03-21 16:50 ` [PATCH v1 24/31] x86/resctrl: Move get_config_index() to a header James Morse
2024-04-09 3:25 ` Reinette Chatre
2024-04-11 14:25 ` Dave Martin
2024-04-11 17:41 ` Reinette Chatre
2024-06-14 13:58 ` James Morse
2024-03-21 16:51 ` [PATCH v1 25/31] x86/resctrl: Claim get_domain_from_cpu() for resctrl James Morse
2024-03-21 16:51 ` [PATCH v1 26/31] x86/resctrl: Describe resctrl's bitmap size assumptions James Morse
2024-03-21 16:51 ` [PATCH v1 27/31] x86/resctrl: Rename resctrl_sched_in() to begin resctrl_arch_ James Morse
2024-04-09 3:26 ` Reinette Chatre
2024-04-11 14:25 ` Dave Martin
2024-04-15 20:43 ` Moger, Babu
2024-03-21 16:51 ` [PATCH v1 28/31] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2024-04-09 3:32 ` Reinette Chatre
2024-04-11 14:26 ` Dave Martin
2024-04-11 15:51 ` [EXTERNAL] " Amit Singh Tomar
2024-04-12 16:20 ` Dave Martin
2024-04-30 7:13 ` Amit Singh Tomar
2024-04-30 16:19 ` Dave Martin
2024-05-01 16:21 ` Amit Singh Tomar
2024-05-02 15:58 ` Dave Martin
2024-06-14 13:59 ` James Morse
2024-06-14 13:59 ` [EXTERNAL] " James Morse
2024-03-21 16:51 ` [PATCH v1 29/31] fs/resctrl: Add boiler plate for external resctrl code James Morse
2024-04-09 3:41 ` Reinette Chatre
2024-04-11 14:27 ` Dave Martin
2024-04-11 17:42 ` Reinette Chatre
2024-04-12 16:23 ` Dave Martin
2024-04-12 16:23 ` Dave Martin
2024-03-21 16:51 ` [PATCH v1 30/31] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2024-04-04 7:43 ` Shaopeng Tan (Fujitsu)
2024-04-11 14:27 ` Dave Martin
2024-04-09 3:42 ` Reinette Chatre
2024-04-11 14:28 ` Dave Martin
2024-04-11 17:43 ` Reinette Chatre
2024-04-12 16:20 ` Dave Martin
2024-04-15 18:03 ` Reinette Chatre
2024-04-17 14:42 ` Dave Martin
2024-03-21 16:51 ` [PATCH v1 31/31] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2024-03-26 19:44 ` Fenghua Yu
2024-04-11 14:30 ` Dave Martin
2024-04-11 17:45 ` Reinette Chatre
2024-04-12 16:20 ` Dave Martin
2024-04-09 3:43 ` Reinette Chatre
2024-04-11 14:38 ` Dave Martin
2024-04-15 20:44 ` Moger, Babu
2024-04-17 14:43 ` Dave Martin
2024-06-14 13:59 ` James Morse
2024-04-09 3:13 ` [PATCH v1 00/31] " Reinette Chatre
2024-04-11 14:38 ` Dave Martin
2024-04-18 15:32 ` Dave Martin
2024-04-20 4:06 ` Reinette Chatre
2024-04-22 13:51 ` Moger, Babu
2024-04-22 16:01 ` Reinette Chatre
2024-04-22 18:35 ` Moger, Babu
2024-04-22 18:39 ` Peter Newman
2024-04-23 12:37 ` Dave Martin
2024-06-14 13:59 ` James Morse
2024-04-11 13:52 ` Dave Martin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=9d339257-97c3-4d9f-aa02-c43713fd33df@intel.com \
--to=reinette.chatre@intel.com \
--cc=Babu.Moger@amd.com \
--cc=amitsinght@marvell.com \
--cc=baolin.wang@linux.alibaba.com \
--cc=bobo.shaobowang@huawei.com \
--cc=bp@alien8.de \
--cc=carl@os.amperecomputing.com \
--cc=dave.martin@arm.com \
--cc=david@redhat.com \
--cc=dfustini@baylibre.com \
--cc=fenghua.yu@intel.com \
--cc=hpa@zytor.com \
--cc=james.morse@arm.com \
--cc=lcherian@marvell.com \
--cc=linux-kernel@vger.kernel.org \
--cc=mingo@redhat.com \
--cc=peternewman@google.com \
--cc=quic_jiles@quicinc.com \
--cc=rex.nie@jaguarmicro.com \
--cc=scott@os.amperecomputing.com \
--cc=shameerali.kolothum.thodi@huawei.com \
--cc=tan.shaopeng@fujitsu.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
--cc=xhao@linux.alibaba.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome