mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Dave Martin <Dave.Martin@arm.com>
To: Reinette Chatre <reinette.chatre@intel.com>
Cc: James Morse <james.morse@arm.com>,
	x86@kernel.org, linux-kernel@vger.kernel.org,
	Fenghua Yu <fenghua.yu@intel.com>,
	Thomas Gleixner <tglx@linutronix.de>,
	Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
	H Peter Anvin <hpa@zytor.com>, Babu Moger <Babu.Moger@amd.com>,
	shameerali.kolothum.thodi@huawei.com,
	D Scott Phillips OS <scott@os.amperecomputing.com>,
	carl@os.amperecomputing.com, lcherian@marvell.com,
	bobo.shaobowang@huawei.com, tan.shaopeng@fujitsu.com,
	baolin.wang@linux.alibaba.com,
	Jamie Iles <quic_jiles@quicinc.com>,
	Xin Hao <xhao@linux.alibaba.com>,
	peternewman@google.com, dfustini@baylibre.com,
	amitsinght@marvell.com, David Hildenbrand <david@redhat.com>,
	Rex Nie <rex.nie@jaguarmicro.com>
Subject: Re: [PATCH v1 05/31] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid()
Date: Tue, 16 Apr 2024 17:16:50 +0100	[thread overview]
Message-ID: <Zh6kchkH9Dy+ywXc@e133380.arm.com> (raw)
In-Reply-To: <0698418a-aede-40d6-90ce-dbf6e8796916@intel.com>

On Mon, Apr 15, 2024 at 10:47:55AM -0700, Reinette Chatre wrote:
> Hi Dave,
> 
> On 4/12/2024 9:12 AM, Dave Martin wrote:
> > On Mon, Apr 08, 2024 at 08:16:08PM -0700, Reinette Chatre wrote:
> >> Hi James,
> >>
> >> On 3/21/2024 9:50 AM, James Morse wrote:
> >>> update_cpu_closid_rmid() takes a struct rdtgroup as an argument, which
> >>> it uses to update the local CPUs default pqr values. This is a problem
> >>> once the resctrl parts move out to /fs/, as the arch code cannot
> >>> poke around inside struct rdtgroup.
> >>>
> >>> Rename update_cpu_closid_rmid() as resctrl_arch_sync_cpus_defaults()
> >>> to be used as the target of an IPI, and pass the effective CLOSID
> >>> and RMID in a new struct.
> >>>
> >>> Signed-off-by: James Morse <james.morse@arm.com>
> >>> ---
> >>>  arch/x86/kernel/cpu/resctrl/rdtgroup.c | 19 +++++++++++++++----
> >>>  include/linux/resctrl.h                | 11 +++++++++++
> >>>  2 files changed, 26 insertions(+), 4 deletions(-)
> >>>
> >>> diff --git a/arch/x86/kernel/cpu/resctrl/rdtgroup.c b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> >>> index 5d2c1ce5b6b1..18f097fce51e 100644
> >>> --- a/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> >>> +++ b/arch/x86/kernel/cpu/resctrl/rdtgroup.c
> >>> @@ -341,13 +341,13 @@ static int rdtgroup_cpus_show(struct kernfs_open_file *of,
> >>>   * from update_closid_rmid() is protected against __switch_to() because
> >>>   * preemption is disabled.
> >>>   */
> >>> -static void update_cpu_closid_rmid(void *info)
> >>> +void resctrl_arch_sync_cpu_defaults(void *info)
> >>>  {
> >>> -	struct rdtgroup *r = info;
> >>> +	struct resctrl_cpu_sync *r = info;
> >>>  
> >>>  	if (r) {
> >>>  		this_cpu_write(pqr_state.default_closid, r->closid);
> >>> -		this_cpu_write(pqr_state.default_rmid, r->mon.rmid);
> >>> +		this_cpu_write(pqr_state.default_rmid, r->rmid);
> >>>  	}
> >>>  
> >>>  	/*
> >>> @@ -362,11 +362,22 @@ static void update_cpu_closid_rmid(void *info)
> >>>   * Update the PGR_ASSOC MSR on all cpus in @cpu_mask,
> >>>   *
> >>>   * Per task closids/rmids must have been set up before calling this function.
> >>> + * @r may be NULL.
> >>>   */
> >>>  static void
> >>>  update_closid_rmid(const struct cpumask *cpu_mask, struct rdtgroup *r)
> >>>  {
> >>> -	on_each_cpu_mask(cpu_mask, update_cpu_closid_rmid, r, 1);
> >>> +	struct resctrl_cpu_sync defaults;
> >>> +	struct resctrl_cpu_sync *defaults_p = NULL;
> >>
> >> Please maintain reverse fir order.
> > 
> > Or, more tersely as follows?
> > 
> > 	struct resctrl_cpu_sync defaults, *defaults_p = NULL;
> 
> Sure.

[*]

> > 
> > "Reverse fir order" seems to be documented as a preference rather than a
> > rule.
> 
> This does not seem to be a place that warrants an exception to this
> preference. Note how this function is not consistent with any other
> in the file.

Ack (just bikeshedding here TBH).

> 
> > The declarations can be swapped, but defaults_p is in some sense a weak
> > pointer to defaults, so it feels a bit strange to declare them backwards.
> > 
> > Alternatively, could we rename defaults_p to p?  Given the size of this
> > function I don't think that impacts clarity.

[...]

> > 
> > I'll wait for your opinion on this.
> > 
> > 
> 
> Do you imply that this would maintain the order in this patch? It does
> not look to me that it would but I may be looking wrong.

I'm not sure without looking again, but since this discussion is not a
good use of your time I'll just go ahead and implement the change at
[*] above, while restoring referse FIR order, if that is good for you.

> 
> sidenote: the "on_each_cpu_mask()" in update_closid_rmid() can be on
> one line.

I guess that might have been split to stick to the 80-char limit.

Due the the small size of this function, shall I just rename defaults_p to p?
Alternatively, there are already a few non-printk lines over 80 chars, so
maybe we can tolerate one more here?

> 
> ..
> 
> >>> + * struct resctrl_cpu_sync, or NULL.
> >>> + */
> >>
> >> Updating the CPU's defaults is not the primary goal of this function and because
> >> of that I do not think this should be the focus with the main goal (updating
> >> RMID and CLOSID on CPU) ignored. Specifically, this function only updates
> >> the defaults if *info is set but it _always_ ensures CPU is running with
> >> appropriate CLOSID/RMID (which may or may not be from a CPU default).
> >>
> >> I think resctrl_arch_sync_cpu_closid_rmid() may be more appropriate
> >> and the comment needs to elaborate what the function does.
> >>
> >>> +void resctrl_arch_sync_cpu_defaults(void *info);
> > 
> > That seems reasonable, and follows the original naming and what the
> > code does:
> > 
> > What about:
> > 
> > /**
> >  * resctrl_arch_sync_cpu_defaults() - Refresh the CPU's CLOSID and RMID.
> >  *				      Call via IPI.
> 
> Did you intend to change function name?

Er, yes, I meant to use your suggestion here, so:
resctrl_arch_sync_cpu_closid_rmid().

Also, Babu Moger's suggestion to rename struct resctrl_cpu_sync
to resctrl_cpu_defaults seems good, since that accurately describes what
is specified in the struct (and what is *not* specified if NULL is
passed).

> 
> How about "Refresh the CPU's ..." -> "Refresh this CPU's ..." I think it
> makes it more obvious how this function is called.

Agreed.

> 
> >  * @info:	If non-NULL, a pointer to a struct resctrl_cpu_sync specifying
> >  *		the new CLOSID and RMID for tasks in the default resctrl ctrl
> >  *		and mon group when running on this CPU.  If NULL, the default
> >  *		CLOSID and RMID are not changed.
> 
> "If NULL, this CPU is not re-assigned to a different group." ?

Agreed.

> >  *
> >  * This is how reassignment of CPUs and/or tasks to different resctrl groups
> >  * is propagated when requested by the resctrl fs core code.
> 
> Could you please use imperative tone here?  For example, "Propagates reassignment
> of CPUs and/or tasks to different resctrl groups."

Yes, that's better (and shorter).

> 
> >  *
> >  * This function should typically record the per-cpu defaults specified by
> 
> "should" sounds like there may be cases when this is not done? Maybe just
> "Records the per-CPU defaults specified ..."

I didn't want to pre-judge what implementation-specific cruft the arch
code needs here, so I was intentionally vague.  But the arch would need
to put the CPU defaults into effect somehow or other, so yes, I think
your text is better here.

I'll make a note of those changes.

[...]

Cheers
---Dave

  reply	other threads:[~2024-04-16 16:16 UTC|newest]

Thread overview: 179+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2024-03-21 16:50 [PATCH v1 00/31] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2024-03-21 16:50 ` [PATCH v1 01/31] x86/resctrl: Fix allocation of cleanest CLOSID on platforms with no monitors James Morse
2024-04-09  3:13   ` Reinette Chatre
2024-04-11 14:13     ` Dave Martin
2024-04-09  8:05   ` David Hildenbrand
2024-04-09 15:02     ` Reinette Chatre
2024-04-09 15:06       ` David Hildenbrand
2024-04-11 15:02         ` Dave Martin
2024-04-11 14:13     ` Dave Martin
2024-04-11 17:35       ` Reinette Chatre
2024-04-12 16:17         ` Dave Martin
2024-04-15 20:27   ` Moger, Babu
2024-04-16 16:13     ` Dave Martin
2024-04-16 20:33       ` Moger, Babu
2024-03-21 16:50 ` [PATCH v1 02/31] x86/resctrl: Add a helper to avoid reaching into the arch code resource list James Morse
2024-04-09  3:13   ` Reinette Chatre
2024-04-11 14:14     ` Dave Martin
2024-04-09  8:09   ` David Hildenbrand
2024-04-11 14:13     ` Dave Martin
2024-04-15 20:28   ` Moger, Babu
2024-04-16 16:15     ` Dave Martin
2024-04-16 20:44       ` Moger, Babu
2024-04-17 14:40         ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 03/31] x86/resctrl: Move ctrlval string parsing policy away from the arch code James Morse
2024-04-09  3:14   ` Reinette Chatre
2024-04-12 16:16     ` Dave Martin
2024-04-15 17:44       ` Reinette Chatre
2024-04-16 16:16         ` Dave Martin
2024-04-18  5:34           ` Reinette Chatre
2024-05-23 18:04             ` James Morse
2024-04-09 15:13   ` David Hildenbrand
2024-04-12 16:13     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 04/31] x86/resctrl: Add helper for setting CPU default properties James Morse
2024-04-09  3:15   ` Reinette Chatre
2024-04-12 16:13     ` Dave Martin
2024-04-15 17:45       ` Reinette Chatre
2024-04-16 16:16         ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 05/31] x86/resctrl: Remove rdtgroup from update_cpu_closid_rmid() James Morse
2024-04-09  3:16   ` Reinette Chatre
2024-04-12 16:12     ` Dave Martin
2024-04-15 17:47       ` Reinette Chatre
2024-04-16 16:16         ` Dave Martin [this message]
2024-04-18  5:12           ` Reinette Chatre
2024-04-18 15:21             ` Dave Martin
2024-04-20  3:58               ` Reinette Chatre
2024-04-15 20:40   ` Moger, Babu
2024-04-16 16:17     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 06/31] x86/resctrl: Export resctrl fs's init function James Morse
2024-04-03  7:51   ` Shaopeng Tan (Fujitsu)
2024-04-11 14:14     ` Dave Martin
2024-04-09  3:16   ` Reinette Chatre
2024-04-11 14:14     ` Dave Martin
2024-04-11 17:36       ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 07/31] x86/resctrl: Wrap resctrl_arch_find_domain() around rdt_find_domain() James Morse
2024-04-09  3:17   ` Reinette Chatre
2024-04-11 14:15     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 08/31] x86/resctrl: Move resctrl types to a separate header James Morse
2024-04-09  3:18   ` Reinette Chatre
2024-04-12 16:17     ` Dave Martin
2024-04-15 18:03       ` Reinette Chatre
2024-04-16 16:19         ` Dave Martin
2024-04-18  5:15           ` Reinette Chatre
2024-04-18 15:25             ` Dave Martin
2024-04-20  3:59               ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 09/31] x86/resctrl: Add a resctrl helper to reset all the resources James Morse
2024-04-03  7:52   ` Shaopeng Tan (Fujitsu)
2024-04-12 16:17     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 10/31] x86/resctrl: Move monitor init work to a resctrl init call James Morse
2024-04-09  3:18   ` Reinette Chatre
2024-04-10  2:57   ` Shawn Wang
2024-04-11 15:35     ` Dave Martin
2024-06-05 16:40     ` James Morse
2024-03-21 16:50 ` [PATCH v1 11/31] x86/resctrl: Move monitor exit work to a restrl exit call James Morse
2024-04-09  3:19   ` Reinette Chatre
2024-04-11 14:15     ` Dave Martin
2024-04-11 17:37       ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 12/31] x86/resctrl: Move max_{name,data}_width into resctrl code James Morse
2024-04-09  3:19   ` Reinette Chatre
2024-04-11 14:15     ` Dave Martin
2024-04-11 17:38       ` Reinette Chatre
2024-04-17 14:41         ` Dave Martin
2024-04-18  5:16           ` Reinette Chatre
2024-04-18 15:26             ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 13/31] x86/resctrl: Stop using the for_each_*_rdt_resource() walkers James Morse
2024-04-09  3:19   ` Reinette Chatre
2024-04-11 14:16     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 14/31] x86/resctrl: Export the is_mbm_*_enabled() helpers to asm/resctrl.h James Morse
2024-04-09  3:20   ` Reinette Chatre
2024-04-11 14:16     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 15/31] x86/resctrl: Add resctrl_arch_is_evt_configurable() to abstract BMEC James Morse
2024-03-21 16:50 ` [PATCH v1 16/31] x86/resctrl: Change mon_event_config_{read,write}() to be arch helpers James Morse
2024-04-09  3:20   ` Reinette Chatre
2024-04-11 14:16     ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 17/31] x86/resctrl: Move mbm_cfg_mask to struct rdt_resource James Morse
2024-04-09  3:21   ` Reinette Chatre
2024-04-11 14:16     ` Dave Martin
2024-04-11 17:39       ` Reinette Chatre
2024-04-17 14:41         ` Dave Martin
2024-04-18  5:18           ` Reinette Chatre
2024-04-18 15:26             ` Dave Martin
2024-06-14 13:57               ` James Morse
2024-03-21 16:50 ` [PATCH v1 18/31] x86/resctrl: Allow resctrl_arch_mon_event_config_write() to return an error James Morse
2024-04-09  3:23   ` Reinette Chatre
2024-04-11 14:17     ` Dave Martin
2024-04-11 17:39       ` Reinette Chatre
2024-04-17 14:42         ` Dave Martin
2024-04-18  5:19           ` Reinette Chatre
2024-04-18 15:31             ` Dave Martin
2024-06-14 13:57     ` James Morse
2024-03-21 16:50 ` [PATCH v1 19/31] x86/resctrl: Add resctrl_arch_ prefix to pseudo lock functions James Morse
2024-03-21 16:50 ` [PATCH v1 20/31] x86/resctrl: Allow an architecture to disable pseudo lock James Morse
2024-04-09  3:24   ` Reinette Chatre
2024-04-11 14:17     ` Dave Martin
2024-04-11 17:40       ` Reinette Chatre
2024-04-17 14:42         ` Dave Martin
2024-03-21 16:50 ` [PATCH v1 21/31] x86/resctrl: Make prefetch_disable_bits belong to the arch code James Morse
2024-03-21 16:50 ` [PATCH v1 22/31] x86/resctrl: Make resctrl_arch_pseudo_lock_fn() take a plr James Morse
2024-04-09  3:24   ` Reinette Chatre
2024-04-11 14:38     ` Dave Martin
2024-04-11 17:40       ` Reinette Chatre
2024-03-21 16:50 ` [PATCH v1 23/31] x86/resctrl: Move thread_throttle_mode_init() to be managed by resctrl James Morse
2024-03-21 16:50 ` [PATCH v1 24/31] x86/resctrl: Move get_config_index() to a header James Morse
2024-04-09  3:25   ` Reinette Chatre
2024-04-11 14:25     ` Dave Martin
2024-04-11 17:41       ` Reinette Chatre
2024-06-14 13:58         ` James Morse
2024-03-21 16:51 ` [PATCH v1 25/31] x86/resctrl: Claim get_domain_from_cpu() for resctrl James Morse
2024-03-21 16:51 ` [PATCH v1 26/31] x86/resctrl: Describe resctrl's bitmap size assumptions James Morse
2024-03-21 16:51 ` [PATCH v1 27/31] x86/resctrl: Rename resctrl_sched_in() to begin resctrl_arch_ James Morse
2024-04-09  3:26   ` Reinette Chatre
2024-04-11 14:25     ` Dave Martin
2024-04-15 20:43   ` Moger, Babu
2024-03-21 16:51 ` [PATCH v1 28/31] x86/resctrl: Drop __init/__exit on assorted symbols James Morse
2024-04-09  3:32   ` Reinette Chatre
2024-04-11 14:26     ` Dave Martin
2024-04-11 15:51       ` [EXTERNAL] " Amit Singh Tomar
2024-04-12 16:20         ` Dave Martin
2024-04-30  7:13           ` Amit Singh Tomar
2024-04-30 16:19             ` Dave Martin
2024-05-01 16:21               ` Amit Singh Tomar
2024-05-02 15:58                 ` Dave Martin
2024-06-14 13:59                   ` James Morse
2024-06-14 13:59         ` [EXTERNAL] " James Morse
2024-03-21 16:51 ` [PATCH v1 29/31] fs/resctrl: Add boiler plate for external resctrl code James Morse
2024-04-09  3:41   ` Reinette Chatre
2024-04-11 14:27     ` Dave Martin
2024-04-11 17:42       ` Reinette Chatre
2024-04-12 16:23         ` Dave Martin
2024-04-12 16:23         ` Dave Martin
2024-03-21 16:51 ` [PATCH v1 30/31] x86/resctrl: Move the filesystem bits to headers visible to fs/resctrl James Morse
2024-04-04  7:43   ` Shaopeng Tan (Fujitsu)
2024-04-11 14:27     ` Dave Martin
2024-04-09  3:42   ` Reinette Chatre
2024-04-11 14:28     ` Dave Martin
2024-04-11 17:43       ` Reinette Chatre
2024-04-12 16:20         ` Dave Martin
2024-04-15 18:03           ` Reinette Chatre
2024-04-17 14:42             ` Dave Martin
2024-03-21 16:51 ` [PATCH v1 31/31] x86/resctrl: Move the resctrl filesystem code to /fs/resctrl James Morse
2024-03-26 19:44   ` Fenghua Yu
2024-04-11 14:30     ` Dave Martin
2024-04-11 17:45       ` Reinette Chatre
2024-04-12 16:20         ` Dave Martin
2024-04-09  3:43   ` Reinette Chatre
2024-04-11 14:38     ` Dave Martin
2024-04-15 20:44   ` Moger, Babu
2024-04-17 14:43     ` Dave Martin
2024-06-14 13:59       ` James Morse
2024-04-09  3:13 ` [PATCH v1 00/31] " Reinette Chatre
2024-04-11 14:38   ` Dave Martin
2024-04-18 15:32   ` Dave Martin
2024-04-20  4:06     ` Reinette Chatre
2024-04-22 13:51       ` Moger, Babu
2024-04-22 16:01         ` Reinette Chatre
2024-04-22 18:35           ` Moger, Babu
2024-04-22 18:39           ` Peter Newman
2024-04-23 12:37             ` Dave Martin
2024-06-14 13:59   ` James Morse
2024-04-11 13:52 ` Dave Martin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=Zh6kchkH9Dy+ywXc@e133380.arm.com \
    --to=dave.martin@arm.com \
    --cc=Babu.Moger@amd.com \
    --cc=amitsinght@marvell.com \
    --cc=baolin.wang@linux.alibaba.com \
    --cc=bobo.shaobowang@huawei.com \
    --cc=bp@alien8.de \
    --cc=carl@os.amperecomputing.com \
    --cc=david@redhat.com \
    --cc=dfustini@baylibre.com \
    --cc=fenghua.yu@intel.com \
    --cc=hpa@zytor.com \
    --cc=james.morse@arm.com \
    --cc=lcherian@marvell.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@redhat.com \
    --cc=peternewman@google.com \
    --cc=quic_jiles@quicinc.com \
    --cc=reinette.chatre@intel.com \
    --cc=rex.nie@jaguarmicro.com \
    --cc=scott@os.amperecomputing.com \
    --cc=shameerali.kolothum.thodi@huawei.com \
    --cc=tan.shaopeng@fujitsu.com \
    --cc=tglx@linutronix.de \
    --cc=x86@kernel.org \
    --cc=xhao@linux.alibaba.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®