* [PATCH] media: qcom: venus: add callback parameter names
@ 2026-06-04 0:18 Hungyu Lin
2026-06-07 21:33 ` Dmitry Baryshkov
2026-06-08 6:22 ` Vishnu Reddy
0 siblings, 2 replies; 3+ messages in thread
From: Hungyu Lin @ 2026-06-04 0:18 UTC (permalink / raw)
To: vikash.garodia, bod, mchehab
Cc: linux-media, linux-arm-msm, linux-kernel, Hungyu Lin
Naming the callback parameters improves readability and resolves
checkpatch warnings about unnamed function pointer arguments.
No functional change intended.
Signed-off-by: Hungyu Lin <dennylin0707@gmail.com>
---
drivers/media/platform/qcom/venus/hfi_msgs.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/media/platform/qcom/venus/hfi_msgs.c b/drivers/media/platform/qcom/venus/hfi_msgs.c
index 47b99d5b5af7..5c2025c5acc7 100644
--- a/drivers/media/platform/qcom/venus/hfi_msgs.c
+++ b/drivers/media/platform/qcom/venus/hfi_msgs.c
@@ -690,7 +690,7 @@ struct hfi_done_handler {
u32 pkt;
u32 pkt_sz;
u32 pkt_sz2;
- void (*done)(struct venus_core *, struct venus_inst *, void *);
+ void (*done)(struct venus_core *core, struct venus_inst *inst, void *packet);
bool is_sys_pkt;
};
--
2.34.1
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] media: qcom: venus: add callback parameter names
2026-06-04 0:18 [PATCH] media: qcom: venus: add callback parameter names Hungyu Lin
@ 2026-06-07 21:33 ` Dmitry Baryshkov
2026-06-08 6:22 ` Vishnu Reddy
1 sibling, 0 replies; 3+ messages in thread
From: Dmitry Baryshkov @ 2026-06-07 21:33 UTC (permalink / raw)
To: Hungyu Lin
Cc: vikash.garodia, bod, mchehab, linux-media, linux-arm-msm, linux-kernel
On Thu, Jun 04, 2026 at 12:18:59AM +0000, Hungyu Lin wrote:
> Naming the callback parameters improves readability and resolves
> checkpatch warnings about unnamed function pointer arguments.
>
> No functional change intended.
>
> Signed-off-by: Hungyu Lin <dennylin0707@gmail.com>
> ---
> drivers/media/platform/qcom/venus/hfi_msgs.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
Reviewed-by: Dmitry Baryshkov <dmitry.baryshkov@oss.qualcomm.com>
--
With best wishes
Dmitry
^ permalink raw reply [flat|nested] 3+ messages in thread
* Re: [PATCH] media: qcom: venus: add callback parameter names
2026-06-04 0:18 [PATCH] media: qcom: venus: add callback parameter names Hungyu Lin
2026-06-07 21:33 ` Dmitry Baryshkov
@ 2026-06-08 6:22 ` Vishnu Reddy
1 sibling, 0 replies; 3+ messages in thread
From: Vishnu Reddy @ 2026-06-08 6:22 UTC (permalink / raw)
To: Hungyu Lin, vikash.garodia, bod, mchehab
Cc: linux-media, linux-arm-msm, linux-kernel
On 6/4/2026 5:48 AM, Hungyu Lin wrote:
> Naming the callback parameters improves readability and resolves
> checkpatch warnings about unnamed function pointer arguments.
>
> No functional change intended.
>
> Signed-off-by: Hungyu Lin <dennylin0707@gmail.com>
> ---
> drivers/media/platform/qcom/venus/hfi_msgs.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/media/platform/qcom/venus/hfi_msgs.c b/drivers/media/platform/qcom/venus/hfi_msgs.c
> index 47b99d5b5af7..5c2025c5acc7 100644
> --- a/drivers/media/platform/qcom/venus/hfi_msgs.c
> +++ b/drivers/media/platform/qcom/venus/hfi_msgs.c
> @@ -690,7 +690,7 @@ struct hfi_done_handler {
> u32 pkt;
> u32 pkt_sz;
> u32 pkt_sz2;
> - void (*done)(struct venus_core *, struct venus_inst *, void *);
> + void (*done)(struct venus_core *core, struct venus_inst *inst, void *packet);
> bool is_sys_pkt;
> };
>
Reviewed-by: Vishnu Reddy <busanna.reddy@oss.qualcomm.com>
^ permalink raw reply [flat|nested] 3+ messages in thread
end of thread, other threads:[~2026-06-08 6:22 UTC | newest]
Thread overview: 3+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-06-04 0:18 [PATCH] media: qcom: venus: add callback parameter names Hungyu Lin
2026-06-07 21:33 ` Dmitry Baryshkov
2026-06-08 6:22 ` Vishnu Reddy
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®