mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH V1 0/3] Redesign memory deposit logic
@ 2026-09-08  2:13 Mukesh R
  2026-09-08  2:13 ` [PATCH V1 1/3] mshv: Rename memory deposit memory functions to _old Mukesh R
                   ` (2 more replies)
  0 siblings, 3 replies; 12+ messages in thread
From: Mukesh R @ 2026-09-08  2:13 UTC (permalink / raw)
  To: linux-hyperv, linux-kernel; +Cc: kys, wei.liu, mhkelley58, mrathor

This small series redesigns the memory deposit logic when Linux runs on
Hyper-V hypervisor as a privileged VM, the second patch explains why.
The series is split in three patches, the first patch renames the
functions to _old and this makes the 2 main patch much easier and nicer
to review. Last patch just removes the *_old functions from first patch.

Thanks,
-Mukesh

V1:
 o Remove hv_alloc_contig_pages() and make contiguous allocation part of
   hv_alloc_dep_pages(), thus getting rid of the kmalloc.
 o Instead of stubbing out functions, rename them to *_old.

Mukesh R (3):
  mshv: Rename memory deposit memory functions to old
  mshv: Redesign hypervisor memory deposit logic
  mshv: Remove unused *_old memory deposit functions

 drivers/hv/hv_proc.c           | 250 +++++++++++++++++++--------------
 drivers/hv/mshv_root_hv_call.c |  10 +-
 include/asm-generic/mshyperv.h |   5 -
 3 files changed, 145 insertions(+), 120 deletions(-)

-- 
2.51.2.vfs.0.1


^ permalink raw reply	[flat|nested] 12+ messages in thread

end of thread, other threads:[~2026-09-09 18:22 UTC | newest]

Thread overview: 12+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-09-08  2:13 [PATCH V1 0/3] Redesign memory deposit logic Mukesh R
2026-09-08  2:13 ` [PATCH V1 1/3] mshv: Rename memory deposit memory functions to _old Mukesh R
2026-09-08 18:01   ` Michael Kelley
2026-09-08 20:43     ` Mukesh R
2026-09-08 21:31       ` Michael Kelley
2026-09-08  2:13 ` [PATCH V1 2/3] mshv: Redesign hypervisor memory deposit logic Mukesh R
2026-09-08 18:02   ` Michael Kelley
2026-09-08 22:32     ` Mukesh R
2026-09-09 17:32       ` Michael Kelley
2026-09-09 18:22         ` Mukesh R
2026-09-08  2:13 ` [PATCH V1 3/3] mshv: Remove unused *_old memory deposit functions Mukesh R
2026-09-08 18:03   ` Michael Kelley

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®