mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Yuan-Hsin Chen <yuanlmm@gmail.com>
To: Tejun Heo <tj@kernel.org>
Cc: jgarzik@pobox.com, linux-ide@vger.kernel.org,
	linux-kernel@vger.kernel.org, sshtylyov@mvista.com,
	Yuan-Hsin Chen <yhchen@faraday-tech.com>
Subject: Re: [PATCH v4] ahci: move ahci_sb600_softreset to libahci.c and rename it
Date: Mon, 20 Jun 2011 18:06:52 +0800	[thread overview]
Message-ID: <BANLkTi=dgTNUESCstJNFUg6_YLbfwpNF5g@mail.gmail.com> (raw)
In-Reply-To: <20110620081937.GN2611@htj.dyndns.org>

Hello.

On Mon, Jun 20, 2011 at 4:19 PM, Tejun Heo <tj@kernel.org> wrote:
> Hello, Yuan.
>
> Yeap, almost there, just few very minor things. :)
>
> On Mon, Jun 20, 2011 at 04:06:41PM +0800, Yuan-Hsin Chen wrote:
>>  static struct ata_port_operations ahci_sb600_ops = {
>>       .inherits               = &ahci_ops,
>> -     .softreset              = ahci_sb600_softreset,
>> -     .pmp_softreset          = ahci_sb600_softreset,
>> +     .softreset              = ahci_pmp_retry_srst_softreset,
>>  };
>
> Why doesn't sb600 just use ahci_pmp_retry_srst_ops?
>
>> @@ -312,6 +312,7 @@ extern struct device_attribute *ahci_sdev_attrs[];
>>       .sdev_attrs             = ahci_sdev_attrs
>>
>>  extern struct ata_port_operations ahci_ops;
>> +extern struct ata_port_operations ahci_pmp_retry_srst_ops;
>
> Heh, I know I suggested that name but that is one ugly name.  If
> anyone has any better idea, please come forward.

How about ahci_pmp_workaround_softreset or ahci_pmp_ipms_set_softreset?
Also applys to ops, ahci_pmp_workaround_ops or ahci_pmp_ipms_set_ops.

>
>> @@ -82,6 +82,8 @@ static void ahci_pmp_attach(struct ata_port *ap);
>>  static void ahci_pmp_detach(struct ata_port *ap);
>>  static int ahci_softreset(struct ata_link *link, unsigned int *class,
>>                         unsigned long deadline);
>> +static int ahci_pmp_retry_srst_softreset(struct ata_link *link, unsigned int *class,
>> +                       unsigned long deadline);
>
> srst equals softreset, so ahci_pmp_retry_softreset() should do.
>
>> +struct ata_port_operations ahci_pmp_retry_srst_ops = {
>> +     .inherits               = &ahci_ops,
>> +     .softreset              = ahci_pmp_retry_srst_softreset,
>> +};
>> +EXPORT_SYMBOL_GPL(ahci_pmp_retry_srst_ops);
>> +
>>  struct ata_port_operations ahci_ops = {
>>       .inherits               = &sata_pmp_port_ops,
>
> Maybe it's better to place ahci_pmp_retry_srst_ops after ahci_ops?
>
>> +static int ahci_pmp_check_ready(struct ata_link *link)
>
> It would be better if the name reflects that it's not for specific
> workaround.
>
> Thank you.
>
> --
> tejun
>

  reply	other threads:[~2011-06-20 10:06 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2011-06-14  5:48 [PATCH] ahci: enable pmp but connected to HDD issue fixed Yuan-Hsin Chen
2011-06-14  6:52 ` Tejun Heo
2011-06-15 10:04   ` [PATCH v2] ahci: fix pmp softreset with HDD Yuan-Hsin Chen
2011-06-15 10:14     ` Tejun Heo
2011-06-17 10:39       ` [PATCH v3] ahci: move ahci_sb600_softreset to libahci.c and rename it Yuan-Hsin Chen
2011-06-17 11:34         ` Sergei Shtylyov
2011-06-17 12:07         ` Tejun Heo
2011-06-20  8:06           ` [PATCH v4] " Yuan-Hsin Chen
2011-06-20  8:15             ` Sergei Shtylyov
2011-06-20  8:47               ` Yuan-Hsin Chen
2011-06-20  8:19             ` Tejun Heo
2011-06-20 10:06               ` Yuan-Hsin Chen [this message]
2011-06-20 12:47                 ` Tejun Heo
2011-06-21  3:24               ` Yuan-Hsin Chen
2011-06-21  7:17                 ` Tejun Heo
2011-06-21  9:17                   ` [PATCH v5] " Yuan-Hsin Chen
2011-06-21  9:53                     ` Tejun Heo
     [not found] ` <BANLkTimiJheFauWXjh-8GszGHoqMOa0Kkw@mail.gmail.com>
2011-06-15  2:50   ` Fwd: [PATCH] ahci: enable pmp but connected to HDD issue fixed BingJiun Luo

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to='BANLkTi=dgTNUESCstJNFUg6_YLbfwpNF5g@mail.gmail.com' \
    --to=yuanlmm@gmail.com \
    --cc=jgarzik@pobox.com \
    --cc=linux-ide@vger.kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=sshtylyov@mvista.com \
    --cc=tj@kernel.org \
    --cc=yhchen@faraday-tech.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®