mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 2/2] lsm: rename variable to avoid shadowing
@ 2024-11-25 10:59 Christian Göttsche
  2024-11-25 10:59 ` [PATCH 1/2] lsm: constify function parameters Christian Göttsche
  2025-01-05  3:04 ` [PATCH 2/2] lsm: rename variable to avoid shadowing Paul Moore
  0 siblings, 2 replies; 4+ messages in thread
From: Christian Göttsche @ 2024-11-25 10:59 UTC (permalink / raw)
  Cc: Christian Göttsche, Paul Moore, James Morris,
	Serge E. Hallyn, Nathan Chancellor, Nick Desaulniers,
	Bill Wendling, Justin Stitt, linux-security-module, linux-kernel,
	llvm

From: Christian Göttsche <cgzones@googlemail.com>

The function dump_common_audit_data() contains two variables with the
name comm: one declared at the top and one nested one.
Rename the nested variable to improve readability and make future refactorings
of the function less error prone.

Reported by clang:

    security/lsm_audit.c:302:10: error: declaration shadows a local variable [-Werror,-Wshadow]
      302 |                                 char comm[sizeof(tsk->comm)];
          |                                      ^
    security/lsm_audit.c:200:7: note: previous declaration is here
      200 |         char comm[sizeof(current->comm)];
          |              ^

Signed-off-by: Christian Göttsche <cgzones@googlemail.com>
---
 security/lsm_audit.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/security/lsm_audit.c b/security/lsm_audit.c
index f1fe99f2221d..429096bf8fe0 100644
--- a/security/lsm_audit.c
+++ b/security/lsm_audit.c
@@ -299,10 +299,10 @@ static void dump_common_audit_data(struct audit_buffer *ab,
 		if (tsk) {
 			pid_t pid = task_tgid_nr(tsk);
 			if (pid) {
-				char comm[sizeof(tsk->comm)];
+				char tskcomm[sizeof(tsk->comm)];
 				audit_log_format(ab, " opid=%d ocomm=", pid);
 				audit_log_untrustedstring(ab,
-				    memcpy(comm, tsk->comm, sizeof(comm)));
+				    memcpy(tskcomm, tsk->comm, sizeof(tskcomm)));
 			}
 		}
 		break;
-- 
2.45.2


^ permalink raw reply	[flat|nested] 4+ messages in thread

end of thread, other threads:[~2025-01-05  3:04 UTC | newest]

Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-11-25 10:59 [PATCH 2/2] lsm: rename variable to avoid shadowing Christian Göttsche
2024-11-25 10:59 ` [PATCH 1/2] lsm: constify function parameters Christian Göttsche
2025-01-05  3:04   ` Paul Moore
2025-01-05  3:04 ` [PATCH 2/2] lsm: rename variable to avoid shadowing Paul Moore

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®