From: Reinette Chatre <reinette.chatre@intel.com>
To: Maciej Wieczor-Retman <maciej.wieczor-retman@intel.com>,
Fenghua Yu <fenghua.yu@intel.com>,
Thomas Gleixner <tglx@linutronix.de>,
Ingo Molnar <mingo@redhat.com>, Borislav Petkov <bp@alien8.de>,
Dave Hansen <dave.hansen@linux.intel.com>, <x86@kernel.org>,
"H. Peter Anvin" <hpa@zytor.com>
Cc: <linux-kernel@vger.kernel.org>
Subject: Re: [PATCH v2 4/4] x86/resctrl: Rename arch_has_sparse_bitmaps
Date: Thu, 28 Sep 2023 13:47:49 -0700 [thread overview]
Message-ID: <a1eedcbb-3797-dc0a-918f-eea8a58bbf52@intel.com> (raw)
In-Reply-To: <e689caf9dbb7664c26515a980084b5f17cb0644e.1695371055.git.maciej.wieczor-retman@intel.com>
Hi Maciej
Could you please move this patch to the beginning of this series?
Having it in the end results in a lot of churn with significant
changes to new code introduced in this series. All this can be avoided
by providing a smaller patch at the beginning of the series.
On 9/22/2023 1:48 AM, Maciej Wieczor-Retman wrote:
> Both AMD and Intel documentations use capacity bitmasks terminology
> rather than capacity bitmaps. Also bitmask term is much more widely
> used inside x86 resctrl code.
Since resctrl is intended to support many architectures and Arm coming
soon (and they use bitmap) I do not think we should use the vendor's
language as a motivation. For me there are three reasons supporting the
rename:
* arch_has_sparse_bitmaps is the *only* instance in resctrl that uses
the bitmap term for capacity bitmasks, all other parts of resctrl refers
to it as a bitmask
* bitmask is the established term used in resctrl documentation
(Documentation/arch/x86/resctrl.rst)
* bitmask is the term already exposed to user space via resctrl ("cbm_mask")
Finally, why do the rename as part of this work? This can be motivated
with something like:
A later patch exposes the value of arch_has_sparse_bitmaps to
user space via the existing term of a bitmask. Rename
arch_has_sparse_bitmaps to arch_has_sparse_bitmasks to ensure
consistent terminology throughout resctrl.
>
> Unify the naming convention by renaming arch_has_sparse_bitmaps struct
> member to arch_has_sparse_bitmasks.
>
> Suggested-by: Reinette Chatre <reinette.chatre@intel.com>
> Signed-off-by: Maciej Wieczor-Retman <maciej.wieczor-retman@intel.com>
> ---
...
> diff --git a/include/linux/resctrl.h b/include/linux/resctrl.h
> index 8334eeacfec5..83c2cbf7136d 100644
> --- a/include/linux/resctrl.h
> +++ b/include/linux/resctrl.h
> @@ -57,7 +57,7 @@ struct resctrl_staged_config {
> * @list: all instances of this resource
> * @id: unique id for this instance
> * @cpu_mask: which CPUs share this resource
> - * @rmid_busy_llc: bitmap of which limbo RMIDs are above threshold
> + * @rmid_busy_llc: bitmask of which limbo RMIDs are above threshold
> * @mbm_total: saved state for MBM total bandwidth
> * @mbm_local: saved state for MBM local bandwidth
> * @mbm_over: worker to periodically read MBM h/w counters
Please drop this hunk. rmid_busy_llc is indeed a bitmap.
Reinette
next prev parent reply other threads:[~2023-09-28 20:54 UTC|newest]
Thread overview: 23+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-09-22 8:47 [PATCH v2 0/4] x86/resctrl: Non-contiguous bitmasks in Intel CAT Maciej Wieczor-Retman
2023-09-22 8:48 ` [PATCH v2 1/4] x86/resctrl: Enable non-contiguous bits " Maciej Wieczor-Retman
2023-09-22 14:14 ` Peter Newman
2023-09-27 9:20 ` Maciej Wieczór-Retman
2023-09-27 10:08 ` Peter Newman
2023-09-27 10:44 ` Maciej Wieczór-Retman
2023-09-27 15:03 ` Tony Luck
2023-09-27 22:34 ` Moger, Babu
2023-09-28 7:06 ` Maciej Wieczór-Retman
2023-09-28 15:08 ` Moger, Babu
2023-09-28 15:53 ` Reinette Chatre
2023-09-28 16:28 ` Moger, Babu
2023-09-22 8:48 ` [PATCH v2 2/4] x86/resctrl: Add sparse_masks file in info Maciej Wieczor-Retman
2023-09-28 20:47 ` Reinette Chatre
2023-09-29 6:22 ` Maciej Wieczór-Retman
2023-09-22 8:48 ` [PATCH v2 3/4] Documentation/x86: Document resctrl's new sparse_masks Maciej Wieczor-Retman
2023-09-27 22:47 ` Moger, Babu
2023-09-27 22:58 ` Reinette Chatre
2023-09-27 23:02 ` Fenghua Yu
2023-09-28 13:59 ` Moger, Babu
2023-09-22 8:48 ` [PATCH v2 4/4] x86/resctrl: Rename arch_has_sparse_bitmaps Maciej Wieczor-Retman
2023-09-28 20:47 ` Reinette Chatre [this message]
2023-09-29 6:20 ` Maciej Wieczór-Retman
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=a1eedcbb-3797-dc0a-918f-eea8a58bbf52@intel.com \
--to=reinette.chatre@intel.com \
--cc=bp@alien8.de \
--cc=dave.hansen@linux.intel.com \
--cc=fenghua.yu@intel.com \
--cc=hpa@zytor.com \
--cc=linux-kernel@vger.kernel.org \
--cc=maciej.wieczor-retman@intel.com \
--cc=mingo@redhat.com \
--cc=tglx@linutronix.de \
--cc=x86@kernel.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®