From: Julia Lawall <julia.lawall@lip6.fr>
To: Amitoj Kaur Chawla <amitoj1606@gmail.com>
Cc: SF Markus Elfring <elfring@users.sourceforge.net>,
LKML <linux-kernel@vger.kernel.org>,
Coccinelle <cocci@systeme.lip6.fr>,
Gilles Muller <Gilles.Muller@lip6.fr>,
Julia Lawall <julia.lawall@lip6.fr>,
Michal Marek <mmarek@suse.com>,
Nicolas Palix <nicolas.palix@imag.fr>
Subject: Re: [Cocci] [PATCH v3] Coccinelle: Script to replace allocate and memset with zalloc functions
Date: Fri, 19 Aug 2016 08:41:51 -0400 (EDT) [thread overview]
Message-ID: <alpine.DEB.2.10.1608190841310.3078@hadrien> (raw)
In-Reply-To: <CA+5yK5HNhcYV+OWhvvgax-fvbtSXEHgPh0mxzWFPFc6-ubzJEQ@mail.gmail.com>
On Fri, 19 Aug 2016, Amitoj Kaur Chawla wrote:
> On Mon, Aug 1, 2016 at 4:53 PM, SF Markus Elfring
> <elfring@users.sourceforge.net> wrote:
> >> +@vz1 depends on patch && !context && !org && !report@
> >> +type T;
> >> +T *d;
> >> +statement S;
> >> +@@
> >> +
> >> + d =
> >> +- vmalloc
> >> ++ vzalloc
> >> + (...);
> >> + if (!d) S
> >> +- memset(d, 0, sizeof(T));
> >> +
> >> +@vz2 depends on patch && !context && !org && !report@
> >> +expression d;
> >> +statement S;
> >> +@@
> >> +
> >> + d =
> >> +- vmalloc
> >> ++ vzalloc
> >> + (...);
> >> + if (!d) S
> >> +- memset(d, 0, sizeof(*d));
> >
> > I suggest to take another look at a few implementation details.
> >
> > 1. Would it make sense to merge such SmPL rules into one
> > so that code duplication could be reduced a bit
> > in such a script?
> >
> > 2. How do you think about to extend the shown check list
> > with the function "kvm_kvzalloc"?
> >
>
> Hi Markus,
>
> kvm_kvzalloc function doesn't fit the same pattern as the other
> functions in this semantic patch, and is kvm specific, so the
> semantic patch looks fine as is.
Acked-by: Julia Lawall <julia.lawall@lip6.fr>
>
> Thanks,
> Amitoj
>
> > 3. Do you want to maintain a growing (?) function name list manually?
> >
> > Regards,
> > Markus
>
next prev parent reply other threads:[~2016-08-19 12:42 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-01 7:02 Amitoj Kaur Chawla
2016-08-01 11:23 ` [Cocci] " SF Markus Elfring
2016-08-01 11:37 ` Julia Lawall
2016-08-01 11:56 ` SF Markus Elfring
2016-08-01 12:03 ` Julia Lawall
2016-08-01 12:24 ` SF Markus Elfring
2016-08-01 12:32 ` Julia Lawall
2016-08-01 12:45 ` SF Markus Elfring
2016-08-19 12:14 ` Amitoj Kaur Chawla
2016-08-19 12:41 ` Julia Lawall [this message]
2016-08-19 13:26 ` [Cocci] " SF Markus Elfring
2016-08-19 13:30 ` Julia Lawall
2016-08-19 16:56 ` SF Markus Elfring
2017-03-03 10:34 ` [Cocci] [PATCH v3] " SF Markus Elfring
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=alpine.DEB.2.10.1608190841310.3078@hadrien \
--to=julia.lawall@lip6.fr \
--cc=Gilles.Muller@lip6.fr \
--cc=amitoj1606@gmail.com \
--cc=cocci@systeme.lip6.fr \
--cc=elfring@users.sourceforge.net \
--cc=linux-kernel@vger.kernel.org \
--cc=mmarek@suse.com \
--cc=nicolas.palix@imag.fr \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome