From: SF Markus Elfring <elfring@users.sourceforge.net>
To: Amitoj Kaur Chawla <amitoj1606@gmail.com>
Cc: LKML <linux-kernel@vger.kernel.org>,
Coccinelle <cocci@systeme.lip6.fr>,
Gilles Muller <Gilles.Muller@lip6.fr>,
Julia Lawall <julia.lawall@lip6.fr>,
Michal Marek <mmarek@suse.com>,
Nicolas Palix <nicolas.palix@imag.fr>
Subject: Re: [Cocci] [PATCH v3] Coccinelle: Script to replace allocate and memset with zalloc functions
Date: Mon, 1 Aug 2016 13:23:33 +0200 [thread overview]
Message-ID: <d3dde65e-a1d5-54ba-d65f-9e996bb4f8f5@users.sourceforge.net> (raw)
In-Reply-To: <20160801070233.GA19102@amitoj-Inspiron-3542>
> +@vz1 depends on patch && !context && !org && !report@
> +type T;
> +T *d;
> +statement S;
> +@@
> +
> + d =
> +- vmalloc
> ++ vzalloc
> + (...);
> + if (!d) S
> +- memset(d, 0, sizeof(T));
> +
> +@vz2 depends on patch && !context && !org && !report@
> +expression d;
> +statement S;
> +@@
> +
> + d =
> +- vmalloc
> ++ vzalloc
> + (...);
> + if (!d) S
> +- memset(d, 0, sizeof(*d));
I suggest to take another look at a few implementation details.
1. Would it make sense to merge such SmPL rules into one
so that code duplication could be reduced a bit
in such a script?
2. How do you think about to extend the shown check list
with the function "kvm_kvzalloc"?
3. Do you want to maintain a growing (?) function name list manually?
Regards,
Markus
next prev parent reply other threads:[~2016-08-01 11:24 UTC|newest]
Thread overview: 14+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-01 7:02 Amitoj Kaur Chawla
2016-08-01 11:23 ` SF Markus Elfring [this message]
2016-08-01 11:37 ` [Cocci] " Julia Lawall
2016-08-01 11:56 ` SF Markus Elfring
2016-08-01 12:03 ` Julia Lawall
2016-08-01 12:24 ` SF Markus Elfring
2016-08-01 12:32 ` Julia Lawall
2016-08-01 12:45 ` SF Markus Elfring
2016-08-19 12:14 ` Amitoj Kaur Chawla
2016-08-19 12:41 ` Julia Lawall
2016-08-19 13:26 ` [Cocci] " SF Markus Elfring
2016-08-19 13:30 ` Julia Lawall
2016-08-19 16:56 ` SF Markus Elfring
2017-03-03 10:34 ` [Cocci] [PATCH v3] " SF Markus Elfring
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d3dde65e-a1d5-54ba-d65f-9e996bb4f8f5@users.sourceforge.net \
--to=elfring@users.sourceforge.net \
--cc=Gilles.Muller@lip6.fr \
--cc=amitoj1606@gmail.com \
--cc=cocci@systeme.lip6.fr \
--cc=julia.lawall@lip6.fr \
--cc=linux-kernel@vger.kernel.org \
--cc=mmarek@suse.com \
--cc=nicolas.palix@imag.fr \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome