mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Julia Lawall <julia.lawall@lip6.fr>
To: SF Markus Elfring <elfring@users.sourceforge.net>
Cc: Amitoj Kaur Chawla <amitoj1606@gmail.com>,
	LKML <linux-kernel@vger.kernel.org>,
	Coccinelle <cocci@systeme.lip6.fr>,
	Gilles Muller <Gilles.Muller@lip6.fr>,
	Michal Marek <mmarek@suse.com>,
	Nicolas Palix <nicolas.palix@imag.fr>
Subject: Re: [Cocci] Coccinelle: Script to replace allocate and memset with zalloc functions
Date: Fri, 19 Aug 2016 09:30:01 -0400 (EDT)	[thread overview]
Message-ID: <alpine.DEB.2.10.1608190928520.3078@hadrien> (raw)
In-Reply-To: <33c75c5f-59d5-5fd4-6767-6144b4f245bc@users.sourceforge.net>

[-- Attachment #1: Type: TEXT/PLAIN, Size: 980 bytes --]



On Fri, 19 Aug 2016, SF Markus Elfring wrote:

> >> I suggest to take another look at a few implementation details.
> >>
> >> 1. Would it make sense to merge such SmPL rules into one
> >>    so that code duplication could be reduced a bit
> >>    in such a script?
> >>
> >> 2. How do you think about to extend the shown check list
> >>    with the function "kvm_kvzalloc"?
> …
> > kvm_kvzalloc function doesn't fit the same pattern as the other
> > functions in this semantic patch, and is kvm specific,
>
> Has this one got a similar function property?

Do you have any example where XXX followed by memset is converted to this
function?

>
> Do you prefer to exclude such functions which belong to subsystems
> so far generally?

Yes, because it would introduce unwanted dependencies.

>
> > so the semantic patch looks fine as is.
>
> How do you think about to express the shown source code repetition
> as an aspect by an other script format?

It is fine as it is.

julia

  reply	other threads:[~2016-08-19 13:31 UTC|newest]

Thread overview: 14+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2016-08-01  7:02 [PATCH v3] " Amitoj Kaur Chawla
2016-08-01 11:23 ` [Cocci] " SF Markus Elfring
2016-08-01 11:37   ` Julia Lawall
2016-08-01 11:56     ` SF Markus Elfring
2016-08-01 12:03       ` Julia Lawall
2016-08-01 12:24         ` SF Markus Elfring
2016-08-01 12:32           ` Julia Lawall
2016-08-01 12:45             ` SF Markus Elfring
2016-08-19 12:14   ` Amitoj Kaur Chawla
2016-08-19 12:41     ` Julia Lawall
2016-08-19 13:26     ` [Cocci] " SF Markus Elfring
2016-08-19 13:30       ` Julia Lawall [this message]
2016-08-19 16:56         ` SF Markus Elfring
2017-03-03 10:34 ` [Cocci] [PATCH v3] " SF Markus Elfring

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.DEB.2.10.1608190928520.3078@hadrien \
    --to=julia.lawall@lip6.fr \
    --cc=Gilles.Muller@lip6.fr \
    --cc=amitoj1606@gmail.com \
    --cc=cocci@systeme.lip6.fr \
    --cc=elfring@users.sourceforge.net \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mmarek@suse.com \
    --cc=nicolas.palix@imag.fr \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome