mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Linus Torvalds <torvalds@linux-foundation.org>
To: Rusty Russell <rusty@rustcorp.com.au>
Cc: Paul Menage <menage@google.com>,
	linux-kernel@vger.kernel.org, Matthew Wilcox <matthew@wil.cx>,
	"Randy.Dunlap" <rdunlap@xenotime.net>,
	Andrew Morton <akpm@linux-foundation.org>,
	Christoph Hellwig <hch@infradead.org>
Subject: Re: [PATCH] Introduce down_try() so we can move away from down_trylock()
Date: Sun, 3 Aug 2008 22:53:59 -0700 (PDT)	[thread overview]
Message-ID: <alpine.LFD.1.10.0808032251050.3668@nehalem.linux-foundation.org> (raw)
In-Reply-To: <200808041328.45773.rusty@rustcorp.com.au>



On Mon, 4 Aug 2008, Rusty Russell wrote:
> 
> Someone sent me a patch documenting the illogic of down_trylock().  I decided 
> to try to fix it rather than just bitch and moan.

I do agree that it is illogical. I just think your solution is worse than 
the problem - turning one illogical function into a redundant one seems 
the worse problem.

We could just fix the return value, since it's not used very much, but 
we'd obviously never know what out-of-tree users there might be, so that's 
not really a good solution either. But that's obviously why we'd then have 
to rename it to something else, so whichever way we turn, we'd just be 
screwed.

I'm much happier telling people to "just don't use semaphores any more".
The _legacy_ users get down_trylock() right. 

		Linus

  reply	other threads:[~2008-08-04  5:54 UTC|newest]

Thread overview: 17+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-07-29  0:15 Rusty Russell
2008-07-29  0:27 ` Paul Menage
2008-07-29 13:01   ` Rusty Russell
2008-07-29 16:21     ` Randy Dunlap
2008-07-29 23:56       ` Rusty Russell
2008-08-01 17:26     ` Linus Torvalds
2008-08-01 17:40       ` Andrew Morton
2008-08-01 18:22         ` Linus Torvalds
2008-08-03  8:33       ` Rusty Russell
2008-08-03 13:07         ` Matthew Wilcox
2008-08-03 17:33         ` Linus Torvalds
2008-08-03 17:35           ` Linus Torvalds
2008-08-04  3:28             ` Rusty Russell
2008-08-04  5:53               ` Linus Torvalds [this message]
2008-08-04  7:57                 ` Rusty Russell
2008-08-04  8:45                   ` Alan Cox
2008-08-04 11:43                     ` Rusty Russell

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=alpine.LFD.1.10.0808032251050.3668@nehalem.linux-foundation.org \
    --to=torvalds@linux-foundation.org \
    --cc=akpm@linux-foundation.org \
    --cc=hch@infradead.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=matthew@wil.cx \
    --cc=menage@google.com \
    --cc=rdunlap@xenotime.net \
    --cc=rusty@rustcorp.com.au \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome