From: Yunsheng Lin <linyunsheng@huawei.com>
To: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Cc: <netdev@vger.kernel.org>,
Jesper Dangaard Brouer <hawk@kernel.org>,
"David S. Miller" <davem@davemloft.net>,
Eric Dumazet <edumazet@google.com>,
Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH net-next] page_pool: Rename frag_users to frag_cnt
Date: Thu, 21 Dec 2023 10:07:26 +0800 [thread overview]
Message-ID: <d853acde-7d69-c715-4207-fb77da1fb203@huawei.com> (raw)
In-Reply-To: <CAC_iWjKH5ZCUwVWc2EisfjeLVF=ko967hqpdAc7G4FdsZCq7NA@mail.gmail.com>
On 2023/12/20 15:56, Ilias Apalodimas wrote:
> Hi Yunsheng,
>>>>> #ifdef CONFIG_PAGE_POOL_STATS
>>>>> /* these stats are incremented while in softirq context */
>>>>> diff --git a/net/core/page_pool.c b/net/core/page_pool.c
>>>>> index 9b203d8660e4..19a56a52ac8f 100644
>>>>> --- a/net/core/page_pool.c
>>>>> +++ b/net/core/page_pool.c
>>>>> @@ -659,7 +659,7 @@ EXPORT_SYMBOL(page_pool_put_page_bulk);
>>>>> static struct page *page_pool_drain_frag(struct page_pool *pool,
>>>>> struct page *page)
>>>>> {
>>>>> - long drain_count = BIAS_MAX - pool->frag_users;
>>>>> + long drain_count = BIAS_MAX - pool->frag_cnt;
>>>>
>>>> drain_count = pool->refcnt_bais;
>>>
>>> I think this is a typo right? This still remains
>>
>> It would be better to invert logic too, as it is mirroring:
>>
>> https://elixir.bootlin.com/linux/v6.7-rc5/source/mm/page_alloc.c#L4745
>
> This is still a bit confusing for me since the actual bias is the
> number of fragments that you initially split the page. But I am fine
Acctually there are two bais numbers for a page used by
page_pool_alloc_frag().
the one for page->pp_ref_count, which already use the BIAS_MAX, which
indicates the initial bais number:
https://elixir.bootlin.com/linux/latest/source/net/core/page_pool.c#L779
Another one for pool->frag_users indicating the runtime bais number, which
need changing when a page is split into more fragments:
https://elixir.bootlin.com/linux/latest/source/net/core/page_pool.c#L776
https://elixir.bootlin.com/linux/latest/source/net/core/page_pool.c#L783
> with having a common approach. I'll send the rename again shortly, and
> I can send the logic invert a bit later (or feel free to send it,
> since it was your idea).
>
> Thanks
> /Ilias
> .
>
next prev parent reply other threads:[~2023-12-21 2:07 UTC|newest]
Thread overview: 11+ messages / expand[flat|nested] mbox.gz Atom feed top
2023-12-15 7:31 Ilias Apalodimas
2023-12-15 7:43 ` Ilias Apalodimas
2023-12-15 11:09 ` Yunsheng Lin
2023-12-15 11:58 ` Ilias Apalodimas
2023-12-15 12:34 ` Yunsheng Lin
2023-12-20 7:56 ` Ilias Apalodimas
2023-12-21 2:07 ` Yunsheng Lin [this message]
2023-12-21 6:37 ` Ilias Apalodimas
2023-12-21 7:59 ` Yunsheng Lin
2023-12-21 8:24 ` Ilias Apalodimas
2023-12-21 9:39 ` Yunsheng Lin
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=d853acde-7d69-c715-4207-fb77da1fb203@huawei.com \
--to=linyunsheng@huawei.com \
--cc=davem@davemloft.net \
--cc=edumazet@google.com \
--cc=hawk@kernel.org \
--cc=ilias.apalodimas@linaro.org \
--cc=kuba@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=netdev@vger.kernel.org \
--cc=pabeni@redhat.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®