mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Yunsheng Lin <linyunsheng@huawei.com>
To: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Cc: <netdev@vger.kernel.org>,
	Jesper Dangaard Brouer <hawk@kernel.org>,
	"David S. Miller" <davem@davemloft.net>,
	Eric Dumazet <edumazet@google.com>,
	Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH net-next] page_pool: Rename frag_users to frag_cnt
Date: Thu, 21 Dec 2023 17:39:33 +0800	[thread overview]
Message-ID: <560730d0-937c-0497-e823-26c6cf72bff1@huawei.com> (raw)
In-Reply-To: <CAC_iWjJBcXu=Zz=UtDj1vR-s5+jhFx8GYoYpqOi-bQX7S3XgbA@mail.gmail.com>

On 2023/12/21 16:24, Ilias Apalodimas wrote:
> 
>> But if we use 'bias' as part of the name, isn't that more reasonable to set
>> both of the bias number to BIAS_MAX initially, and decrement the runtime
>> bais number every time the page is split to more fragments?
> 
> I think it's a matter of taste and how you interpret BIAS_MAX. In any
> case, page_pool_drain_frag() will eventually set the *real* number of
> references. But since the code can get complicated I like the idea of
> making it identical to the mm subsystem tracking.
> 
> Can we just merge v2 and me or you can send the logic inversion
> patches right after. They are orthogonal to the rename anyway

It is fine by me.
And I can send the logic inversion patch if v2 is merged.

      reply	other threads:[~2023-12-21  9:39 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-12-15  7:31 Ilias Apalodimas
2023-12-15  7:43 ` Ilias Apalodimas
2023-12-15 11:09 ` Yunsheng Lin
2023-12-15 11:58   ` Ilias Apalodimas
2023-12-15 12:34     ` Yunsheng Lin
2023-12-20  7:56       ` Ilias Apalodimas
2023-12-21  2:07         ` Yunsheng Lin
2023-12-21  6:37           ` Ilias Apalodimas
2023-12-21  7:59             ` Yunsheng Lin
2023-12-21  8:24               ` Ilias Apalodimas
2023-12-21  9:39                 ` Yunsheng Lin [this message]

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=560730d0-937c-0497-e823-26c6cf72bff1@huawei.com \
    --to=linyunsheng@huawei.com \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=hawk@kernel.org \
    --cc=ilias.apalodimas@linaro.org \
    --cc=kuba@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®