mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Yunsheng Lin <linyunsheng@huawei.com>
To: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Cc: <netdev@vger.kernel.org>,
	Jesper Dangaard Brouer <hawk@kernel.org>,
	"David S. Miller" <davem@davemloft.net>,
	Eric Dumazet <edumazet@google.com>,
	Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH net-next] page_pool: Rename frag_users to frag_cnt
Date: Fri, 15 Dec 2023 20:34:05 +0800	[thread overview]
Message-ID: <fb0f33d8-d09a-57fc-83b0-ccf152277355@huawei.com> (raw)
In-Reply-To: <CAC_iWjLiOdUqLmRHjZmwv9QBsBvYNV=zn30JrRbJa05qMyDBmw@mail.gmail.com>

On 2023/12/15 19:58, Ilias Apalodimas wrote:
> Hi Yunsheng,
> 
> On Fri, 15 Dec 2023 at 13:10, Yunsheng Lin <linyunsheng@huawei.com> wrote:
>>
>> On 2023/12/15 15:31, Ilias Apalodimas wrote:
>>> Since [0] got merged, it's clear that 'pp_ref_count' is used to track
>>> the number of users for each page. On struct_page though we have
>>> a member called 'frag_users'. Despite of what the name suggests this is
>>> not the number of users. It instead represents the number of fragments of
>>> the current page. When we have a single page this is set to one. When we
>>> split the page this is set to the actual number of frags and later used
>>> in page_pool_drain_frag() to infer the real number of users.
>>>
>>> So let's rename it to something that matches the description above
>>>
>>> [0]
>>> Link: https://lore.kernel.org/netdev/20231212044614.42733-2-liangchen.linux@gmail.com/
>>> Signed-off-by: Ilias Apalodimas <ilias.apalodimas@linaro.org>
>>> ---
>>>  include/net/page_pool.h | 2 +-
>>>  net/core/page_pool.c    | 8 ++++----
>>>  2 files changed, 5 insertions(+), 5 deletions(-)
>>>
>>> diff --git a/include/net/page_pool.h b/include/net/page_pool.h
>>> index 813c93499f20..957cd84bb3f4 100644
>>> --- a/include/net/page_pool.h
>>> +++ b/include/net/page_pool.h
>>> @@ -158,7 +158,7 @@ struct page_pool {
>>>       u32 pages_state_hold_cnt;
>>>       unsigned int frag_offset;
>>>       struct page *frag_page;
>>> -     long frag_users;
>>> +     long frag_cnt;
>>
>> I would rename it to something like refcnt_bais to mirror the pagecnt_bias
>> in struct page_frag_cache.
> 
> Sure
> 
>>
>>>
>>>  #ifdef CONFIG_PAGE_POOL_STATS
>>>       /* these stats are incremented while in softirq context */
>>> diff --git a/net/core/page_pool.c b/net/core/page_pool.c
>>> index 9b203d8660e4..19a56a52ac8f 100644
>>> --- a/net/core/page_pool.c
>>> +++ b/net/core/page_pool.c
>>> @@ -659,7 +659,7 @@ EXPORT_SYMBOL(page_pool_put_page_bulk);
>>>  static struct page *page_pool_drain_frag(struct page_pool *pool,
>>>                                        struct page *page)
>>>  {
>>> -     long drain_count = BIAS_MAX - pool->frag_users;
>>> +     long drain_count = BIAS_MAX - pool->frag_cnt;
>>
>> drain_count = pool->refcnt_bais;
> 
> I think this is a typo right? This still remains

It would be better to invert logic too, as it is mirroring:

https://elixir.bootlin.com/linux/v6.7-rc5/source/mm/page_alloc.c#L4745

  reply	other threads:[~2023-12-15 12:52 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-12-15  7:31 Ilias Apalodimas
2023-12-15  7:43 ` Ilias Apalodimas
2023-12-15 11:09 ` Yunsheng Lin
2023-12-15 11:58   ` Ilias Apalodimas
2023-12-15 12:34     ` Yunsheng Lin [this message]
2023-12-20  7:56       ` Ilias Apalodimas
2023-12-21  2:07         ` Yunsheng Lin
2023-12-21  6:37           ` Ilias Apalodimas
2023-12-21  7:59             ` Yunsheng Lin
2023-12-21  8:24               ` Ilias Apalodimas
2023-12-21  9:39                 ` Yunsheng Lin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=fb0f33d8-d09a-57fc-83b0-ccf152277355@huawei.com \
    --to=linyunsheng@huawei.com \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=hawk@kernel.org \
    --cc=ilias.apalodimas@linaro.org \
    --cc=kuba@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®