mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Yunsheng Lin <linyunsheng@huawei.com>
To: Ilias Apalodimas <ilias.apalodimas@linaro.org>
Cc: <netdev@vger.kernel.org>,
	Jesper Dangaard Brouer <hawk@kernel.org>,
	"David S. Miller" <davem@davemloft.net>,
	Eric Dumazet <edumazet@google.com>,
	Jakub Kicinski <kuba@kernel.org>, Paolo Abeni <pabeni@redhat.com>,
	<linux-kernel@vger.kernel.org>
Subject: Re: [PATCH net-next] page_pool: Rename frag_users to frag_cnt
Date: Thu, 21 Dec 2023 15:59:32 +0800	[thread overview]
Message-ID: <0dfffe91-2bd4-2151-cf71-ef29bf562767@huawei.com> (raw)
In-Reply-To: <CAC_iWjL04RRFCU13yejUONvvY0dzYO1scAzNOC+auWpFDctzAA@mail.gmail.com>

On 2023/12/21 14:37, Ilias Apalodimas wrote:
> Hi Yunsheng,
> 
> On Thu, 21 Dec 2023 at 04:07, Yunsheng Lin <linyunsheng@huawei.com> wrote:
>>
>> On 2023/12/20 15:56, Ilias Apalodimas wrote:
>>> Hi Yunsheng,
>>>>>>>  #ifdef CONFIG_PAGE_POOL_STATS
>>>>>>>       /* these stats are incremented while in softirq context */
>>>>>>> diff --git a/net/core/page_pool.c b/net/core/page_pool.c
>>>>>>> index 9b203d8660e4..19a56a52ac8f 100644
>>>>>>> --- a/net/core/page_pool.c
>>>>>>> +++ b/net/core/page_pool.c
>>>>>>> @@ -659,7 +659,7 @@ EXPORT_SYMBOL(page_pool_put_page_bulk);
>>>>>>>  static struct page *page_pool_drain_frag(struct page_pool *pool,
>>>>>>>                                        struct page *page)
>>>>>>>  {
>>>>>>> -     long drain_count = BIAS_MAX - pool->frag_users;
>>>>>>> +     long drain_count = BIAS_MAX - pool->frag_cnt;
>>>>>>
>>>>>> drain_count = pool->refcnt_bais;
>>>>>
>>>>> I think this is a typo right? This still remains
>>>>
>>>> It would be better to invert logic too, as it is mirroring:
>>>>
>>>> https://elixir.bootlin.com/linux/v6.7-rc5/source/mm/page_alloc.c#L4745
>>>
>>> This is still a bit confusing for me since the actual bias is the
>>> number of fragments that you initially split the page. But I am fine
>> Acctually there are two bais numbers for a page used by
>> page_pool_alloc_frag().
>> the one for page->pp_ref_count, which already use the BIAS_MAX, which
>> indicates the initial bais number:
>> https://elixir.bootlin.com/linux/latest/source/net/core/page_pool.c#L779
>>
>> Another one for pool->frag_users indicating the runtime bais number, which
>> need changing when a page is split into more fragments:
>> https://elixir.bootlin.com/linux/latest/source/net/core/page_pool.c#L776
>> https://elixir.bootlin.com/linux/latest/source/net/core/page_pool.c#L783
> 
> I know, and that's exactly what my commit message explains.  Also,
> that's the reason that the rename was 'frag_cnt' on v1.
> 

Yes, I think we do not need to invert logic when the naming is frag_users
or frag_cnt.

But if we use 'bias' as part of the name, isn't that more reasonable to set
both of the bias number to BIAS_MAX initially, and decrement the runtime
bais number every time the page is split to more fragmemts?

> 

  reply	other threads:[~2023-12-21  7:59 UTC|newest]

Thread overview: 11+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2023-12-15  7:31 Ilias Apalodimas
2023-12-15  7:43 ` Ilias Apalodimas
2023-12-15 11:09 ` Yunsheng Lin
2023-12-15 11:58   ` Ilias Apalodimas
2023-12-15 12:34     ` Yunsheng Lin
2023-12-20  7:56       ` Ilias Apalodimas
2023-12-21  2:07         ` Yunsheng Lin
2023-12-21  6:37           ` Ilias Apalodimas
2023-12-21  7:59             ` Yunsheng Lin [this message]
2023-12-21  8:24               ` Ilias Apalodimas
2023-12-21  9:39                 ` Yunsheng Lin

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=0dfffe91-2bd4-2151-cf71-ef29bf562767@huawei.com \
    --to=linyunsheng@huawei.com \
    --cc=davem@davemloft.net \
    --cc=edumazet@google.com \
    --cc=hawk@kernel.org \
    --cc=ilias.apalodimas@linaro.org \
    --cc=kuba@kernel.org \
    --cc=linux-kernel@vger.kernel.org \
    --cc=netdev@vger.kernel.org \
    --cc=pabeni@redhat.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®