mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [RFC/RFT PATCH 0/5] Clean up UFS(-qcom) MCQ situation
@ 2025-07-04 17:36 Konrad Dybcio
  2025-07-04 17:36 ` [PATCH RFC/RFT 1/5] ufs: ufs-qcom: Fix UFS base region name in MCQ case Konrad Dybcio
                   ` (5 more replies)
  0 siblings, 6 replies; 15+ messages in thread
From: Konrad Dybcio @ 2025-07-04 17:36 UTC (permalink / raw)
  To: Manivannan Sadhasivam, James E.J. Bottomley, Martin K. Petersen,
	Asutosh Das, Bart Van Assche, Stanley Chu
  Cc: Marijn Suijten, Can Guo, Nitin Rawat, linux-arm-msm, linux-scsi,
	linux-kernel, Konrad Dybcio

The initial implementation was quite messy, including requesting
regions that do not really exist in hardware (or at least not in the
way they were described).

As we have no users (and the corresponding dt-bindings were never even
accepted), remove a whole lot of boilerplate code and clean up the
software's expectations.

Note that this revision does not fix the bindings defficiency yet.

Compile-tested only & not the best code I've written, but I'm looking
for feedback whether this approach is acceptable.

Signed-off-by: Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>
---
Konrad Dybcio (5):
      ufs: ufs-qcom: Fix UFS base region name in MCQ case
      ufs: ufs-qcom: Remove inferred MCQ mappings
      ufs: ufs-qcom: Don't try to map inexistent regions
      ufs: ufs-qcom: Rename "mcq_sqd" to "mcq_opr"
      ufs: ufs-qcom: Kill ufshcd_res_info

 drivers/ufs/host/ufs-qcom.c      | 151 ++++++++++-----------------------------
 drivers/ufs/host/ufs-qcom.h      |   4 ++
 drivers/ufs/host/ufshcd-pltfrm.c |   4 +-
 include/ufs/ufshcd.h             |  26 +------
 4 files changed, 45 insertions(+), 140 deletions(-)
---
base-commit: 26ffb3d6f02cd0935fb9fa3db897767beee1cb2a
change-id: 20250704-topic-qcom_ufs_mcq_cleanup-3e7614ae06a8

Best regards,
-- 
Konrad Dybcio <konrad.dybcio@oss.qualcomm.com>


^ permalink raw reply	[flat|nested] 15+ messages in thread

end of thread, other threads:[~2025-07-08 16:32 UTC | newest]

Thread overview: 15+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2025-07-04 17:36 [RFC/RFT PATCH 0/5] Clean up UFS(-qcom) MCQ situation Konrad Dybcio
2025-07-04 17:36 ` [PATCH RFC/RFT 1/5] ufs: ufs-qcom: Fix UFS base region name in MCQ case Konrad Dybcio
2025-07-07 17:50   ` Bart Van Assche
2025-07-08 10:34   ` Manivannan Sadhasivam
2025-07-08 15:26     ` Konrad Dybcio
2025-07-04 17:36 ` [PATCH RFC/RFT 2/5] ufs: ufs-qcom: Remove inferred MCQ mappings Konrad Dybcio
2025-07-07 17:51   ` Bart Van Assche
2025-07-08 15:29     ` Konrad Dybcio
2025-07-08 11:13   ` Manivannan Sadhasivam
2025-07-08 16:32     ` Konrad Dybcio
2025-07-04 17:36 ` [PATCH RFC/RFT 3/5] ufs: ufs-qcom: Don't try to map inexistent regions Konrad Dybcio
2025-07-04 17:36 ` [PATCH RFC/RFT 4/5] ufs: ufs-qcom: Rename "mcq_sqd" to "mcq_opr" Konrad Dybcio
2025-07-04 17:36 ` [PATCH RFC/RFT 5/5] ufs: ufs-qcom: Kill ufshcd_res_info Konrad Dybcio
2025-07-07 17:54   ` Bart Van Assche
2025-07-08 11:28 ` [RFC/RFT PATCH 0/5] Clean up UFS(-qcom) MCQ situation Manivannan Sadhasivam

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®