mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 00/10] [v2] x86/cpu: Centralize and standardize CPUID leaf naming
@ 2024-12-13 20:50 Dave Hansen
  2024-12-13 20:50 ` [PATCH 01/10] x86/cpu: Move MWAIT leaf definition to common header Dave Hansen
                   ` (9 more replies)
  0 siblings, 10 replies; 13+ messages in thread
From: Dave Hansen @ 2024-12-13 20:50 UTC (permalink / raw)
  To: linux-kernel
  Cc: x86, tglx, bp, rafael, lenb, dave.jiang, irenic.rajneesh,
	david.e.box, Dave Hansen

Changes from v1:
 * Drop bogus "Check MWAIT feature instead of CPUID level" patch
 * Add review tags

--

I noticed that the MWAIT code was rather haphazard in how it deals
with CPUID leaf levels.  As a result, there were a ton of unnecessary
checks for ->cpuid_level.  It is truly the worst offender because
arch/x86, intel_idle and ACPI that want to poke at it.

Move several of the leaf definitions to one place (cpuid.h).  Use
the definitions to get rid of magic numbers.  Simplify the code
when the CPUID feature level dependencies can be used.  Lastly,
change all the leaf names to be consistent.

This does not get *ALL* the leaves.  The topology and cache ones
are left along for now, but they can also be converted over.

 arch/x86/events/intel/pt.c            |    5 ++--
 arch/x86/events/intel/pt.h            |    3 --
 arch/x86/include/asm/cpuid.h          |    7 ++++++
 arch/x86/include/asm/fpu/xstate.h     |    4 ---
 arch/x86/include/asm/mwait.h          |    1
 arch/x86/kernel/acpi/cstate.c         |    5 ++--
 arch/x86/kernel/cpu/common.c          |    7 +++---
 arch/x86/kernel/fpu/xstate.c          |   26 ++++++++++--------------
 arch/x86/kernel/hpet.c                |    6 +----
 arch/x86/kernel/process.c             |    3 +-
 arch/x86/kernel/smpboot.c             |    5 +---
 arch/x86/kernel/tsc.c                 |   23 ++++++++++-----------
 arch/x86/xen/enlighten_pv.c           |    5 ++--
 drivers/acpi/acpi_pad.c               |    5 +---
 drivers/dma/ioat/dca.c                |    8 ++++---
 drivers/idle/intel_idle.c             |    6 +----
 drivers/platform/x86/intel/pmc/core.c |    7 +++---
 17 files changed, 61 insertions(+), 65 deletions(-)


^ permalink raw reply	[flat|nested] 13+ messages in thread

end of thread, other threads:[~2024-12-16 21:23 UTC | newest]

Thread overview: 13+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2024-12-13 20:50 [PATCH 00/10] [v2] x86/cpu: Centralize and standardize CPUID leaf naming Dave Hansen
2024-12-13 20:50 ` [PATCH 01/10] x86/cpu: Move MWAIT leaf definition to common header Dave Hansen
2024-12-13 20:50 ` [PATCH 02/10] x86/cpu: Use MWAIT leaf definition Dave Hansen
2024-12-13 20:50 ` [PATCH 03/10] x86/cpu: Remove unnecessary MwAIT leaf checks Dave Hansen
2024-12-13 20:50 ` [PATCH 04/10] x86/cpu: Refresh DCA leaf reading code Dave Hansen
2024-12-13 20:50 ` [PATCH 05/10] x86/cpu: Move TSC CPUID leaf definition Dave Hansen
2024-12-13 20:50 ` [PATCH 06/10] x86/tsc: Move away from TSC leaf magic numbers Dave Hansen
2024-12-13 20:50 ` [PATCH 07/10] x86/tsc: Remove CPUID "frequency" " Dave Hansen
2024-12-13 20:50 ` [PATCH 08/10] x86/fpu: Move CPUID leaf definitions to common code Dave Hansen
2024-12-13 20:50 ` [PATCH 09/10] x86/fpu: Remove unnecessary CPUID level check Dave Hansen
2024-12-16 19:05   ` Chang S. Bae
2024-12-16 21:23     ` Dave Hansen
2024-12-13 20:50 ` [PATCH 10/10] x86/cpu: Make all all CPUID leaf names consistent Dave Hansen

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®