From: Bart Van Assche <bart.vanassche@sandisk.com>
To: Baole Ni <baolex.ni@intel.com>, <dledford@redhat.com>,
<sean.hefty@intel.com>, <hal.rosenstock@gmail.com>,
<bp@alien8.de>
Cc: <linux-rdma@vger.kernel.org>, <linux-kernel@vger.kernel.org>,
<leon@kernel.org>, <cl@linux.com>, <erezsh@mellanox.com>,
<haggaie@mellanox.com>, <markb@mellanox.com>,
<matanb@mellanox.com>, <eli@mellanox.com>, <guysh@mellanox.com>,
<ogerlitz@mellanox.com>, <chuansheng.liu@intel.com>
Subject: Re: [PATCH 0269/1285] Replace numeric parameter like 0444 with macro
Date: Tue, 2 Aug 2016 08:14:10 -0700 [thread overview]
Message-ID: <fd5c7644-7dcc-0cca-d38b-2379bca04dff@sandisk.com> (raw)
In-Reply-To: <20160802105508.31682-1-baolex.ni@intel.com>
On 08/02/2016 03:55 AM, Baole Ni wrote:
> I find that the developers often just specified the numeric value
> when calling a macro which is defined with a parameter for access permission.
> As we know, these numeric value for access permission have had the corresponding macro,
> and that using macro can improve the robustness and readability of the code,
> thus, I suggest replacing the numeric parameter with the macro.
>
> Signed-off-by: Chuansheng Liu <chuansheng.liu@intel.com>
> Signed-off-by: Baole Ni <baolex.ni@intel.com>
> ---
> drivers/infiniband/ulp/ipoib/ipoib_main.c | 6 +++---
> 1 file changed, 3 insertions(+), 3 deletions(-)
>
> diff --git a/drivers/infiniband/ulp/ipoib/ipoib_main.c b/drivers/infiniband/ulp/ipoib/ipoib_main.c
> index 5f58c41..eed3e3c 100644
> --- a/drivers/infiniband/ulp/ipoib/ipoib_main.c
> +++ b/drivers/infiniband/ulp/ipoib/ipoib_main.c
> @@ -65,15 +65,15 @@ MODULE_VERSION(DRV_VERSION);
> int ipoib_sendq_size __read_mostly = IPOIB_TX_RING_SIZE;
> int ipoib_recvq_size __read_mostly = IPOIB_RX_RING_SIZE;
>
> -module_param_named(send_queue_size, ipoib_sendq_size, int, 0444);
> +module_param_named(send_queue_size, ipoib_sendq_size, int, S_IRUSR | S_IRGRP | S_IROTH);
> MODULE_PARM_DESC(send_queue_size, "Number of descriptors in send queue");
> -module_param_named(recv_queue_size, ipoib_recvq_size, int, 0444);
> +module_param_named(recv_queue_size, ipoib_recvq_size, int, S_IRUSR | S_IRGRP | S_IROTH);
> MODULE_PARM_DESC(recv_queue_size, "Number of descriptors in receive queue");
>
> #ifdef CONFIG_INFINIBAND_IPOIB_DEBUG
> int ipoib_debug_level;
>
> -module_param_named(debug_level, ipoib_debug_level, int, 0644);
> +module_param_named(debug_level, ipoib_debug_level, int, S_IRUSR | S_IWUSR | S_IRGRP | S_IROTH);
> MODULE_PARM_DESC(debug_level, "Enable debug tracing if > 0");
> #endif
Hello Baole,
Please change 0444 into S_IRUGO and 0644 into S_IRUGO | S_IWUSR. The
latter form is more compact and hence makes the code easier to read.
Thanks,
Bart.
next prev parent reply other threads:[~2016-08-02 18:52 UTC|newest]
Thread overview: 4+ messages / expand[flat|nested] mbox.gz Atom feed top
2016-08-02 10:55 Baole Ni
2016-08-02 15:14 ` Bart Van Assche [this message]
2016-08-02 19:30 ` Steven Rostedt
2016-08-02 20:04 ` Bart Van Assche
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=fd5c7644-7dcc-0cca-d38b-2379bca04dff@sandisk.com \
--to=bart.vanassche@sandisk.com \
--cc=baolex.ni@intel.com \
--cc=bp@alien8.de \
--cc=chuansheng.liu@intel.com \
--cc=cl@linux.com \
--cc=dledford@redhat.com \
--cc=eli@mellanox.com \
--cc=erezsh@mellanox.com \
--cc=guysh@mellanox.com \
--cc=haggaie@mellanox.com \
--cc=hal.rosenstock@gmail.com \
--cc=leon@kernel.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-rdma@vger.kernel.org \
--cc=markb@mellanox.com \
--cc=matanb@mellanox.com \
--cc=ogerlitz@mellanox.com \
--cc=sean.hefty@intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®