* Re: [PATCH 10/44] kdbus: Use conditional operator
[not found] <05f401d10246$1a881ff0$4f985fd0$@alibaba-inc.com>
@ 2015-10-09 3:58 ` Hillf Danton
0 siblings, 0 replies; 2+ messages in thread
From: Hillf Danton @ 2015-10-09 3:58 UTC (permalink / raw)
To: Sergei Zviagintsev
Cc: 'Greg Kroah-Hartman', 'Daniel Mack',
'David Herrmann', 'Djalal Harouni',
'linux-kernel'
>
> Signed-off-by: Sergei Zviagintsev <sergei@...v.net>
> ---
> ipc/kdbus/names.c | 5 +----
> 1 file changed, 1 insertion(+), 4 deletions(-)
>
> diff --git a/ipc/kdbus/names.c b/ipc/kdbus/names.c
> index bf44ca3f12b6..6b31b38ac2ad 100644
> --- a/ipc/kdbus/names.c
> +++ b/ipc/kdbus/names.c
> @@ -438,10 +438,7 @@ static void kdbus_name_release_unlocked(struct kdbus_name_owner *owner)
> name->activator = NULL;
>
> if (!primary || owner == primary) {
> - next = kdbus_name_entry_first(name);
> - if (!next)
> - next = name->activator;
> -
> + next = kdbus_name_entry_first(name) ?: name->activator;
Fix? Cleanup? What we gain, given no log message?
> if (next) {
> /* hand to next in queue */
> next->flags &= ~KDBUS_NAME_IN_QUEUE;
> --
> 1.8.3.1
>
>
^ permalink raw reply [flat|nested] 2+ messages in thread
* [PATCH 00/44] kdbus cleanups
@ 2015-10-08 11:31 Sergei Zviagintsev
2015-10-08 11:31 ` [PATCH 10/44] kdbus: Use conditional operator Sergei Zviagintsev
0 siblings, 1 reply; 2+ messages in thread
From: Sergei Zviagintsev @ 2015-10-08 11:31 UTC (permalink / raw)
To: Greg Kroah-Hartman, Daniel Mack, David Herrmann, Djalal Harouni
Cc: linux-kernel, Sergei Zviagintsev
Hi all,
This is a set of various kdbus code cleanups. Patches are ordered by
increasing complexity, starting with docs and comments fixes and
one-liners.
Patch 29 is the revised version of
http://lkml.kernel.org/g/1435497454-10464-6-git-send-email-sergei@s15v.net
Feel free to ask to change layout of this, split/join, etc if necessary.
Thanks, Sergei
Sergei Zviagintsev (44):
Documentation/kdbus: Document new name registry flags
uapi: kdbus.h: Kernel-doc fixes
kdbus: Kernel-docs and comments trivial fixes
kdbus: Update kernel-doc for struct kdbus_pool
kdbus: Add comment on merging free pool slices
kdbus: Fix kernel-doc for struct kdbus_gaps
kdbus: Fix comment on translation of caps between namespaces
kdbus: Rename var in kdbus_meta_export_caps()
kdbus: Remove unused KDBUS_MSG_MAX_SIZE constant
kdbus: Use conditional operator
kdbus: Cosmetic fix of kdbus_name_is_valid()
kdbus: Use conventional list macros in __kdbus_pool_slice_release()
kdbus: Use list_next_entry() in kdbus_queue_entry_unlink()
kdbus: Simplify expression in kdbus_get_memfd()
kdbus: Simplify bitwise expression in kdbus_meta_get_mask()
kdbus: Drop redundant code from kdbus_name_acquire()
kdbus: Drop duplicated code from kdbus_pool_slice_alloc()
kdbus: Add var initialization to kdbus_conn_entry_insert()
kdbus: Drop useless initialization from kdbus_conn_reply()
kdbus: Drop useless initialization from kdbus_cmd_hello()
kdbus: Cleanup tests in kdbus_cmd_send()
kdbus: Cleanup error path in kdbus_staging_new_user()
kdbus: Cleanup kdbus_conn_call()
kdbus: Cleanup kdbus_conn_unicast()
kdbus: Cleanup kdbus_cmd_conn_info()
kdbus: Cleanup kdbus_pin_dst()
kdbus: Cleanup kdbus_conn_new()
kdbus: Cleanup kdbus_queue_entry_new()
kdbus: Improve tests on incrementing quota
kdbus: Cleanup kdbus_meta_proc_mask()
kdbus: Cleanup kdbus_conn_move_messages()
kdbus: Remove duplicated code from kdbus_conn_lock2()
kdbus: Improve kdbus_staging_reserve()
kdbus: Improve kdbus_conn_entry_sync_attach()
kdbus: Drop goto from kdbus_queue_entry_link()
kdbus: Improve kdbus_name_release()
kdbus: Fix error path in kdbus_meta_proc_collect_cgroup()
kdbus: Fix error path in kdbus_user_lookup()
kdbus: Cleanup kdbus_user_lookup()
kdbus: Cleanup kdbus_item_validate_name()
kdbus: Fix memfd install algorithm
kdbus: Check if fd is allocated before trying to free it
kdbus: Give up on failed fd allocation
kdbus: Cleanup kdbus_gaps_install()
Documentation/kdbus/kdbus.name.xml | 42 +++++++++-
include/uapi/linux/kdbus.h | 43 +++++-----
ipc/kdbus/connection.c | 157 +++++++++++++++----------------------
ipc/kdbus/connection.h | 19 ++---
ipc/kdbus/domain.c | 38 +++++----
ipc/kdbus/fs.c | 2 +-
ipc/kdbus/item.c | 26 +++---
ipc/kdbus/limits.h | 3 -
ipc/kdbus/message.c | 81 +++++++++----------
ipc/kdbus/message.h | 9 ++-
ipc/kdbus/metadata.c | 79 ++++++++++---------
ipc/kdbus/names.c | 32 ++++----
ipc/kdbus/node.c | 4 +-
ipc/kdbus/pool.c | 26 +++---
ipc/kdbus/queue.c | 51 ++++++------
ipc/kdbus/queue.h | 2 +-
16 files changed, 298 insertions(+), 316 deletions(-)
--
1.8.3.1
^ permalink raw reply [flat|nested] 2+ messages in thread
* [PATCH 10/44] kdbus: Use conditional operator
2015-10-08 11:31 [PATCH 00/44] kdbus cleanups Sergei Zviagintsev
@ 2015-10-08 11:31 ` Sergei Zviagintsev
0 siblings, 0 replies; 2+ messages in thread
From: Sergei Zviagintsev @ 2015-10-08 11:31 UTC (permalink / raw)
To: Greg Kroah-Hartman, Daniel Mack, David Herrmann, Djalal Harouni
Cc: linux-kernel, Sergei Zviagintsev
Signed-off-by: Sergei Zviagintsev <sergei@s15v.net>
---
ipc/kdbus/names.c | 5 +----
1 file changed, 1 insertion(+), 4 deletions(-)
diff --git a/ipc/kdbus/names.c b/ipc/kdbus/names.c
index bf44ca3f12b6..6b31b38ac2ad 100644
--- a/ipc/kdbus/names.c
+++ b/ipc/kdbus/names.c
@@ -438,10 +438,7 @@ static void kdbus_name_release_unlocked(struct kdbus_name_owner *owner)
name->activator = NULL;
if (!primary || owner == primary) {
- next = kdbus_name_entry_first(name);
- if (!next)
- next = name->activator;
-
+ next = kdbus_name_entry_first(name) ?: name->activator;
if (next) {
/* hand to next in queue */
next->flags &= ~KDBUS_NAME_IN_QUEUE;
--
1.8.3.1
^ permalink raw reply [flat|nested] 2+ messages in thread
end of thread, other threads:[~2015-10-09 3:58 UTC | newest]
Thread overview: 2+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
[not found] <05f401d10246$1a881ff0$4f985fd0$@alibaba-inc.com>
2015-10-09 3:58 ` [PATCH 10/44] kdbus: Use conditional operator Hillf Danton
2015-10-08 11:31 [PATCH 00/44] kdbus cleanups Sergei Zviagintsev
2015-10-08 11:31 ` [PATCH 10/44] kdbus: Use conditional operator Sergei Zviagintsev
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®