mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH 00/41] Cleanup and consolidate efuse related code.
@ 2014-06-20 14:59 navin patidar
  2014-06-20 14:59 ` [PATCH 01/41] staging: rtl8188eu: Rename hal_EfusePowerSwitch_RTL8188E() navin patidar
                   ` (40 more replies)
  0 siblings, 41 replies; 42+ messages in thread
From: navin patidar @ 2014-06-20 14:59 UTC (permalink / raw)
  To: gregkh; +Cc: Larry.Finger, devel, linux-kernel, navin patidar


navin patidar (41):
  staging: rtl8188eu: Rename hal_EfusePowerSwitch_RTL8188E()
  staging: rtl8188eu: Remove rtl8188e_ReadEFuse()
  staging: rtl8188eu: Remove unused function ReadEFuse_Pseudo()
  staging: rtl8188eu: Remove rtl8188e_EfuseGetCurrentSize()
  staging: rtl8188eu: Remove unused function
    Hal_EfuseGetCurrentSize_Pseudo()
  staging: rtl8188eu: Remove function
    Hal_EFUSEGetEfuseDefinition_Pseudo88E()
  staging: rtl8188eu: Rename Hal_EFUSEGetEfuseDefinition88E()
  staging: rtl8188eu: assign hal_EfusePgPacketRead_8188e() to
    ->Efuse_PgPacketRead
  staging:rtl8188eu:assign hal_EfusePgPacketWrite_8188e() to
    ->Efuse_PgPacketWrite
  staging:rtl8188eu: Assign rtl8188e_Efuse_WordEnableDataWrite() to
    ->Efuse_WordEnableDataWrite
  staging: rtl8188eu: rtw_efuse.c: Remove unnecessary function
    declaration
  staging: rtl8188eu: Rename rtl8188e_EFUSE_GetEfuseDefinition()
  staging: rtl8188eu: Rename hal_EfuseGetCurrentSize_8188e()
  staging: rtl8188eu: Rename rtl8188e_EfusePowerSwitch() to
    Efuse_PowerSwitch()
  staging: rtl8188eu: Rename function Hal_EfuseWordEnableDataWrite()
  staging: rtl8188eu: Remove function Hal_EfuseReadEFuse88E()
  staging: rtl8188eu: Rename function ReadEFuseByIC() to
    efuse_ReadEFuse()
  staging: rtl8188eu: Rename hal_EfusePgPacketRead_8188e() to
    Efuse_PgPacketRead()
  staging: rtl8188eu: Rename hal_EfusePgPacketWrite_8188e()
  staging: rtl8188eu: Remove function Efuse_Write1ByteToFakeContent()
  staging: rtl8188eu: Remove function Efuse_Read1ByteFromFakeContent()
  staging: rtl8188eu: Remove function rtw_BT_efuse_map_write()
  staging: rtl8188eu: Remove unused function Efuse_PgPacketWrite_BT()
  staging: rtl8188eu: Remove function rtw_BT_efuse_map_read()
  staging: rtl8188eu: Remove unused function ReadEFuseByte()
  staging: rtl8188eu: Remove unused function EFUSE_Read1Byte()
  staging: rtl8188eu: efuse_OneByteRead():Remove unused parameter bool
    test
  staging: rtl8188eu: efuse_OneByteWrite(): Remove unused parameter
    bool test
  staging: rtl8188eu: efuse_ReadEFuse(): Remove parameter bool
    bPseudoTest
  staging: rtl8188eu: Efuse_GetCurrentSize(): Remove parameter bool
    test
  staging: rtl8188eu: Efuse_ReadAllMap(): Remove unused parameter bool
    test
  staging: rtl8188eu: EFUSE_ShadowMapUpdate():Remove unused parameter
    bool test
  staging: rtl8188eu: Efuse_WordEnableDataWrite(): Remove unused
    parameter test
  staging: rtl8188eu: hal_EfuseCheckIfDatafollowed(): Remove unused
    parameter
  staging: rtl8188eu: Remove bool bPseudoTest parameter from efuse
    functions
  staging: rtl8188eu: rtl8188e_hal_init.c: Remove forward declarations
  staging: rtl8188eu: hal_EfusePartialWriteCheck(): Remove bluetooth
    specific code
  staging: rtl8188eu: rtw_efuse.c: Remove unused global variables
  staging: rtl8188eu: rtw_efuse.c: Remove unused local variables
  staging: rtl8188eu: rtw_efuse.c: Remove unnecessary comments
  staging: rtl8188eu: Move all efuse related code to rtw_efuse.c

 drivers/staging/rtl8188eu/core/rtw_efuse.c        | 1392 +++++++++++++--------
 drivers/staging/rtl8188eu/core/rtw_mp_ioctl.c     |   10 +-
 drivers/staging/rtl8188eu/hal/rtl8188e_hal_init.c | 1253 +------------------
 drivers/staging/rtl8188eu/include/hal_intf.h      |   18 -
 drivers/staging/rtl8188eu/include/rtl8188e_hal.h  |    2 +
 drivers/staging/rtl8188eu/include/rtw_efuse.h     |   43 +-
 drivers/staging/rtl8188eu/os_dep/ioctl_linux.c    |  108 +-
 7 files changed, 920 insertions(+), 1906 deletions(-)

--
1.7.10.4


^ permalink raw reply	[flat|nested] 42+ messages in thread

end of thread, other threads:[~2014-06-20 15:07 UTC | newest]

Thread overview: 42+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2014-06-20 14:59 [PATCH 00/41] Cleanup and consolidate efuse related code navin patidar
2014-06-20 14:59 ` [PATCH 01/41] staging: rtl8188eu: Rename hal_EfusePowerSwitch_RTL8188E() navin patidar
2014-06-20 14:59 ` [PATCH 02/41] staging: rtl8188eu: Remove rtl8188e_ReadEFuse() navin patidar
2014-06-20 14:59 ` [PATCH 03/41] staging: rtl8188eu: Remove unused function ReadEFuse_Pseudo() navin patidar
2014-06-20 14:59 ` [PATCH 04/41] staging: rtl8188eu: Remove rtl8188e_EfuseGetCurrentSize() navin patidar
2014-06-20 14:59 ` [PATCH 05/41] staging: rtl8188eu: Remove unused function Hal_EfuseGetCurrentSize_Pseudo() navin patidar
2014-06-20 14:59 ` [PATCH 06/41] staging: rtl8188eu: Remove function Hal_EFUSEGetEfuseDefinition_Pseudo88E() navin patidar
2014-06-20 14:59 ` [PATCH 07/41] staging: rtl8188eu: Rename Hal_EFUSEGetEfuseDefinition88E() navin patidar
2014-06-20 14:59 ` [PATCH 08/41] staging: rtl8188eu: assign hal_EfusePgPacketRead_8188e() to ->Efuse_PgPacketRead navin patidar
2014-06-20 14:59 ` [PATCH 09/41] staging:rtl8188eu:assign hal_EfusePgPacketWrite_8188e() to ->Efuse_PgPacketWrite navin patidar
2014-06-20 14:59 ` [PATCH 10/41] staging:rtl8188eu: Assign rtl8188e_Efuse_WordEnableDataWrite() to ->Efuse_WordEnableDataWrite navin patidar
2014-06-20 14:59 ` [PATCH 11/41] staging: rtl8188eu: rtw_efuse.c: Remove unnecessary function declaration navin patidar
2014-06-20 14:59 ` [PATCH 12/41] staging: rtl8188eu: Rename rtl8188e_EFUSE_GetEfuseDefinition() navin patidar
2014-06-20 14:59 ` [PATCH 13/41] staging: rtl8188eu: Rename hal_EfuseGetCurrentSize_8188e() navin patidar
2014-06-20 14:59 ` [PATCH 14/41] staging: rtl8188eu: Rename rtl8188e_EfusePowerSwitch() to Efuse_PowerSwitch() navin patidar
2014-06-20 14:59 ` [PATCH 15/41] staging: rtl8188eu: Rename function Hal_EfuseWordEnableDataWrite() navin patidar
2014-06-20 14:59 ` [PATCH 16/41] staging: rtl8188eu: Remove function Hal_EfuseReadEFuse88E() navin patidar
2014-06-20 14:59 ` [PATCH 17/41] staging: rtl8188eu: Rename function ReadEFuseByIC() to efuse_ReadEFuse() navin patidar
2014-06-20 14:59 ` [PATCH 18/41] staging: rtl8188eu: Rename hal_EfusePgPacketRead_8188e() to Efuse_PgPacketRead() navin patidar
2014-06-20 14:59 ` [PATCH 19/41] staging: rtl8188eu: Rename hal_EfusePgPacketWrite_8188e() navin patidar
2014-06-20 14:59 ` [PATCH 20/41] staging: rtl8188eu: Remove function Efuse_Write1ByteToFakeContent() navin patidar
2014-06-20 14:59 ` [PATCH 21/41] staging: rtl8188eu: Remove function Efuse_Read1ByteFromFakeContent() navin patidar
2014-06-20 14:59 ` [PATCH 22/41] staging: rtl8188eu: Remove function rtw_BT_efuse_map_write() navin patidar
2014-06-20 14:59 ` [PATCH 23/41] staging: rtl8188eu: Remove unused function Efuse_PgPacketWrite_BT() navin patidar
2014-06-20 14:59 ` [PATCH 24/41] staging: rtl8188eu: Remove function rtw_BT_efuse_map_read() navin patidar
2014-06-20 14:59 ` [PATCH 25/41] staging: rtl8188eu: Remove unused function ReadEFuseByte() navin patidar
2014-06-20 14:59 ` [PATCH 26/41] staging: rtl8188eu: Remove unused function EFUSE_Read1Byte() navin patidar
2014-06-20 14:59 ` [PATCH 27/41] staging: rtl8188eu: efuse_OneByteRead():Remove unused parameter bool test navin patidar
2014-06-20 14:59 ` [PATCH 28/41] staging: rtl8188eu: efuse_OneByteWrite(): Remove " navin patidar
2014-06-20 14:59 ` [PATCH 29/41] staging: rtl8188eu: efuse_ReadEFuse(): Remove parameter bool bPseudoTest navin patidar
2014-06-20 14:59 ` [PATCH 30/41] staging: rtl8188eu: Efuse_GetCurrentSize(): Remove parameter bool test navin patidar
2014-06-20 14:59 ` [PATCH 31/41] staging: rtl8188eu: Efuse_ReadAllMap(): Remove unused " navin patidar
2014-06-20 14:59 ` [PATCH 32/41] staging: rtl8188eu: EFUSE_ShadowMapUpdate():Remove " navin patidar
2014-06-20 14:59 ` [PATCH 33/41] staging: rtl8188eu: Efuse_WordEnableDataWrite(): Remove unused parameter test navin patidar
2014-06-20 14:59 ` [PATCH 34/41] staging: rtl8188eu: hal_EfuseCheckIfDatafollowed(): Remove unused parameter navin patidar
2014-06-20 14:59 ` [PATCH 35/41] staging: rtl8188eu: Remove bool bPseudoTest parameter from efuse functions navin patidar
2014-06-20 14:59 ` [PATCH 36/41] staging: rtl8188eu: rtl8188e_hal_init.c: Remove forward declarations navin patidar
2014-06-20 14:59 ` [PATCH 37/41] staging: rtl8188eu: hal_EfusePartialWriteCheck(): Remove bluetooth specific code navin patidar
2014-06-20 14:59 ` [PATCH 38/41] staging: rtl8188eu: rtw_efuse.c: Remove unused global variables navin patidar
2014-06-20 14:59 ` [PATCH 39/41] staging: rtl8188eu: rtw_efuse.c: Remove unused local variables navin patidar
2014-06-20 14:59 ` [PATCH 40/41] staging: rtl8188eu: rtw_efuse.c: Remove unnecessary comments navin patidar
2014-06-20 14:59 ` [PATCH 41/41] staging: rtl8188eu: Move all efuse related code to rtw_efuse.c navin patidar

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®