mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Jesse Barnes <jbarnes@virtuousgeek.org>
To: Ingo Molnar <mingo@elte.hu>
Cc: Linus Torvalds <torvalds@linux-foundation.org>,
	linux-kernel@vger.kernel.org,
	Andrew Morton <akpm@linux-foundation.org>,
	Thomas Gleixner <tglx@linutronix.de>,
	"H. Peter Anvin" <hpa@zytor.com>, Yinghai Lu <yinghai.lu@sun.com>,
	Yinghai Lu <yhlu.kernel@gmail.com>
Subject: Re: [git pull] "big box" x86 changes, PCI
Date: Mon, 28 Apr 2008 13:34:15 -0700	[thread overview]
Message-ID: <200804281334.16713.jbarnes@virtuousgeek.org> (raw)
In-Reply-To: <20080426215540.GA3545@elte.hu>

On Saturday, April 26, 2008 2:55 pm Ingo Molnar wrote:> @@ -184,51 +322,80 @@ static void __init pci_mmcfg_reject_broken(int type)>  >         cfg = &pci_mmcfg_config[0];>  > -       /*> -        * Handle more broken MCFG tables on Asus etc.> -        * They only contain a single entry for bus 0-0.> -        */> -       if (pci_mmcfg_config_num == 1 &&> -           cfg->pci_segment == 0 &&> -           (cfg->start_bus_number | cfg->end_bus_number) == 0) {> -               printk(KERN_ERR "PCI: start and end of bus number is 0. "> -                      "Rejected as broken MCFG.\n");> -               goto reject;> +       for (i = 0; i < pci_mmcfg_config_num; i++) {> +               int valid = 0;> +               u32 size = (cfg->end_bus_number + 1) << 20;> +               cfg = &pci_mmcfg_config[i];> +               printk(KERN_NOTICE "PCI: MCFG configuration %d: base %lx "> +                      "segment %hu buses %u - %u\n",> +                      i, (unsigned long)cfg->address, cfg->pci_segment,> +                      (unsigned int)cfg->start_bus_number,> +                      (unsigned int)cfg->end_bus_number);> +> +               if (!early &&> +                   is_acpi_reserved(cfg->address, cfg->address + size -> 1)) { +                       printk(KERN_NOTICE "PCI: MCFG area at %Lx> reserved " +                              "in ACPI motherboard> resources\n",> +                              cfg->address);> +                       valid = 1;> +               }> +> +               if (valid)> +                       continue;> +> +               if (!early)> +                       printk(KERN_ERR "PCI: BIOS Bug: MCFG area at %Lx is> not" +                              " reserved in ACPI motherboard> resources\n", +                              cfg->address);> +               /* Don't try to do this check unless configuration> +                  type 1 is available. how about type 2 ?*/> +               if (raw_pci_ops && e820_all_mapped(cfg->address,> +                                                 cfg->address + size - 1,> +                                                 E820_RESERVED)) {> +                       printk(KERN_NOTICE> +                              "PCI: MCFG area at %Lx reserved in E820\n",> +                              cfg->address);> +                       valid = 1;> +               }> +> +               if (!valid)> +                       goto reject;>         }
This loop is a bit messy, is there some way of making it clearer?  Maybe the early vs. late stuff should be split into separate routines entirely...
> @@ -842,11 +842,14 @@ static void set_pcie_port_type(struct pci_dev *pdev)>   * reading the dword at 0x100 which must either be 0 or a valid extended>   * capability header.>   */> -int pci_cfg_space_size(struct pci_dev *dev)> +int pci_cfg_space_size_ext(struct pci_dev *dev, unsigned check_exp_pcix)>  {>         int pos;>         u32 status;>  > +       if (!check_exp_pcix)> +               goto skip;> +
Rather than adding a flag to pci_cfg_space_size, you could either factor out the extended space probe into a separate routine and use it from both pci_cfg_space_size and the fixup code, or just make the fixup code do the probe & cfg_size setting by hand, moving the PCI_CFG_SPACE_SIZE and PCI_CFG_SPACE_EXP_SIZE to pci.h.
In both cases I'm just trying to avoid having a flag you pass to a routine that changes its behavior significantly enough that a new function would make things more readable.
Other than that, things look pretty good.  And the resulting kernel boots fine on my test box, which is nice...
Thanks,Jesseÿôèº{.nÇ+‰·Ÿ®‰­†+%ŠËÿ±éݶ\x17¥Šwÿº{.nÇ+‰·¥Š{±þG«éÿŠ{ayº\x1dʇڙë,j\a­¢f£¢·hšïêÿ‘êçz_è®\x03(­éšŽŠÝ¢j"ú\x1a¶^[m§ÿÿ¾\a«þG«éÿ¢¸?™¨è­Ú&£ø§~á¶iO•æ¬z·švØ^\x14\x04\x1a¶^[m§ÿÿÃ\fÿ¶ìÿ¢¸?–I¥

  parent reply	other threads:[~2008-04-28 20:35 UTC|newest]

Thread overview: 52+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2008-04-26 18:55 [RFC git pull] "big box" x86 changes Ingo Molnar
2008-04-26 19:05 ` Stefan Richter
2008-04-26 19:21   ` Ingo Molnar
2008-04-26 19:12 ` Linus Torvalds
2008-04-26 19:41   ` [git pull] "big box" x86 changes, bootmem/sparsemem Ingo Molnar
2008-04-26 19:52     ` Linus Torvalds
2008-04-26 20:07       ` Ingo Molnar
2008-04-26 20:08       ` [git pull] "big box" x86 changes, bootmem/sparsemem, #2 Ingo Molnar
2008-04-26 20:30         ` Linus Torvalds
2008-04-26 20:55           ` [git pull] "big box" x86 changes, bootmem/sparsemem, #3 Ingo Molnar
2008-04-27 22:48     ` [git pull] "big box" x86 changes, bootmem/sparsemem Johannes Weiner
2008-04-27 23:46       ` Ingo Molnar
2008-04-28  0:19         ` Johannes Weiner
2008-04-28  0:40           ` [patch] mm: node-setup agnostic free_bootmem() Ingo Molnar
2008-04-28  1:48             ` Yinghai Lu
2008-04-28 16:54               ` Johannes Weiner
2008-04-28 19:11                 ` Yinghai Lu
2008-04-28 19:55                   ` Yinghai Lu
2008-04-30 10:50                     ` Johannes Weiner
2008-04-30 16:22                       ` Yinghai Lu
2008-04-30 17:52                         ` Johannes Weiner
2008-04-30 20:30                           ` Yinghai Lu
2008-04-28 16:49             ` Johannes Weiner
2008-04-29 14:25               ` Ingo Molnar
2008-04-30 10:52                 ` Johannes Weiner
2008-04-28  0:33       ` [git pull] "big box" x86 changes, bootmem/sparsemem Yinghai Lu
2008-04-28 16:58         ` Johannes Weiner
2008-04-26 19:54   ` [git pull] "big box" x86 changes, boot protocol Ingo Molnar
2008-04-26 20:39     ` Andrew Morton
2008-04-26 21:06       ` Adrian Bunk
2008-04-26 21:10         ` H. Peter Anvin
2008-04-26 21:11         ` Linus Torvalds
2008-04-26 21:17           ` Ingo Molnar
2008-04-26 23:37       ` Jeremy Fitzhardinge
2008-04-27 11:21     ` Ian Campbell
2008-04-27 19:29       ` H. Peter Anvin
2008-04-28 15:27       ` Ingo Molnar
2008-04-26 20:24   ` [RFC git pull] "big box" x86 changes, GART Ingo Molnar
2008-04-26 20:26     ` Ingo Molnar
2008-04-26 21:55   ` [git pull] "big box" x86 changes, PCI Ingo Molnar
2008-04-27 16:30     ` Jesse Barnes
2008-04-28 15:38       ` Ingo Molnar
2008-04-28 20:34     ` Jesse Barnes [this message]
2008-04-28 22:53       ` Yinghai Lu
2008-04-28 23:27       ` [PATCH] x86/pci: remove flag in pci_cfg_space_size_ext Yinghai Lu
2008-04-29 16:14         ` Jesse Barnes
2008-04-29 22:05           ` Ingo Molnar
2008-04-29 22:34             ` Jesse Barnes
2008-04-26 22:17 ` [RFC git pull] "big box" x86 changes Andi Kleen
2008-04-27  3:14   ` Yinghai Lu
2008-04-27  8:30     ` Andi Kleen
2008-04-27  8:32     ` [RFC git pull] "big box" x86 changes II Andi Kleen

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=200804281334.16713.jbarnes@virtuousgeek.org \
    --to=jbarnes@virtuousgeek.org \
    --cc=akpm@linux-foundation.org \
    --cc=hpa@zytor.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=mingo@elte.hu \
    --cc=tglx@linutronix.de \
    --cc=torvalds@linux-foundation.org \
    --cc=yhlu.kernel@gmail.com \
    --cc=yinghai.lu@sun.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome