From: Greg KH <greg@kroah.com>
To: Alex Chiang <achiang@hp.com>
Cc: sarah.a.sharp@linux.intel.com, linux-usb@vger.kernel.org,
linux-kernel@vger.kernel.org
Subject: Re: [PATCH 0/2] small xhci cleanups
Date: Tue, 9 Mar 2010 10:14:13 -0800 [thread overview]
Message-ID: <20100309181413.GB31027@kroah.com> (raw)
In-Reply-To: <20100309174815.29339.96173.stgit@bob.kio>
On Tue, Mar 09, 2010 at 10:52:43AM -0700, Alex Chiang wrote:
> While trying to render aid and assistance for a USB3 issue that Sarah
> has been chasing, she grumbled in a private email that she was unable
> to coerce the build system to produce a module named "xhci_hcd".
>
> This patch series shows one way to get around the Makefile intrinsics
> and create a module name of our choosing. There's probably a better
> way to do it, but it's beyond my makefile-fu.
>
> The other change is to move all the debug code under
> CONFIG_XHCI_HCD_DEBUGGING, which is a straightforward change.
>
> Thanks,
> /ac
>
> ---
>
> Alex Chiang (2):
> USB: xhci: rename driver to xhci_hcd
I'm not opposed to this at all, but note, we should do it _now_ and not
hold on to this patch for the rest of the .34 development cycle
otherwise people are going to have a lot of trouble merging patches.
Sarah, mind if I take this one patch?
> USB: xhci: move all debug code under CONFIG_XHCI_HCD_DEBUGGING
Does this conflict with Sarah's other debugging patch she just sent out?
thanks,
greg k-h
next prev parent reply other threads:[~2010-03-09 18:14 UTC|newest]
Thread overview: 18+ messages / expand[flat|nested] mbox.gz Atom feed top
2010-03-09 17:52 Alex Chiang
2010-03-09 17:52 ` [PATCH 1/2] USB: xhci: rename driver to xhci_hcd Alex Chiang
2010-03-16 19:03 ` Greg KH
2010-03-09 17:52 ` [PATCH 2/2] USB: xhci: move all debug code under CONFIG_XHCI_HCD_DEBUGGING Alex Chiang
2010-03-09 18:14 ` Greg KH [this message]
2010-03-09 18:32 ` [PATCH 0/2] small xhci cleanups Alex Chiang
2010-03-09 18:47 ` Greg KH
2010-03-16 21:24 ` Sarah Sharp
2010-03-16 21:40 ` Greg KH
2010-03-18 21:33 ` Sarah Sharp
2010-03-18 21:50 ` Roland Dreier
2010-03-18 22:19 ` Greg KH
2010-03-18 22:30 ` Roland Dreier
2010-03-18 22:54 ` Sarah Sharp
2010-03-16 20:48 [PATCH v2] USB: xhci: rename driver to xhci_hcd Alex Chiang
2010-03-16 21:09 ` Sarah Sharp
2010-03-17 2:22 ` Crane Cai
2010-03-17 4:30 ` Greg KH
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=20100309181413.GB31027@kroah.com \
--to=greg@kroah.com \
--cc=achiang@hp.com \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-usb@vger.kernel.org \
--cc=sarah.a.sharp@linux.intel.com \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®