mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Roland Dreier <rdreier@cisco.com>
To: Greg KH <greg@kroah.com>
Cc: Sarah Sharp <sarah.a.sharp@linux.intel.com>,
	Alex Chiang <achiang@hp.com>,
	linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 0/2] small xhci cleanups
Date: Thu, 18 Mar 2010 15:30:05 -0700	[thread overview]
Message-ID: <ada1vfh6z6a.fsf@roland-alpha.cisco.com> (raw)
In-Reply-To: <20100318221958.GB3299@kroah.com> (Greg KH's message of "Thu, 18 Mar 2010 15:19:58 -0700")

 > > I think the end user doesn't want to see anything from the driver unless
 > > something serious has gone wrong.  But those cases use xhci_warn(),
 > > which translates down to dev_warn(), instead of xhci_dbg().
 > 
 > Yes, that's fine.  But you need/want something for when a user reports a
 > problem, and they can't rebuild their kernel.

Yes, just to be clear (and I'm pretty sure I'm agreeing with Greg here)
any warnings that you want always enabled to show something in the
kernel log whenever there's a problem should be dev_warn() or
equivalent.

Things that produce too much output and that you only want on when
you're debugging a problem are probably best done via trace events.

 - R.
-- 
Roland Dreier  <rolandd@cisco.com>
For corporate legal information go to:
http://www.cisco.com/web/about/doing_business/legal/cri/index.html

  reply	other threads:[~2010-03-18 22:30 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-03-09 17:52 Alex Chiang
2010-03-09 17:52 ` [PATCH 1/2] USB: xhci: rename driver to xhci_hcd Alex Chiang
2010-03-16 19:03   ` Greg KH
2010-03-09 17:52 ` [PATCH 2/2] USB: xhci: move all debug code under CONFIG_XHCI_HCD_DEBUGGING Alex Chiang
2010-03-09 18:14 ` [PATCH 0/2] small xhci cleanups Greg KH
2010-03-09 18:32   ` Alex Chiang
2010-03-09 18:47     ` Greg KH
2010-03-16 21:24       ` Sarah Sharp
2010-03-16 21:40         ` Greg KH
2010-03-18 21:33           ` Sarah Sharp
2010-03-18 21:50             ` Roland Dreier
2010-03-18 22:19             ` Greg KH
2010-03-18 22:30               ` Roland Dreier [this message]
2010-03-18 22:54               ` Sarah Sharp
2010-03-16 20:48 [PATCH v2] USB: xhci: rename driver to xhci_hcd Alex Chiang
2010-03-16 21:09 ` Sarah Sharp
2010-03-17  2:22 ` Crane Cai
2010-03-17  4:30   ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=ada1vfh6z6a.fsf@roland-alpha.cisco.com \
    --to=rdreier@cisco.com \
    --cc=achiang@hp.com \
    --cc=greg@kroah.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=sarah.a.sharp@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®