mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg KH <greg@kroah.com>
To: Alex Chiang <achiang@hp.com>
Cc: sarah.a.sharp@linux.intel.com, linux-usb@vger.kernel.org,
	linux-kernel@vger.kernel.org
Subject: Re: [PATCH 0/2] small xhci cleanups
Date: Tue, 9 Mar 2010 10:47:23 -0800	[thread overview]
Message-ID: <20100309184723.GA31374@kroah.com> (raw)
In-Reply-To: <20100309183227.GD15974@grease.lan>

On Tue, Mar 09, 2010 at 11:32:27AM -0700, Alex Chiang wrote:
> * Greg KH <greg@kroah.com>:
> > On Tue, Mar 09, 2010 at 10:52:43AM -0700, Alex Chiang wrote:
> > 
> > >       USB: xhci: move all debug code under CONFIG_XHCI_HCD_DEBUGGING
> > 
> > Does this conflict with Sarah's other debugging patch she just sent out?
> 
> I'm assuming you're talking about this patch:
> 
> 	http://thread.gmane.org/gmane.linux.usb.general/28681

Yes.

> Yes, we'll definitely have conflicts. If you agree that we should
> move the debug code under the Kconfig option, then the best
> course of action would be for Sarah to rebase her work on top of
> my patches (since they're intrusive).

As Sarah is the maintainer of the file, I'll leave that decision up to
her :)

And keeping a config option for debugging isn't a good idea.  The rest
of the kernel has switched to using dynamic debugging, so that distros
and others can easily get information without requiring a kernel rebuild
(which we can't expect users to always be able to do.)  So I would not
recommend this change.

thanks,

greg k-h

  reply	other threads:[~2010-03-09 18:47 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-03-09 17:52 Alex Chiang
2010-03-09 17:52 ` [PATCH 1/2] USB: xhci: rename driver to xhci_hcd Alex Chiang
2010-03-16 19:03   ` Greg KH
2010-03-09 17:52 ` [PATCH 2/2] USB: xhci: move all debug code under CONFIG_XHCI_HCD_DEBUGGING Alex Chiang
2010-03-09 18:14 ` [PATCH 0/2] small xhci cleanups Greg KH
2010-03-09 18:32   ` Alex Chiang
2010-03-09 18:47     ` Greg KH [this message]
2010-03-16 21:24       ` Sarah Sharp
2010-03-16 21:40         ` Greg KH
2010-03-18 21:33           ` Sarah Sharp
2010-03-18 21:50             ` Roland Dreier
2010-03-18 22:19             ` Greg KH
2010-03-18 22:30               ` Roland Dreier
2010-03-18 22:54               ` Sarah Sharp
2010-03-16 20:48 [PATCH v2] USB: xhci: rename driver to xhci_hcd Alex Chiang
2010-03-16 21:09 ` Sarah Sharp
2010-03-17  2:22 ` Crane Cai
2010-03-17  4:30   ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100309184723.GA31374@kroah.com \
    --to=greg@kroah.com \
    --cc=achiang@hp.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=sarah.a.sharp@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

Powered by JetHome