mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
From: Greg KH <greg@kroah.com>
To: Sarah Sharp <sarah.a.sharp@linux.intel.com>
Cc: Alex Chiang <achiang@hp.com>,
	linux-usb@vger.kernel.org, linux-kernel@vger.kernel.org
Subject: Re: [PATCH 0/2] small xhci cleanups
Date: Thu, 18 Mar 2010 15:19:58 -0700	[thread overview]
Message-ID: <20100318221958.GB3299@kroah.com> (raw)
In-Reply-To: <20100318213308.GA5461@xanatos>

On Thu, Mar 18, 2010 at 02:33:08PM -0700, Sarah Sharp wrote:
> On Tue, Mar 16, 2010 at 02:40:14PM -0700, Greg KH wrote:
> > On Tue, Mar 16, 2010 at 02:24:45PM -0700, Sarah Sharp wrote:
> > > Ok, I didn't see Greg's email about dynamic debugging.  I guess you
> > > shouldn't refresh the second patch.  I'm not sure how I would go about
> > > converting the xHCI driver to dynamic debugging, as I haven't looked
> > > into it.  Is there any documentation/simple examples?
> > 
> > Yes, just use 'dev_dbg' and you are finished.
> > 
> > Or pr_debug if you want to use different logging levels with your
> > macros.
> > 
> > > Greg, does the less-verbose patch with log levels still make sense if
> > > the driver got converted over to dynamic debugging?
> > 
> > I don't know what people really want to see.  In 6 months you will
> > probably only care about "debugging on or off" as the majority of the
> > messages only help you out when developing the driver, right?
> 
> "On" or "off" doesn't really help when you're trying to debug different
> parts of the driver.  If you're trying to debug a command, messages
> about wrapping rings or enqueueing transfers doesn't really matter.

Like Roland, I recommend the tracing interface for this.

> I think the end user doesn't want to see anything from the driver unless
> something serious has gone wrong.  But those cases use xhci_warn(),
> which translates down to dev_warn(), instead of xhci_dbg().

Yes, that's fine.  But you need/want something for when a user reports a
problem, and they can't rebuild their kernel.

> > So maybe par down some of the messages, or just live with seeing them
> > all, it will be easier in the end.
> 
> Yes, I did par down the duplicate/redundant messages, but I still want
> to see very detailed messages when I think there's a hardware problem.
> 
> What if I removed the debug config option for xHCI, allowed people to
> use dynamic debugging to enable debugging for specific xHCI files, but
> also allowed them to set the log level through a debugfs file?  That way
> people could still control the variety of messages that they see, but
> they can also change the level of debugging dynamically.

Sure, that might work, but I'd recommend tracing for the most part,
that's what it is there for :)

thanks,

greg k-h

  parent reply	other threads:[~2010-03-18 22:20 UTC|newest]

Thread overview: 18+ messages / expand[flat|nested]  mbox.gz  Atom feed  top
2010-03-09 17:52 Alex Chiang
2010-03-09 17:52 ` [PATCH 1/2] USB: xhci: rename driver to xhci_hcd Alex Chiang
2010-03-16 19:03   ` Greg KH
2010-03-09 17:52 ` [PATCH 2/2] USB: xhci: move all debug code under CONFIG_XHCI_HCD_DEBUGGING Alex Chiang
2010-03-09 18:14 ` [PATCH 0/2] small xhci cleanups Greg KH
2010-03-09 18:32   ` Alex Chiang
2010-03-09 18:47     ` Greg KH
2010-03-16 21:24       ` Sarah Sharp
2010-03-16 21:40         ` Greg KH
2010-03-18 21:33           ` Sarah Sharp
2010-03-18 21:50             ` Roland Dreier
2010-03-18 22:19             ` Greg KH [this message]
2010-03-18 22:30               ` Roland Dreier
2010-03-18 22:54               ` Sarah Sharp
2010-03-16 20:48 [PATCH v2] USB: xhci: rename driver to xhci_hcd Alex Chiang
2010-03-16 21:09 ` Sarah Sharp
2010-03-17  2:22 ` Crane Cai
2010-03-17  4:30   ` Greg KH

Reply instructions:

You may reply publicly to this message via plain-text email
using any one of the following methods:

* Save the following mbox file, import it into your mail client,
  and reply-to-all from there: mbox

  Avoid top-posting and favor interleaved quoting:
  https://en.wikipedia.org/wiki/Posting_style#Interleaved_style

* Reply using the --to, --cc, and --in-reply-to
  switches of git-send-email(1):

  git send-email \
    --in-reply-to=20100318221958.GB3299@kroah.com \
    --to=greg@kroah.com \
    --cc=achiang@hp.com \
    --cc=linux-kernel@vger.kernel.org \
    --cc=linux-usb@vger.kernel.org \
    --cc=sarah.a.sharp@linux.intel.com \
    /path/to/YOUR_REPLY

  https://kernel.org/pub/software/scm/git/docs/git-send-email.html

* If your mail client supports setting the In-Reply-To header
  via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®