* [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id
@ 2026-08-04 11:17 Pawel Zalewski via B4 Relay
2026-08-04 22:34 ` Jonathan Cameron
` (2 more replies)
0 siblings, 3 replies; 4+ messages in thread
From: Pawel Zalewski via B4 Relay @ 2026-08-04 11:17 UTC (permalink / raw)
To: Yushan Wang, Conor Dooley, Jonathan Cameron
Cc: linux-kernel, Pawel Zalewski (The Capable Hub)
From: "Pawel Zalewski (The Capable Hub)" <pzalewski@thegoodpenguin.co.uk>
Use a named initializer for the acpi_device_id fields which
makes the code more readable and consistent with how lists
are initialized in the rest of the kernel code base.
Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
---
drivers/cache/hisi_soc_hha.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/drivers/cache/hisi_soc_hha.c b/drivers/cache/hisi_soc_hha.c
index 756c43398515..f0f6c0354108 100644
--- a/drivers/cache/hisi_soc_hha.c
+++ b/drivers/cache/hisi_soc_hha.c
@@ -170,7 +170,7 @@ static void hisi_soc_hha_remove(struct platform_device *pdev)
}
static const struct acpi_device_id hisi_soc_hha_ids[] = {
- { "HISI0511", },
+ { .id = "HISI0511" },
{ }
};
MODULE_DEVICE_TABLE(acpi, hisi_soc_hha_ids);
---
base-commit: 075b74841bd0065a3bda3440873c747938e69b68
change-id: 20260803-cache-55f8e58f7d94
Best regards,
--
Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id
2026-08-04 11:17 [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id Pawel Zalewski via B4 Relay
@ 2026-08-04 22:34 ` Jonathan Cameron
2026-08-05 1:07 ` Yushan Wang
2026-08-10 14:56 ` Conor Dooley
2 siblings, 0 replies; 4+ messages in thread
From: Jonathan Cameron @ 2026-08-04 22:34 UTC (permalink / raw)
To: Pawel Zalewski via B4 Relay
Cc: pzalewski, Yushan Wang, Conor Dooley, linux-kernel
On Tue, 04 Aug 2026 12:17:45 +0100
Pawel Zalewski via B4 Relay <devnull+pzalewski.thegoodpenguin.co.uk@kernel.org> wrote:
> From: "Pawel Zalewski (The Capable Hub)" <pzalewski@thegoodpenguin.co.uk>
>
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base.
>
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
Acked-by: Jonathan Cameron <jonathan.cameron@oss.qualcomm.com>
> ---
> drivers/cache/hisi_soc_hha.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/cache/hisi_soc_hha.c b/drivers/cache/hisi_soc_hha.c
> index 756c43398515..f0f6c0354108 100644
> --- a/drivers/cache/hisi_soc_hha.c
> +++ b/drivers/cache/hisi_soc_hha.c
> @@ -170,7 +170,7 @@ static void hisi_soc_hha_remove(struct platform_device *pdev)
> }
>
> static const struct acpi_device_id hisi_soc_hha_ids[] = {
> - { "HISI0511", },
> + { .id = "HISI0511" },
> { }
> };
> MODULE_DEVICE_TABLE(acpi, hisi_soc_hha_ids);
>
> ---
> base-commit: 075b74841bd0065a3bda3440873c747938e69b68
> change-id: 20260803-cache-55f8e58f7d94
>
> Best regards,
> --
> Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
>
>
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id
2026-08-04 11:17 [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id Pawel Zalewski via B4 Relay
2026-08-04 22:34 ` Jonathan Cameron
@ 2026-08-05 1:07 ` Yushan Wang
2026-08-10 14:56 ` Conor Dooley
2 siblings, 0 replies; 4+ messages in thread
From: Yushan Wang @ 2026-08-05 1:07 UTC (permalink / raw)
To: pzalewski; +Cc: linux-kernel, Conor Dooley, Jonathan Cameron
On 8/4/2026 7:17 PM, Pawel Zalewski via B4 Relay wrote:
> From: "Pawel Zalewski (The Capable Hub)" <pzalewski@thegoodpenguin.co.uk>
>
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base.
>
> Signed-off-by: Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
Reviewed-by: Yushan Wang <wangyushan12@huawei.com>
> ---
> drivers/cache/hisi_soc_hha.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/cache/hisi_soc_hha.c b/drivers/cache/hisi_soc_hha.c
> index 756c43398515..f0f6c0354108 100644
> --- a/drivers/cache/hisi_soc_hha.c
> +++ b/drivers/cache/hisi_soc_hha.c
> @@ -170,7 +170,7 @@ static void hisi_soc_hha_remove(struct platform_device *pdev)
> }
>
> static const struct acpi_device_id hisi_soc_hha_ids[] = {
> - { "HISI0511", },
> + { .id = "HISI0511" },
> { }
> };
> MODULE_DEVICE_TABLE(acpi, hisi_soc_hha_ids);
>
> ---
> base-commit: 075b74841bd0065a3bda3440873c747938e69b68
> change-id: 20260803-cache-55f8e58f7d94
>
> Best regards,
> --
> Pawel Zalewski (The Capable Hub) <pzalewski@thegoodpenguin.co.uk>
>
>
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id
2026-08-04 11:17 [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id Pawel Zalewski via B4 Relay
2026-08-04 22:34 ` Jonathan Cameron
2026-08-05 1:07 ` Yushan Wang
@ 2026-08-10 14:56 ` Conor Dooley
2 siblings, 0 replies; 4+ messages in thread
From: Conor Dooley @ 2026-08-10 14:56 UTC (permalink / raw)
To: Yushan Wang, Conor Dooley, Jonathan Cameron,
Pawel Zalewski (The Capable Hub)
Cc: Conor Dooley, linux-kernel
From: Conor Dooley <conor.dooley@microchip.com>
On Tue, 04 Aug 2026 12:17:45 +0100, Pawel Zalewski (The Capable Hub) wrote:
> Use a named initializer for the acpi_device_id fields which
> makes the code more readable and consistent with how lists
> are initialized in the rest of the kernel code base.
Applied to cache-for-next, thanks!
[1/1] cache: hisi_soc_hha: use named initializers for acpi_device_id
https://git.kernel.org/conor/c/8a5d6c13cc7c
Thanks,
Conor.
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2026-08-10 14:56 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2026-08-04 11:17 [PATCH] cache: hisi_soc_hha: use named initializers for acpi_device_id Pawel Zalewski via B4 Relay
2026-08-04 22:34 ` Jonathan Cameron
2026-08-05 1:07 ` Yushan Wang
2026-08-10 14:56 ` Conor Dooley
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®