From: "Srivatsa S. Bhat" <srivatsa.bhat@linux.vnet.ibm.com>
To: "Rafael J. Wysocki" <rjw@sisk.pl>
Cc: Kay Sievers <kay@vrfy.org>, Greg KH <gregkh@linuxfoundation.org>,
Christian Lamparter <chunkeey@googlemail.com>,
linux-kernel@vger.kernel.org, alan@lxorguk.ukuu.org.uk,
Linus Torvalds <torvalds@linux-foundation.org>,
Linux PM mailing list <linux-pm@vger.kernel.org>,
skannan@codeaurora.org, Stephen Boyd <sboyd@codeaurora.org>
Subject: Re: [PATCH] firmware loader: don't cancel _nowait requests when helper is not yet available
Date: Fri, 16 Mar 2012 12:44:09 +0530 [thread overview]
Message-ID: <4F62E841.70405@linux.vnet.ibm.com> (raw)
In-Reply-To: <201203142354.04256.rjw@sisk.pl>
On 03/15/2012 04:24 AM, Rafael J. Wysocki wrote:
> On Wednesday, March 14, 2012, Srivatsa S. Bhat wrote:
>> On 03/14/2012 05:40 AM, Rafael J. Wysocki wrote:
>>
>>> On Wednesday, March 14, 2012, Kay Sievers wrote:
>>>> On Tue, Mar 13, 2012 at 20:42, Rafael J. Wysocki <rjw@sisk.pl> wrote:
>>>>> On Sunday, March 11, 2012, Kay Sievers wrote:
>>>>>> On Sat, Mar 10, 2012 at 00:36, Greg KH <gregkh@linuxfoundation.org> wrote:
>>>>
>>>>>>> What does uevent have to do with things here?
>>>>>>
>>>>>> I don't think that the firmware loader should care about the
>>>>>> usermodehelper at all, and that stuff fiddling should just be removed
>>>>>> from the firmware class.
>>>>>
>>>>> It's there to warn people that their drivers do stupid things like
>>>>> loading frimware during system resume, which is guaranteed not to work.
>>>>>
>>>>> IOW, it's there very much on purpose.
>>>>
>>>> Using the /sbin/hotplug is no case that needs any warning. It' such a
>>>> broken model these days, that firmware loading is the least problem
>>>> that occurs with it.
>>>>
>>>>>> Forking /sbin/hotplug is disabled by default, it is a broken concept,
>>>>>> and it cannot work reliably on today's systems.
>>>>>>
>>>>>> Firmware is not loaded by /sbin/hotplug since many years, but by udev
>>>>>> or whatever service handles uevents, like ueventd on android.
>>>>>
>>>>> Which I'm not sure why is relevant here.
>>>>
>>>> It is relevant in the sense that the firmware loader should not even
>>>> know that a uevent *can* cause a usermodehelper exec() if it runs in
>>>> legacy mode. The firmware loader just has no business in fiddling with
>>>> the details of driver core legacy stuff. I don't think his warning
>>>> makes much sense.
>>>
>>> But that warning actually triggers for drivers that attempt to use
>>> request_firmware() during system resume, even though /sbin/hotplug isn't
>>> used any more.
>>>
>>
>>
>> I agree with Rafael about why the warning and the bail out is required,
>> including the part about the races with freezer which he explained in his
>> other mail. These problems have already been well documented too.
>> (See Documentation/power/freezing-of-tasks.txt).
>>
>>> usermodehelper_is_disabled() means "we are in the middle of system power
>>> transition" rather than anything else (I agree it should be called
>>> suspend_in_progress() or something similar these days).
>>>
>>
>>
>> How about this patch then?
>>
>> ---
>>
>> From: Srivatsa S. Bhat <srivatsa.bhat@linux.vnet.ibm.com>
>> Subject: PM/firmware loader: Use better name for usermodehelper_is_disabled()
>>
>> Rafael J. Wysocki <rjw@sisk.pl> wrote:
>>
>> | usermodehelper_is_disabled() means "we are in the middle of system power
>> | transition" rather than anything else (I agree it should be called
>> | suspend_in_progress() or something similar these days).
>>
>>
>> But simply renaming usermodehelper_is_disabled() to suspend_in_progress()
>> isn't the best thing to do since that would be misleading because suspend
>> transitions are begun much before usermodehelpers are disabled.
>>
>> Apart from that, we don't want people to suddenly start abusing this function
>> in future in a totally different context to check if suspend is in progress.
>>
>> So, add an alias specific to firmware loaders alone, that will internally
>> call usermodehelpers_is_disabled().
>>
>> Signed-off-by: Srivatsa S. Bhat <srivatsa.bhat@linux.vnet.ibm.com>
>> ---
>>
>> drivers/base/firmware_class.c | 12 +++++++++++-
>> 1 files changed, 11 insertions(+), 1 deletions(-)
>>
>> diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c
>> index 6c9387d..9e401e1 100644
>> --- a/drivers/base/firmware_class.c
>> +++ b/drivers/base/firmware_class.c
>> @@ -510,6 +510,8 @@ static void fw_destroy_instance(struct firmware_priv *fw_priv)
>> device_unregister(f_dev);
>> }
>>
>> +#define suspend_in_progress() usermodehelper_is_disabled()
>
> This looks like an overstretch to me. I think a comment would be sufficient.
On second thoughts... I agree, a comment is good enough.
>
>> +
>> static int _request_firmware(const struct firmware **firmware_p,
>> const char *name, struct device *device,
>> bool uevent, bool nowait)
>> @@ -535,7 +537,15 @@ static int _request_firmware(const struct firmware **firmware_p,
>>
>> read_lock_usermodehelper();
>>
>> - if (WARN_ON(usermodehelper_is_disabled())) {
>> + /*
>> + * It is wrong to request firmware when the system is suspended,
>> + * because it simply won't work reliably.
>
> In fact, it won't work at all.
>
>> + Also, it can cause races with
>> + * the freezer, leading to freezing failures.
>
> It actually is worse than that too. It may cause a user space process
> to run when we think we have frozen user space and _that_ may lead to
> all kinds of interesting breakage.
>
Oh, yes! That would be really dreadful!
>> * So check if the system is
>> + * in a state which is unsuitable for requesting firmware (because the
>> + * system is suspended or not yet fully resumed) and bail out early if
>> + * needed.
>
> And here I'd explain why usermodehelper_is_disabled() is used for that.
>
OK
>> + */
>> + if (WARN_ON(suspend_in_progress())) {
>> dev_err(device, "firmware: %s will not be loaded\n", name);
>> retval = -EBUSY;
>> goto out;
>
So here is the updated patch:
(I know its a bit verbose, but given that it is causing a considerable amount of
confusion, may be a proper comment with good explanation is worthwhile).
---
From: Srivatsa S. Bhat <srivatsa.bhat@linux.vnet.ibm.com>
Subject: PM/firmware loader: Explain why usermodehelper_is_disabled() check is used
Rafael J. Wysocki <rjw@sisk.pl> wrote:
| usermodehelper_is_disabled() means "we are in the middle of system power
| transition" rather than anything else (I agree it should be called
| suspend_in_progress() or something similar these days).
But instead of renaming usermodehelper_is_disabled(), add a comment
explaining its importance and also why the warning and bail out at
_request_firmware() makes sense.
Signed-off-by: Srivatsa S. Bhat <srivatsa.bhat@linux.vnet.ibm.com>
---
drivers/base/firmware_class.c | 16 ++++++++++++++++
1 files changed, 16 insertions(+), 0 deletions(-)
diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c
index 6c9387d..9199e3e 100644
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
@@ -535,6 +535,22 @@ static int _request_firmware(const struct firmware **firmware_p,
read_lock_usermodehelper();
+ /*
+ * It is wrong to request firmware when the system is suspended,
+ * because it simply won't work. Also, it can cause races with
+ * the freezer, leading to freezing failures. Worse than that,
+ * it may even cause a user space process to run when we think
+ * we have frozen the user space! - and that can lead to all kinds
+ * of interesting breakage..
+ *
+ * So check if the system is in a state which is unsuitable for
+ * requesting firmware (because it is suspended or not yet fully
+ * resumed) and bail out early if needed.
+ * Usermodehelpers are disabled at the beginning of suspend, before
+ * freezing tasks and re-enabled only towards the end of resume, after
+ * thawing tasks, when it is safe. So all we need to do here is ensure
+ * that we don't request firmware when usermodehelpers are disabled.
+ */
if (WARN_ON(usermodehelper_is_disabled())) {
dev_err(device, "firmware: %s will not be loaded\n", name);
retval = -EBUSY;
next prev parent reply other threads:[~2012-03-16 7:14 UTC|newest]
Thread overview: 111+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-03-03 20:22 [RFC] firmware loader: retry _nowait requests when userhelper " Christian Lamparter
2012-03-03 23:57 ` Alan Cox
2012-03-04 1:50 ` Christian Lamparter
2012-03-05 20:12 ` Srivatsa S. Bhat
2012-03-09 22:30 ` [PATCH] firmware loader: don't cancel _nowait requests when helper " Christian Lamparter
2012-03-09 23:36 ` Greg KH
2012-03-10 0:52 ` Christian Lamparter
2012-03-11 11:56 ` Kay Sievers
2012-03-13 9:37 ` Saravana Kannan
2012-03-13 9:43 ` Saravana Kannan
2012-03-13 20:14 ` Rafael J. Wysocki
2012-03-14 19:21 ` Stephen Boyd
2012-03-14 23:04 ` Rafael J. Wysocki
2012-03-14 23:13 ` Rafael J. Wysocki
2012-03-14 23:17 ` Stephen Boyd
2012-03-14 23:34 ` Rafael J. Wysocki
2012-03-14 23:38 ` Stephen Boyd
2012-03-15 0:11 ` Rafael J. Wysocki
2012-03-15 19:50 ` [PATCH] firmware_class: Move request_firmware_nowait() to workqueues Stephen Boyd
2012-03-15 20:07 ` Christian Lamparter
2012-03-15 20:12 ` Stephen Boyd
2012-03-15 22:31 ` Rafael J. Wysocki
2012-03-16 1:39 ` Stephen Boyd
2012-03-16 20:19 ` Rafael J. Wysocki
2012-03-16 20:26 ` Stephen Boyd
2012-03-16 21:45 ` Rafael J. Wysocki
2012-03-16 22:18 ` Christian Lamparter
2012-03-16 22:35 ` Rafael J. Wysocki
2012-03-17 2:47 ` [PATCH] firmware loader: don't cancel _nowait requests when helper is not yet available Stephen Boyd
2012-03-17 5:51 ` Linus Torvalds
2012-03-17 20:06 ` Rafael J. Wysocki
2012-03-18 8:26 ` Stephen Boyd
2012-03-18 12:01 ` Rafael J. Wysocki
2012-03-19 6:32 ` Stephen Boyd
2012-03-19 11:24 ` Rafael J. Wysocki
2012-03-19 23:00 ` Rafael J. Wysocki
2012-03-25 22:00 ` [PATCH 0/6] firmware_class: Fix problems with usermodehelper test Rafael J. Wysocki
2012-03-25 22:01 ` [PATCH 1/6] firmware_class: Rework usermodehelper check Rafael J. Wysocki
2012-03-25 22:01 ` [PATCH 2/6] firmware_class: Split _request_firmware() into three functions Rafael J. Wysocki
2012-03-26 18:15 ` Stephen Boyd
2012-03-26 18:21 ` Stephen Boyd
2012-03-26 20:12 ` Rafael J. Wysocki
2012-03-26 20:31 ` Stephen Boyd
2012-03-26 20:36 ` Rafael J. Wysocki
2012-03-27 21:35 ` Stephen Boyd
2012-03-27 21:51 ` Rafael J. Wysocki
2012-03-25 22:02 ` [PATCH 3/6] firmware_class: Do not warn that system is not ready from async loads Rafael J. Wysocki
2012-03-25 22:03 ` [PATCH 4/6] PM / Hibernate: Disable usermode helpers right before freezing tasks Rafael J. Wysocki
2012-03-25 22:03 ` [PATCH 5/6] PM / Sleep: Move disabling of usermode helpers to the freezer Rafael J. Wysocki
2012-03-25 22:04 ` [PATCH 6/6] PM / Sleep: Mitigate race between the freezer and request_firmware() Rafael J. Wysocki
2012-03-26 18:16 ` Stephen Boyd
2012-03-26 20:06 ` Rafael J. Wysocki
2012-03-27 21:25 ` Stephen Boyd
2012-03-27 21:37 ` Rafael J. Wysocki
2012-03-26 18:42 ` [PATCH 0/6] firmware_class: Fix problems with usermodehelper test Greg KH
2012-03-26 20:37 ` Rafael J. Wysocki
2012-03-27 21:28 ` [PATCH 1/2] firmware_class: Reorganize fw_create_instance() Stephen Boyd
2012-03-27 21:47 ` Rafael J. Wysocki
2012-03-27 21:49 ` Greg KH
2012-03-27 21:56 ` Rafael J. Wysocki
2012-03-27 21:28 ` [PATCH 2/2] firmware_class: Move request_firmware_nowait() to workqueues Stephen Boyd
2012-03-27 21:49 ` Rafael J. Wysocki
2012-03-27 22:01 ` Tejun Heo
2012-03-27 22:21 ` Rafael J. Wysocki
2012-03-27 22:48 ` Tejun Heo
2012-03-27 22:55 ` Rafael J. Wysocki
2012-03-27 23:02 ` Stephen Boyd
2012-03-27 23:05 ` Stephen Boyd
2012-03-28 21:19 ` [PATCH v2 0/8] firmware_class: Fix problems with usermodehelper test Rafael J. Wysocki
2012-03-28 21:20 ` [PATCH v2 1/8] firmware_class: Rework usermodehelper check Rafael J. Wysocki
2012-03-28 21:21 ` [PATCH v2 2/8] firmware_class: Split _request_firmware() into three functions, v2 Rafael J. Wysocki
2012-03-28 21:22 ` [PATCH v3 3/8] firmware_class: Do not warn that system is not ready from async loads Rafael J. Wysocki
2012-03-28 21:23 ` [PATCH v2 4/8] PM / Hibernate: Disable usermode helpers right before freezing tasks Rafael J. Wysocki
2012-03-28 21:23 ` [PATCH v2 5/8] PM / Sleep: Move disabling of usermode helpers to the freezer Rafael J. Wysocki
2012-03-28 21:24 ` [PATCH v2 6/8] PM / Sleep: Mitigate race between the freezer and request_firmware() Rafael J. Wysocki
2012-03-28 21:25 ` [PATCH v2 7/8] firmware_class: Reorganize fw_create_instance() Rafael J. Wysocki
2012-03-28 21:26 ` [PATCH v2 8/8] firmware_class: Move request_firmware_nowait() to workqueues Rafael J. Wysocki
2012-03-14 23:19 ` [PATCH] firmware loader: don't cancel _nowait requests when helper is not yet available Rafael J. Wysocki
2012-03-13 19:42 ` Rafael J. Wysocki
2012-03-13 23:25 ` Kay Sievers
2012-03-14 0:10 ` Rafael J. Wysocki
2012-03-14 0:14 ` Kay Sievers
2012-03-14 0:54 ` Linus Torvalds
2012-03-14 1:43 ` Kay Sievers
2012-03-14 1:51 ` Linus Torvalds
2012-03-14 1:55 ` Kay Sievers
2012-03-14 2:00 ` Kay Sievers
2012-03-14 2:21 ` Linus Torvalds
2012-03-14 15:07 ` Srivatsa S. Bhat
2012-03-14 22:54 ` Rafael J. Wysocki
2012-03-16 7:14 ` Srivatsa S. Bhat [this message]
2012-03-16 20:23 ` Rafael J. Wysocki
2012-03-16 21:14 ` Christian Lamparter
2012-03-16 21:19 ` Linus Torvalds
2012-03-19 7:06 ` Srivatsa S. Bhat
2012-03-16 22:19 ` [RFC] firmware loader: retry _nowait requests when userhelper " Rafael J. Wysocki
2012-03-16 22:25 ` Christian Lamparter
2012-03-16 22:57 ` Rafael J. Wysocki
2012-03-16 23:35 ` Christian Lamparter
2012-03-16 23:37 ` Linus Torvalds
2012-03-17 0:23 ` Rafael J. Wysocki
2012-03-17 0:33 ` Linus Torvalds
2012-03-18 0:29 ` Rafael J. Wysocki
2012-03-18 2:21 ` Linus Torvalds
2012-03-18 12:21 ` Rafael J. Wysocki
2012-03-18 12:43 ` Christian Lamparter
2012-03-18 23:15 ` [PATCH 0/3] firmware_class: Fix problem with async requests (was: Re: [RFC] firmware loader: retry ...) Rafael J. Wysocki
2012-03-18 23:17 ` [PATCH 1/3] firmware_class: Rework usermodehelper check Rafael J. Wysocki
2012-03-18 23:18 ` [PATCH 2/3] firmware_class: Split _request_firmware() into three functions Rafael J. Wysocki
2012-03-18 23:21 ` [PATCH 3/3] firmware_class: Do not warn that system is not ready for async loads Rafael J. Wysocki
2012-03-19 12:41 ` [RFC] firmware loader: retry _nowait requests when userhelper is not yet available James Courtier-Dutton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4F62E841.70405@linux.vnet.ibm.com \
--to=srivatsa.bhat@linux.vnet.ibm.com \
--cc=alan@lxorguk.ukuu.org.uk \
--cc=chunkeey@googlemail.com \
--cc=gregkh@linuxfoundation.org \
--cc=kay@vrfy.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=rjw@sisk.pl \
--cc=sboyd@codeaurora.org \
--cc=skannan@codeaurora.org \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome