From: Stephen Boyd <sboyd@codeaurora.org>
To: "Rafael J. Wysocki" <rjw@sisk.pl>
Cc: Tejun Heo <tj@kernel.org>,
linux-kernel@vger.kernel.org,
Linus Torvalds <torvalds@linux-foundation.org>,
Saravana Kannan <skannan@codeaurora.org>,
Kay Sievers <kay.sievers@vrfy.org>,
Greg KH <gregkh@linuxfoundation.org>,
Christian Lamparter <chunkeey@googlemail.com>,
"Srivatsa S. Bhat" <srivatsa.bhat@linux.vnet.ibm.com>,
alan@lxorguk.ukuu.org.uk,
Linux PM mailing list <linux-pm@vger.kernel.org>
Subject: Re: [PATCH 2/2] firmware_class: Move request_firmware_nowait() to workqueues
Date: Tue, 27 Mar 2012 16:02:58 -0700 [thread overview]
Message-ID: <4F724722.2000202@codeaurora.org> (raw)
In-Reply-To: <201203280055.06624.rjw@sisk.pl>
On 03/27/12 15:55, Rafael J. Wysocki wrote:
> On Wednesday, March 28, 2012, Tejun Heo wrote:
>> On Wed, Mar 28, 2012 at 12:21:27AM +0200, Rafael J. Wysocki wrote:
>>> On Wednesday, March 28, 2012, Tejun Heo wrote:
>>>> On Tue, Mar 27, 2012 at 02:28:30PM -0700, Stephen Boyd wrote:
>>>>> Oddly enough a work_struct was already part of the firmware_work
>>>>> structure but nobody was using it. Instead of creating a new
>>>>> kthread for each request_firmware_nowait() call just schedule the
>>>>> work on the long system workqueue. This should avoid some overhead
>>>>> in forking new threads when they're not strictly necessary.
>>>>>
>>>>> Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
>>>>> ---
>>>>>
>>>>> Is it better to use alloc_workqueue() and not put these on the system
>>>>> long workqueue?
>>>> No, just use schedule_work() unless there are specific requirements
>>>> which can't be fulfilled that way (e.g. it's on memory allocation
>>>> path, may consume large amount of cpu cycles, ...)
>>> It may wait quite long.
>> That shouldn't matter. system_long_wq's name is a bit misleading at
>> this point. The only reason it's used currently is to avoid cyclic
>> dependency involving flush_workqueue(), which calls for clearer
>> solution anyway. So, yeap, using system_wq should be fine here.
> Good, thanks for the explanation.
>
> Stephen, care to respin?
>
Sure. We want system_wq instead of system_long_wq? If so let's use this
patch.
-----8<-- cut here -->8------
Subject: [PATCH] firmware_class: Move request_firmware_nowait() to workqueues
Oddly enough a work_struct was already part of the firmware_work
structure but nobody was using it. Instead of creating a new
kthread for each request_firmware_nowait() call just schedule the
work on the system workqueue. This should avoid some overhead
in forking new threads when they're not strictly necessary.
Signed-off-by: Stephen Boyd <sboyd@codeaurora.org>
---
drivers/base/firmware_class.c | 27 +++++++--------------------
1 file changed, 7 insertions(+), 20 deletions(-)
diff --git a/drivers/base/firmware_class.c b/drivers/base/firmware_class.c
index ae00a2f..5401814 100644
--- a/drivers/base/firmware_class.c
+++ b/drivers/base/firmware_class.c
@@ -16,10 +16,11 @@
#include <linux/interrupt.h>
#include <linux/bitops.h>
#include <linux/mutex.h>
-#include <linux/kthread.h>
+#include <linux/workqueue.h>
#include <linux/highmem.h>
#include <linux/firmware.h>
#include <linux/slab.h>
+#include <linux/sched.h>
#define to_dev(obj) container_of(obj, struct device, kobj)
@@ -630,19 +631,15 @@ struct firmware_work {
bool uevent;
};
-static int request_firmware_work_func(void *arg)
+static void request_firmware_work_func(struct work_struct *work)
{
- struct firmware_work *fw_work = arg;
+ struct firmware_work *fw_work;
const struct firmware *fw;
struct firmware_priv *fw_priv;
long timeout;
int ret;
- if (!arg) {
- WARN_ON(1);
- return 0;
- }
-
+ fw_work = container_of(work, struct firmware_work, work);
fw_priv = _request_firmware_prepare(&fw, fw_work->name, fw_work->device,
fw_work->uevent, true);
if (IS_ERR_OR_NULL(fw_priv)) {
@@ -667,8 +664,6 @@ static int request_firmware_work_func(void *arg)
module_put(fw_work->module);
kfree(fw_work);
-
- return ret;
}
/**
@@ -694,7 +689,6 @@ request_firmware_nowait(
const char *name, struct device *device, gfp_t gfp, void *context,
void (*cont)(const struct firmware *fw, void *context))
{
- struct task_struct *task;
struct firmware_work *fw_work;
fw_work = kzalloc(sizeof (struct firmware_work), gfp);
@@ -713,15 +707,8 @@ request_firmware_nowait(
return -EFAULT;
}
- task = kthread_run(request_firmware_work_func, fw_work,
- "firmware/%s", name);
- if (IS_ERR(task)) {
- fw_work->cont(NULL, fw_work->context);
- module_put(fw_work->module);
- kfree(fw_work);
- return PTR_ERR(task);
- }
-
+ INIT_WORK(&fw_work->work, request_firmware_work_func);
+ schedule_work(&fw_work->work);
return 0;
}
--
Sent by an employee of the Qualcomm Innovation Center, Inc.
The Qualcomm Innovation Center, Inc. is a member of the Code Aurora Forum.
next prev parent reply other threads:[~2012-03-27 23:03 UTC|newest]
Thread overview: 111+ messages / expand[flat|nested] mbox.gz Atom feed top
2012-03-03 20:22 [RFC] firmware loader: retry _nowait requests when userhelper is not yet available Christian Lamparter
2012-03-03 23:57 ` Alan Cox
2012-03-04 1:50 ` Christian Lamparter
2012-03-05 20:12 ` Srivatsa S. Bhat
2012-03-09 22:30 ` [PATCH] firmware loader: don't cancel _nowait requests when helper " Christian Lamparter
2012-03-09 23:36 ` Greg KH
2012-03-10 0:52 ` Christian Lamparter
2012-03-11 11:56 ` Kay Sievers
2012-03-13 9:37 ` Saravana Kannan
2012-03-13 9:43 ` Saravana Kannan
2012-03-13 20:14 ` Rafael J. Wysocki
2012-03-14 19:21 ` Stephen Boyd
2012-03-14 23:04 ` Rafael J. Wysocki
2012-03-14 23:13 ` Rafael J. Wysocki
2012-03-14 23:17 ` Stephen Boyd
2012-03-14 23:34 ` Rafael J. Wysocki
2012-03-14 23:38 ` Stephen Boyd
2012-03-15 0:11 ` Rafael J. Wysocki
2012-03-15 19:50 ` [PATCH] firmware_class: Move request_firmware_nowait() to workqueues Stephen Boyd
2012-03-15 20:07 ` Christian Lamparter
2012-03-15 20:12 ` Stephen Boyd
2012-03-15 22:31 ` Rafael J. Wysocki
2012-03-16 1:39 ` Stephen Boyd
2012-03-16 20:19 ` Rafael J. Wysocki
2012-03-16 20:26 ` Stephen Boyd
2012-03-16 21:45 ` Rafael J. Wysocki
2012-03-16 22:18 ` Christian Lamparter
2012-03-16 22:35 ` Rafael J. Wysocki
2012-03-17 2:47 ` [PATCH] firmware loader: don't cancel _nowait requests when helper is not yet available Stephen Boyd
2012-03-17 5:51 ` Linus Torvalds
2012-03-17 20:06 ` Rafael J. Wysocki
2012-03-18 8:26 ` Stephen Boyd
2012-03-18 12:01 ` Rafael J. Wysocki
2012-03-19 6:32 ` Stephen Boyd
2012-03-19 11:24 ` Rafael J. Wysocki
2012-03-19 23:00 ` Rafael J. Wysocki
2012-03-25 22:00 ` [PATCH 0/6] firmware_class: Fix problems with usermodehelper test Rafael J. Wysocki
2012-03-25 22:01 ` [PATCH 1/6] firmware_class: Rework usermodehelper check Rafael J. Wysocki
2012-03-25 22:01 ` [PATCH 2/6] firmware_class: Split _request_firmware() into three functions Rafael J. Wysocki
2012-03-26 18:15 ` Stephen Boyd
2012-03-26 18:21 ` Stephen Boyd
2012-03-26 20:12 ` Rafael J. Wysocki
2012-03-26 20:31 ` Stephen Boyd
2012-03-26 20:36 ` Rafael J. Wysocki
2012-03-27 21:35 ` Stephen Boyd
2012-03-27 21:51 ` Rafael J. Wysocki
2012-03-25 22:02 ` [PATCH 3/6] firmware_class: Do not warn that system is not ready from async loads Rafael J. Wysocki
2012-03-25 22:03 ` [PATCH 4/6] PM / Hibernate: Disable usermode helpers right before freezing tasks Rafael J. Wysocki
2012-03-25 22:03 ` [PATCH 5/6] PM / Sleep: Move disabling of usermode helpers to the freezer Rafael J. Wysocki
2012-03-25 22:04 ` [PATCH 6/6] PM / Sleep: Mitigate race between the freezer and request_firmware() Rafael J. Wysocki
2012-03-26 18:16 ` Stephen Boyd
2012-03-26 20:06 ` Rafael J. Wysocki
2012-03-27 21:25 ` Stephen Boyd
2012-03-27 21:37 ` Rafael J. Wysocki
2012-03-26 18:42 ` [PATCH 0/6] firmware_class: Fix problems with usermodehelper test Greg KH
2012-03-26 20:37 ` Rafael J. Wysocki
2012-03-27 21:28 ` [PATCH 1/2] firmware_class: Reorganize fw_create_instance() Stephen Boyd
2012-03-27 21:47 ` Rafael J. Wysocki
2012-03-27 21:49 ` Greg KH
2012-03-27 21:56 ` Rafael J. Wysocki
2012-03-27 21:28 ` [PATCH 2/2] firmware_class: Move request_firmware_nowait() to workqueues Stephen Boyd
2012-03-27 21:49 ` Rafael J. Wysocki
2012-03-27 22:01 ` Tejun Heo
2012-03-27 22:21 ` Rafael J. Wysocki
2012-03-27 22:48 ` Tejun Heo
2012-03-27 22:55 ` Rafael J. Wysocki
2012-03-27 23:02 ` Stephen Boyd [this message]
2012-03-27 23:05 ` Stephen Boyd
2012-03-28 21:19 ` [PATCH v2 0/8] firmware_class: Fix problems with usermodehelper test Rafael J. Wysocki
2012-03-28 21:20 ` [PATCH v2 1/8] firmware_class: Rework usermodehelper check Rafael J. Wysocki
2012-03-28 21:21 ` [PATCH v2 2/8] firmware_class: Split _request_firmware() into three functions, v2 Rafael J. Wysocki
2012-03-28 21:22 ` [PATCH v3 3/8] firmware_class: Do not warn that system is not ready from async loads Rafael J. Wysocki
2012-03-28 21:23 ` [PATCH v2 4/8] PM / Hibernate: Disable usermode helpers right before freezing tasks Rafael J. Wysocki
2012-03-28 21:23 ` [PATCH v2 5/8] PM / Sleep: Move disabling of usermode helpers to the freezer Rafael J. Wysocki
2012-03-28 21:24 ` [PATCH v2 6/8] PM / Sleep: Mitigate race between the freezer and request_firmware() Rafael J. Wysocki
2012-03-28 21:25 ` [PATCH v2 7/8] firmware_class: Reorganize fw_create_instance() Rafael J. Wysocki
2012-03-28 21:26 ` [PATCH v2 8/8] firmware_class: Move request_firmware_nowait() to workqueues Rafael J. Wysocki
2012-03-14 23:19 ` [PATCH] firmware loader: don't cancel _nowait requests when helper is not yet available Rafael J. Wysocki
2012-03-13 19:42 ` Rafael J. Wysocki
2012-03-13 23:25 ` Kay Sievers
2012-03-14 0:10 ` Rafael J. Wysocki
2012-03-14 0:14 ` Kay Sievers
2012-03-14 0:54 ` Linus Torvalds
2012-03-14 1:43 ` Kay Sievers
2012-03-14 1:51 ` Linus Torvalds
2012-03-14 1:55 ` Kay Sievers
2012-03-14 2:00 ` Kay Sievers
2012-03-14 2:21 ` Linus Torvalds
2012-03-14 15:07 ` Srivatsa S. Bhat
2012-03-14 22:54 ` Rafael J. Wysocki
2012-03-16 7:14 ` Srivatsa S. Bhat
2012-03-16 20:23 ` Rafael J. Wysocki
2012-03-16 21:14 ` Christian Lamparter
2012-03-16 21:19 ` Linus Torvalds
2012-03-19 7:06 ` Srivatsa S. Bhat
2012-03-16 22:19 ` [RFC] firmware loader: retry _nowait requests when userhelper " Rafael J. Wysocki
2012-03-16 22:25 ` Christian Lamparter
2012-03-16 22:57 ` Rafael J. Wysocki
2012-03-16 23:35 ` Christian Lamparter
2012-03-16 23:37 ` Linus Torvalds
2012-03-17 0:23 ` Rafael J. Wysocki
2012-03-17 0:33 ` Linus Torvalds
2012-03-18 0:29 ` Rafael J. Wysocki
2012-03-18 2:21 ` Linus Torvalds
2012-03-18 12:21 ` Rafael J. Wysocki
2012-03-18 12:43 ` Christian Lamparter
2012-03-18 23:15 ` [PATCH 0/3] firmware_class: Fix problem with async requests (was: Re: [RFC] firmware loader: retry ...) Rafael J. Wysocki
2012-03-18 23:17 ` [PATCH 1/3] firmware_class: Rework usermodehelper check Rafael J. Wysocki
2012-03-18 23:18 ` [PATCH 2/3] firmware_class: Split _request_firmware() into three functions Rafael J. Wysocki
2012-03-18 23:21 ` [PATCH 3/3] firmware_class: Do not warn that system is not ready for async loads Rafael J. Wysocki
2012-03-19 12:41 ` [RFC] firmware loader: retry _nowait requests when userhelper is not yet available James Courtier-Dutton
Reply instructions:
You may reply publicly to this message via plain-text email
using any one of the following methods:
* Save the following mbox file, import it into your mail client,
and reply-to-all from there: mbox
Avoid top-posting and favor interleaved quoting:
https://en.wikipedia.org/wiki/Posting_style#Interleaved_style
* Reply using the --to, --cc, and --in-reply-to
switches of git-send-email(1):
git send-email \
--in-reply-to=4F724722.2000202@codeaurora.org \
--to=sboyd@codeaurora.org \
--cc=alan@lxorguk.ukuu.org.uk \
--cc=chunkeey@googlemail.com \
--cc=gregkh@linuxfoundation.org \
--cc=kay.sievers@vrfy.org \
--cc=linux-kernel@vger.kernel.org \
--cc=linux-pm@vger.kernel.org \
--cc=rjw@sisk.pl \
--cc=skannan@codeaurora.org \
--cc=srivatsa.bhat@linux.vnet.ibm.com \
--cc=tj@kernel.org \
--cc=torvalds@linux-foundation.org \
/path/to/YOUR_REPLY
https://kernel.org/pub/software/scm/git/docs/git-send-email.html
* If your mail client supports setting the In-Reply-To header
via mailto: links, try the mailto: link
Be sure your reply has a Subject: header at the top and a blank line
before the message body.
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
Powered by JetHome