mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v2 0/2] cpuacct: rename parameter in cpuusage_write for readability
@ 2016-03-04  9:47 Zhao Lei
  2016-03-04  9:47 ` [PATCH v2 1/2] " Zhao Lei
  2016-03-04  9:47 ` [PATCH v2 2/2] cpuacct: split usage into user_usage and sys_usage Zhao Lei
  0 siblings, 2 replies; 6+ messages in thread
From: Zhao Lei @ 2016-03-04  9:47 UTC (permalink / raw)
  To: zhaolei, cgroups, linux-kernel, mingo, peterz, tj

The name of 'reset' makes a little confusion in reading, we would
say, if we want to reset usage, return -EINVAL. That's not true.

Actually, we want to say, we only allow user to do a reset. This
patch rename reset to val and add a comment here, making the code
more readable.

Changelog v1->v2:
1: Rebase on top of 4.5-rc6
2: Fix little spelling typo in description.
3: Fix line over 80 characters
4: Add Acked-by: Tejun Heo <tj@kernel.org>

Yang Dongsheng (2):
  cpuacct: rename parameter in cpuusage_write for readability
  cpuacct: split usage into user_usage and sys_usage.

 kernel/sched/cpuacct.c | 151 ++++++++++++++++++++++++++++++++++++++++++-------
 1 file changed, 129 insertions(+), 22 deletions(-)

-- 
1.8.5.1

^ permalink raw reply	[flat|nested] 6+ messages in thread

end of thread, other threads:[~2016-03-16 10:41 UTC | newest]

Thread overview: 6+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2016-03-04  9:47 [PATCH v2 0/2] cpuacct: rename parameter in cpuusage_write for readability Zhao Lei
2016-03-04  9:47 ` [PATCH v2 1/2] " Zhao Lei
2016-03-11 17:42   ` Tejun Heo
2016-03-04  9:47 ` [PATCH v2 2/2] cpuacct: split usage into user_usage and sys_usage Zhao Lei
2016-03-10 13:27   ` Peter Zijlstra
2016-03-16 10:39     ` Zhao Lei

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®