mirror of https://lore.kernel.org/lkml/
 help / color / mirror / Atom feed
* [PATCH v3 0/3] replace 'selftest' with 'unittest' and update the document.
@ 2015-03-17  3:19 Wang Long
  2015-03-17  3:19 ` [PATCH v3 1/3] of/unittest: replace 'selftest' with 'unittest' Wang Long
                   ` (2 more replies)
  0 siblings, 3 replies; 7+ messages in thread
From: Wang Long @ 2015-03-17  3:19 UTC (permalink / raw)
  To: gaurav.minocha.os, robherring2, pantelis.antoniou, grant.likely
  Cc: pawel.moll, mark.rutland, galak, devicetree, linux-kernel,
	peifeiyue, long.wanglong, ijc+devicetree

This series patches replace 'selftest' with 'unittest' in the 
OF unittest, and update the document.

the first patch comes from Gaurav Minocha, and i update it. because
it can not apply on linux 4.0-rc4 when using 'git am' command.


* v3 <- v2:
	- Rebase the patch on 4.0-rc4
	- Re-adjust the sequence of the patches

* v2 <- v1:
	- According to Gaurav's advice. make the rename
	file patch correctly.

Wang Long (3):
  of/unittest: replace 'selftest' with 'unittest'
  Documentation: rename of_selftest.txt to of_unittest.txt
  Documentation: update the of_unittest.txt

 Documentation/devicetree/bindings/unittest.txt     |  44 +-
 .../{of_selftest.txt => of_unittest.txt}           |  35 +-
 drivers/of/unittest-data/tests-overlay.dtsi        | 108 ++--
 drivers/of/unittest.c                              | 706 ++++++++++-----------
 4 files changed, 447 insertions(+), 446 deletions(-)
 rename Documentation/devicetree/{of_selftest.txt => of_unittest.txt} (87%)

-- 
1.8.3.4


^ permalink raw reply	[flat|nested] 7+ messages in thread

end of thread, other threads:[~2015-03-28 12:04 UTC | newest]

Thread overview: 7+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2015-03-17  3:19 [PATCH v3 0/3] replace 'selftest' with 'unittest' and update the document Wang Long
2015-03-17  3:19 ` [PATCH v3 1/3] of/unittest: replace 'selftest' with 'unittest' Wang Long
2015-03-28  4:09   ` Grant Likely
2015-03-17  3:19 ` [PATCH v3 2/3] Documentation: rename of_selftest.txt to of_unittest.txt Wang Long
2015-03-28  4:11   ` Grant Likely
2015-03-17  3:20 ` [PATCH v3 3/3] Documentation: update the of_unittest.txt Wang Long
2015-03-28  4:11   ` Grant Likely

This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox

all inboxes | Powered by JetHome®