* kmemleak_scan_area
@ 2010-03-31 10:00 Sachin Pandhare
2010-03-31 10:10 ` kmemleak_scan_area Sachin Pandhare
2010-03-31 12:06 ` kmemleak_scan_area Catalin Marinas
0 siblings, 2 replies; 4+ messages in thread
From: Sachin Pandhare @ 2010-03-31 10:00 UTC (permalink / raw)
To: Linux Kernel Mailing List; +Cc: Sachin
Hi Catalin,
In kmemleak.c file "kmemleak_scan_area" is appearing as a structure as
well as a function.
e.g.:
- struct kmemleak_scan_area_node {
- void __ref kmemleak_scan_area(const void *ptr, size_t size, gfp_t gfp)
Do you think it is a good to have it like that?
regards,
Sachin
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: kmemleak_scan_area
2010-03-31 10:00 kmemleak_scan_area Sachin Pandhare
@ 2010-03-31 10:10 ` Sachin Pandhare
2010-03-31 12:06 ` kmemleak_scan_area Catalin Marinas
1 sibling, 0 replies; 4+ messages in thread
From: Sachin Pandhare @ 2010-03-31 10:10 UTC (permalink / raw)
To: Linux Kernel Mailing List; +Cc: Sachin
Sorry, corrected myself in the code snippet
struct kmemleak_scan_area {
instead of
struct kmemleak_scan_area_node {
On Wed, Mar 31, 2010 at 3:30 PM, Sachin Pandhare
<sachinpandhare@gmail.com> wrote:
> Hi Catalin,
> In kmemleak.c file "kmemleak_scan_area" is appearing as a structure as
> well as a function.
> e.g.:
> - struct kmemleak_scan_area {
> - void __ref kmemleak_scan_area(const void *ptr, size_t size, gfp_t gfp)
>
> Do you think it is a good to have it like that?
>
> regards,
> Sachin
>
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: kmemleak_scan_area
2010-03-31 10:00 kmemleak_scan_area Sachin Pandhare
2010-03-31 10:10 ` kmemleak_scan_area Sachin Pandhare
@ 2010-03-31 12:06 ` Catalin Marinas
2010-03-31 12:10 ` kmemleak_scan_area Sachin Pandhare
1 sibling, 1 reply; 4+ messages in thread
From: Catalin Marinas @ 2010-03-31 12:06 UTC (permalink / raw)
To: Sachin Pandhare; +Cc: Linux Kernel Mailing List
Sachin Pandhare <sachinpandhare@gmail.com> wrote:
> In kmemleak.c file "kmemleak_scan_area" is appearing as a structure as
> well as a function.
> e.g.:
> - struct kmemleak_scan_area {
> - void __ref kmemleak_scan_area(const void *ptr, size_t size, gfp_t gfp)
>
> Do you think it is a good to have it like that?
Does it cause any problems? I think C has different namespaces for types
and functions, so they should not collide. I agree that from a
readability perspective, it would be better if they are named
differently (like kmemleak_scan_area_node :)).
--
Catalin
^ permalink raw reply [flat|nested] 4+ messages in thread
* Re: kmemleak_scan_area
2010-03-31 12:06 ` kmemleak_scan_area Catalin Marinas
@ 2010-03-31 12:10 ` Sachin Pandhare
0 siblings, 0 replies; 4+ messages in thread
From: Sachin Pandhare @ 2010-03-31 12:10 UTC (permalink / raw)
To: Catalin Marinas; +Cc: Linux Kernel Mailing List
On Wed, Mar 31, 2010 at 5:36 PM, Catalin Marinas
<catalin.marinas@arm.com> wrote:
> Sachin Pandhare <sachinpandhare@gmail.com> wrote:
>> In kmemleak.c file "kmemleak_scan_area" is appearing as a structure as
>> well as a function.
>> e.g.:
>> - struct kmemleak_scan_area {
>> - void __ref kmemleak_scan_area(const void *ptr, size_t size, gfp_t gfp)
>>
>> Do you think it is a good to have it like that?
>
> Does it cause any problems? I think C has different namespaces for types
> and functions, so they should not collide. I agree that from a
> readability perspective, it would be better if they are named
> differently (like kmemleak_scan_area_node :)).
It has not caused any problem.
Thanks,
>
> --
> Catalin
^ permalink raw reply [flat|nested] 4+ messages in thread
end of thread, other threads:[~2010-03-31 12:10 UTC | newest]
Thread overview: 4+ messages (download: mbox.gz / follow: Atom feed)
-- links below jump to the message on this page --
2010-03-31 10:00 kmemleak_scan_area Sachin Pandhare
2010-03-31 10:10 ` kmemleak_scan_area Sachin Pandhare
2010-03-31 12:06 ` kmemleak_scan_area Catalin Marinas
2010-03-31 12:10 ` kmemleak_scan_area Sachin Pandhare
This is a public inbox, see mirroring instructions
for how to clone and mirror all data and code used for this inbox
all inboxes | Powered by JetHome®